Internal Error

83 views
Skip to first unread message
Assigned to ewpa...@gmail.com by aget...@gmail.com

Ray Weber

unread,
Jul 31, 2019, 8:56:58 AM7/31/19
to MIT App Inventor Forum
Hello World,

since today I get always the same error when clicking in the blocks on an item at the left side. 

I can send a report which contains: 

notes = Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.142 Safari/537.36
foundIn = nb178
faultData = com.google.gwt.core.client.JavaScriptException: (TypeError) : Cannot read property 'pb' of undefined
projectId = 5302582422142976

I use Windows 10, nothing was changed. I can not work on, really confused.

Is there anybody who could help me?

Cheers, Ray
Error1.jpg

s un

unread,
Jul 31, 2019, 9:15:32 AM7/31/19
to MIT App Inventor Forum
i have same issue

i think when screen name has _
popup that massage
change screen name

Sandeep V. Menon

unread,
Jul 31, 2019, 10:29:18 AM7/31/19
to MIT App Inventor Forum
I too am experiencing the same issue from morning today onwards (IST)
A change I noticed is that the the "Options" for Built-In sections of Blocks are appearing despite the Error message popping up, while the there is no options appearing for the blocks I had put and the error message persists.

ABG

unread,
Jul 31, 2019, 1:02:23 PM7/31/19
to MIT App Inventor Forum
AI2 was updated to nb178 yesterday.

Which web browser are you using?

What add-ons does it use?

for some things to try.

ABG
Clear cached images and files.PNG

ABG

unread,
Jul 31, 2019, 1:33:45 PM7/31/19
to MIT App Inventor Forum
(assigned to Evan Patton)
(added to App Inventor Issues section of FAQ)
ABG

Ray Weber

unread,
Aug 1, 2019, 9:29:54 AM8/1/19
to MIT App Inventor Forum
Hello ABG and all others,

thank you for your help. I use Chrome and FF. The problem is the same in both browsers. No adds.

Now I will try the idea of SUN. I reply agagin in a few days.
Ray

Evan Patton

unread,
Aug 1, 2019, 2:39:06 PM8/1/19
to MIT App Inventor Forum
Hi Ray,

May I have permission to access your account? If so, I can take a look at your project and try to determine what is causing the internal error.

Regards,
Evan

Ray Weber

unread,
Aug 1, 2019, 5:37:30 PM8/1/19
to MIT App Inventor Forum
Thank you all for helping. I think the problem is solved. The User SUN was maybe right. There should not be an underscore ( _ ) in the name of a screen.
I had created the project new, screennames without underscore. In the moment it seems, that there is no more error.
Ray

Chathuranga W

unread,
Aug 9, 2019, 11:38:09 AM8/9/19
to MIT App Inventor Forum
Is there a way to remove '_' in existing projects

BodyMindPower

unread,
Aug 9, 2019, 12:28:04 PM8/9/19
to MIT App Inventor Forum
Reply all
Reply to author
Forward
0 new messages