EEPROM IC - DAQ v3.3

43 views
Skip to first unread message

Forest FOSP8218

unread,
Oct 6, 2021, 4:11:14 PMOct 6
to Miniscope
Hello, 

I am helping assist a researcher at CU Anschutz with the assembly of a Miniscope V4 system with a v3.3 DAQ. We are receiving an error that "Miniscope retrieve frame failed." After reading the post included below, I assumed the solution may be to update the firmware on the DAQ. However, when I took a look at the PCB it seems the EEPROM IC that would normally go on U5 is missing. My understanding is that this is the memory where the firmware is stored. Was an EEPROM IC supposed to be included for the PCB, or has that been bypassed in the DAQ v3.3.? I have included a picture of our PCB. 

IMG_3765.jpg


Thank You,
Forest 

Federico Sangiuliano

unread,
Oct 6, 2021, 4:20:23 PMOct 6
to Miniscope
Hello Forest. The unpopulated IC socket in your picture is for the previous 128k EEPROM. For your DAQ you will need the "Miniscope_DAQ_256K_EEPROM.img" file found here

Thank you

Federico

Daniel Aharoni

unread,
Oct 6, 2021, 5:37:41 PMOct 6
to Miniscope
Hi Forest,
As Federico mentioned, that unpopulated socket is there sort of as a backwards compatibility options for the EEPROM. On your version of DAQ board, there is a 256K EEPROM just the the left of the circle you drew.

This version of the PCB, I think it is from OEPS, should already have up-to-date firmware on it. Just to make sure, are you using this version of the newer Miniscope DAQ software: https://github.com/Aharoni-Lab/Miniscope-DAQ-QT-Software/releases/tag/v1.11?

xiaoyu peng

unread,
Oct 6, 2021, 5:50:01 PMOct 6
to Daniel Aharoni, Miniscope
Hi, Daniel and Federico,

Thank you for getting back to us.  I am the neurobiologist working with Forest.  Yes,  I've installed the v1.11 DAQ software.  The DAQ board is from open ephys,  the v4 scope and its coax cable are from lab marker. 

best,

Xiaoyu

--
You received this message because you are subscribed to the Google Groups "Miniscope" group.
To unsubscribe from this group and stop receiving emails from it, send an email to miniscope+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/miniscope/b4282f91-ddc3-4f8b-aa9c-0701a5602e5cn%40googlegroups.com.

Daniel Aharoni

unread,
Oct 6, 2021, 5:56:03 PMOct 6
to Miniscope
Hi Xiaoyu,
That configuration of software and devices should work without issue.

Does the red LED on the Miniscope turn on? Do all 3 green LEDs on the DAQ PCB turn on?

Do you only have 1 DAQ and 1 Miniscope to test or does this issue persist across different combinations of DAQs and Miniscopes?

xiaoyu peng

unread,
Oct 6, 2021, 6:03:29 PMOct 6
to Daniel Aharoni, Miniscope
Hi, Daniel,

The red light on miniscope is on,  the three lights on DAQ is on.  The LED on the scope doesn't seem to be on,  I couldn't see any blue light coming from it.  I checked the coax cable and didn't detect shorts from either end.  Other trouble shooting,  we are still trying to see what we can test. 

Xiaoyu

xiaoyu peng

unread,
Oct 8, 2021, 5:47:43 PMOct 8
to Miniscope
We tried another computer, it works;  We then updated the computer usb drivers and also changed to another USB port (the previous USB port we used was used for miniscope V3 though),  now it also works.  Thank you all for your support!  Excited to move on to mice then! --Xiaoyu
Reply all
Reply to author
Forward
0 new messages