bash: majiq: command not found

44 views
Skip to first unread message

Yilu Zhou

unread,
Jul 5, 2021, 3:08:20 PMJul 5
to majiq_voila

Hi,

I think I have successfully installed MAJIQ in hpc. However, it says 'majiq:command not found' when I used majiq build.

Any idea about this?

Kind regards,

Lu

---------------------------------------------------------------------------------------------------

(py38) [cyan01 MAJIQ]$ pip install git+https://bitbucket.org/biociphers/majiq_academic.git#egg=majiq

Collecting majiq

  Cloning https://bitbucket.org/biociphers/majiq_academic.git to /tmp/pip-install-7dm6ow6v/majiq_87457384938e405884544fe5c703806a

  Running command git clone -q https://bitbucket.org/biociphers/majiq_academic.git /tmp/pip-install-7dm6ow6v/majiq_87457384938e405884544fe5c703806a

Requirement already satisfied: Click==7.0 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (7.0)

Requirement already satisfied: Cython==0.29.14 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (0.29.14)

Requirement already satisfied: Flask==1.0.2 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (1.0.2)

Requirement already satisfied: Flask-Session==0.3.1 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (0.3.1)

Requirement already satisfied: Flask-WTF==0.14.2 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (0.14.2)

Requirement already satisfied: gitdb2==2.0.6 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (2.0.6)

Requirement already satisfied: GitPython==3.0.5 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (3.0.5)

Requirement already satisfied: gunicorn==19.9.0 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (19.9.0)

Requirement already satisfied: h5py==2.10.0 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (2.10.0)

Requirement already satisfied: itsdangerous==1.1.0 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (1.1.0)

Requirement already satisfied: Jinja2==2.11.1 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (2.11.1)

Requirement already satisfied: MarkupSafe==1.1.1 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (1.1.1)

Requirement already satisfied: numpy==1.18.1 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (1.18.1)

Requirement already satisfied: psutil==5.6.7 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (5.6.7)

Requirement already satisfied: scipy==1.4.1 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (1.4.1)

Requirement already satisfied: six==1.14.0 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (1.14.0)

Requirement already satisfied: smmap2==2.0.5 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (2.0.5)

Requirement already satisfied: waitress==1.1.0 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (1.1.0)

Requirement already satisfied: Werkzeug==0.16.0 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (0.16.0)

Requirement already satisfied: WTForms==2.2.1 in /home/.conda/envs/py38/lib/python3.8/site-packages (from majiq) (2.2.1)

Building wheels for collected packages: majiq

  Building wheel for majiq (setup.py) ... done

  Created wheel for majiq: filename=majiq-2.2-py3-none-any.whl size=12148701 sha256=08285067d2f30fad4910b3542347c8b4625a99409d057e03bcfa083fcb615551

  Stored in directory: /tmp/pip-ephem-wheel-cache-hs7u9wx3/wheels/19/4e/94/a6b19e9ddcd68d486f25f04b766592ce28f1ca71fe509a8a91

Successfully built majiq

Installing collected packages: majiq

Successfully installed majiq-2.2


(py38) [cyan01 MAJIQ]$ majiq

-bash: majiq: command not found

Yilu Zhou

unread,
Jul 6, 2021, 6:06:54 AMJul 6
to majiq_voila
I think MAJIQ will not work in the environment created by Conda.
This problem has been solved since I re-installed it in a python3.7 environment in the HPC.

BTW, running MAJiQ in Mac will lead to 'Segmentation fault: 11'. It happens in my two separate laptops.
Although Nicholas found a way to deal with it (https://groups.google.com/g/majiq_voila/c/G4C2kO95yg4/m/UW4SN-8gCgAJ)
I still hope it will be solved in the next version of MAJIQ.

Kind regards,
Lu

Reply all
Reply to author
Forward
0 new messages