Segmentation fault: 11 on macOSm mojave 10.14.5

84 views
Skip to first unread message

Nicolas Gomez

unread,
Jul 31, 2019, 6:32:22 PM7/31/19
to majiq_voila
Hi majiq team,

I am trying to use Majiq Build v2.1-c3da3ce on a mac book pro and keep getting a "Segmentation fault: 11" error while on the "Parsing GFF3" step. The command I am using is:

majiq build /path/to/gencode.v31.primary_assembly.annotation.gff3 -c /path/to/configure_file -o /path/to/MAJIQ_output/ --logger /path/to/MAJIQ_output/


The Python process crashes after reaching around 700MB of memory... I have 32GB


What other information can I provide to help troubleshoot this issue?


Thanks,

Nico


Nicolas Gomez

unread,
Aug 3, 2019, 10:32:40 AM8/3/19
to majiq_voila
Update: I realized that supplying the compressed gff (.gff.gz) produces a completely different error copied below:

Traceback (most recent call last):

  File "/usr/local/bin/majiq", line 10, in <module>

    sys.exit(main())

  File "/usr/local/lib/python3.7/site-packages/majiq/run_majiq.py", line 204, in main

    args.func(args)

  File "majiq/src/build.pyx", line 520, in majiq.src.build.build

  File "/usr/local/lib/python3.7/site-packages/majiq/src/basic_pipeline.py", line 11, in pipeline_run

    return pipeline.run()

  File "majiq/src/build.pyx", line 530, in majiq.src.build.Builder.run

  File "majiq/src/build.pyx", line 538, in majiq.src.build.Builder.builder

  File "majiq/src/build.pyx", line 458, in majiq.src.build._core_build

  File "majiq/src/io.pyx", line 51, in majiq.src.io.read_gff

  File "/usr/local/lib/python3.7/site-packages/majiq/src/gff.py", line 48, in parse_gff3

    if line.startswith("#"):

TypeError: startswith first arg must be bytes or a tuple of bytes, not str



I have also attached the pip install log which *i think* shows a pretty uneventful installation.

Thank you,
Nico
pipinstalllog.txt

Nicolas Gomez

unread,
Aug 3, 2019, 12:20:13 PM8/3/19
to majiq_voila
Ok. Nevermind, this is a separate issue that I solved by specifying the gzip read mode to "str" by modifying the .../env/lib/python3.7/site-packages/majiq/src/gff.py file line 44:
with open_func(filename, mode="rt") as infile:

Now when I rerun majiq, I get the seg fault error that I originally posted about. I am certain that the gff.py file is successfully iterating through the supplied annotation file. So, I'm still quite lost. I have attached my config file as well
MAJIQ_Kate_configure

Jordi Vaquero

unread,
Aug 3, 2019, 1:47:57 PM8/3/19
to Nicolas Gomez, majiq_voila

Hi,

Please can you try running without the logger option?

 

Thanks

jordi

--
You received this message because you are subscribed to the Google Groups "majiq_voila" group.
To unsubscribe from this group and stop receiving emails from it, send an email to majiq_voila...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/majiq_voila/cbe1d227-a015-443f-a8b6-9bb633442c2e%40googlegroups.com.

Nicolas Gomez

unread,
Aug 8, 2019, 10:23:45 PM8/8/19
to majiq_voila
I'm attaching the crash report. Perhaps someone else is having a similar experience.

Nico

To unsubscribe from this group and stop receiving emails from it, send an email to majiq...@googlegroups.com.

Python_2019-08-08-222053_claude.crash

Nicolas Gomez

unread,
Aug 10, 2019, 1:07:39 PM8/10/19
to majiq_voila
I imported faulthandler in basic_pipeline.py, run_majiq.py, and gff.py as was suggested by this blog to learn more about the segfault. Ran majiq as follows:

python -Xfaulthandler /usr/local/lib/python3.7/site-packages/majiq/run_majiq.py build ...


Fatal Python error: Segmentation fault


Current thread 0x000000011846d5c0 (most recent call first):

  File "/usr/local/lib/python3.7/site-packages/majiq/src/basic_pipeline.py", line 12 in pipeline_run

  File "/usr/local/lib/python3.7/site-packages/majiq/run_majiq.py", line 205 in main

  File "/usr/local/lib/python3.7/site-packages/majiq/run_majiq.py", line 209 in <module>

Segmentation fault: 11


Although this doesn't tell me much, it did change the crash report (see attached) and it points to the pipeline_run function in basic_pipeline.py as a potential source. Unfortunately pipeline_run doesn't contain much in the way of seg fault red flags. :/w

Nico
Python_2019-08-10-125809_claude.crash

Jordi Vaquero

unread,
Aug 12, 2019, 9:46:23 PM8/12/19
to Nicolas Gomez, majiq_voila

Hello Nico,

Sorry for the delay, I have been out for some time. I will take a look at what you sent me and come back to you tomorrow

 

Jordi

To unsubscribe from this group and stop receiving emails from it, send an email to majiq_voila...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/majiq_voila/83761f64-527e-4ee1-9c49-8715344771db%40googlegroups.com.

Message has been deleted

Nicolas Gomez

unread,
Jan 8, 2020, 12:00:07 PM1/8/20
to majiq_voila
Hi Jordi,

I'm just copying my recent email to you here:

After about 3 months of on and off troubleshooting, I got Majiq to work on my Mac. Here are the things I did:

- recompiled GCC9.2 following this protocol: https://solarianprogrammer.com/2019/10/12/compiling-gcc-macos/
- I think this was the most important step
- uninstalled homebrew and all homebrew installed packages
- this included ALL other compilers and symbolic links
- uninstalled all non-OS-installed python versions and packages
- including 3.8
- reinstalled python3.7 and homebrew (to manage readline and some other dependencies)

Finally I updated my .bash_profile to use all of the above. Majiq and Voila compiled without error and build, psi, and delta psi functions worked without any problems. I did have to change line 419 in Voila's view_matrix.py file to allow LSV text copying function.

I hope this helps other MacOS users. Note: I did stupidly update to MacOS Catalina but I think following the Mojave GCC9 compilation protocol here is the only change you'd have to make to get this to work.

Cheers,
Nico


Paul Jewell

unread,
Jan 8, 2020, 1:12:42 PM1/8/20
to majiq_voila
Hi Nicholas, 

I (and likely some other worldwide visitors) appreciate your solution description. Thanks for coming back with the solution you found!

-Paul
Reply all
Reply to author
Forward
0 new messages