Tabular Data File Ingest Error

64 views
Skip to first unread message

Philipp at UiT

unread,
Jun 4, 2020, 6:37:18 AM6/4/20
to Dataverse Users Community
The following error message is displayed in a warning triangle after a depositor has uploaded a csv file:

Upload Competed with Errors: Tabular data ingest failed. Reading mismatch, line 2375 of the Data file: 1 delimited values expected, 2 found.

We have experienced similar error messages about data ingest failure in other datasets. I've tried to figure out what could be wrong in line 2375 (and 2374 and 2376), but cannot find any issues. Also, when I upload the tabular data as an Excel file, the file is successfully ingested.

Phil: If you want to have a look at the files, they are in this dataset:

Best, Philipp

Philip Durbin

unread,
Jun 4, 2020, 2:24:17 PM6/4/20
to dataverse...@googlegroups.com
I looked at your dataset_main_model.csv and the first thing that struck me is that it's semicolon-separated, as we've discussed previously[1].

My theory from playing around a bit in CSVFileReader.java is that the error is a red herring and that the problem is the semicolons. I played around with inFormat = CSVFormat.newFormat(';') and at least got the file to print out[2]. Please feel free to create a GitHub issue about semicolon support.

I'm glad to hear the Excel format worked, at least!

Phil

p.s. If you'd like to give us a public file to test with, https://github.com/IQSS/dataverse-sample-data is a good place. The demo server is fine but we reserve the right to clean it out from time to time. :)

2. From CSVFileReaderTest.java.

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dataverse-community/6cddef71-4d36-478b-850e-0edab204f854%40googlegroups.com.


--
Reply all
Reply to author
Forward
0 new messages