CommCare ODK Crashing

19 views
Skip to first unread message

James Tinkamanyire

unread,
Jun 23, 2015, 2:01:53 AM6/23/15
to commcar...@googlegroups.com
Hi CommCare Users,

We have this error that periodically pops up in the middle of an interview and the mobile workers have to login again and start afresh. It's quite annoying and time wasting. Has anyone encountered this error "Unfortunately, CommCare ODK has stopped" When I try to report a problem from the error pop-up, I am redirected to reporting a bug to Google instead.

Need some help.

Thanks,
James

Charles Flèche

unread,
Jun 23, 2015, 4:48:55 AM6/23/15
to commcar...@googlegroups.com, James Tinkamanyire
Dear James,

First thing to check is if you are running the latest version of CommCare. You
can check it at the bottom of CommCareODK's home screen.

If your version is not 2.21.0 I suggest you update and retry. Does the crash
still occur ?

Regards,

Charles


On Monday, June 22, 2015 11:01:52 PM James Tinkamanyire wrote:
> Hi CommCare Users,
>
> We have this error that periodically pops up in the middle of an interview
> and the mobile workers have to login again and start afresh. It's quite
> annoying and time wasting. Has anyone encountered this error
> *"Unfortunately, CommCare ODK has stopped"* When I try to report a problem

James Tinkamanyire

unread,
Jun 23, 2015, 4:53:54 AM6/23/15
to commcar...@googlegroups.com
Hey Charles,

We are running CommCare ODK version 2.21.0 and CC version 2.21. The error still appears. Should it be something in Google settings? Because the when I try to report an error from the pop up, I am redirecting to Google's Report a bug form

Thanks,
James

--
You received this message because you are subscribed to a topic in the Google Groups "commcare-users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/commcare-users/w-ZFrRkphbs/unsubscribe.
To unsubscribe from this group and all its topics, send an email to commcare-user...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
-----------
James Tinkamanyire | Data Manager
Measuring Early Treatment Adherence - META Project
Global Health Collaborative - MUST - Uganda

P.O. Box 1397, Mbarara.

BSc Computer Engineering
MBARARA UNIVERSITY OF SCIENCE & TECHNOLOGY
P.O. Box 1410, Mbarara, Uganda.

Mobile Tel: +256 (0)702 864 964
Skype: jimmyjaymes1


Charles Flèche

unread,
Jun 23, 2015, 5:03:22 AM6/23/15
to commcar...@googlegroups.com
A rogue Google settings seems unlikely. What device are you running
CommCareODK on ? What Android version ? Can you consistently recreate the
issue ? It could be an error in your form that is only triggered at run-time
(like a bad string concatenation or something like that).

James Tinkamanyire

unread,
Jun 23, 2015, 5:06:16 AM6/23/15
to commcar...@googlegroups.com
We are using Nexus 7, Android Version 5.1.1. This error actually happened to all the 5 tablets we were using during our training, at the same time. Weird!

Charles Flèche

unread,
Jun 23, 2015, 5:18:02 AM6/23/15
to commcar...@googlegroups.com
Does the crash happen at a specific question in your form ?
Have you tried a on a different device (your own smartphone for example) ?

James Tinkamanyire

unread,
Jun 23, 2015, 5:22:18 AM6/23/15
to commcar...@googlegroups.com
It's not really consistently happening at a specific question or form. It occurs randomly and at different times.

Charles Flèche

unread,
Jun 23, 2015, 5:27:22 AM6/23/15
to commcar...@googlegroups.com
OK, so your application seems not to be the issue here. Now we need to tie
down the problem to either CommCareODK itself or the device you are using. In
order to do that you should try your app on a different device and see it
still crashes.

James Tinkamanyire

unread,
Jun 23, 2015, 5:31:02 AM6/23/15
to commcar...@googlegroups.com
OK, great. I just checked my Application settings on HQ and I see that the CC version is set to 2.20. we are running version 2.21.0 on the tablets. So may be I need to change this to v2.21.0 on HQ?

Charles Flèche

unread,
Jun 23, 2015, 5:42:33 AM6/23/15
to commcar...@googlegroups.com
It worths a try for sure: if the crash vanishes after this change you just
found a bug in CommCare that the dev team would be happy to hear about.

If the crash still persists, let's try on another device.

James Tinkamanyire

unread,
Jun 23, 2015, 5:52:00 AM6/23/15
to commcar...@googlegroups.com
Cool. Thanks, Charles! Will get you feedback after a while.

James Tinkamanyire

unread,
Jun 23, 2015, 5:53:29 AM6/23/15
to commcar...@googlegroups.com
Oh, one more question -- do I need to make a New Version after changing this setting?

Charles Flèche

unread,
Jun 23, 2015, 6:17:13 AM6/23/15
to commcar...@googlegroups.com
I don't think so, but I'm not 100% sure about this one. It probably won't hurt
to make a new version though.

William Pride

unread,
Jun 23, 2015, 8:03:44 AM6/23/15
to commcar...@googlegroups.com
James,

As Charles suggests, its always helpful to be using the most recent version of CommCare as we often resolve crashes in new builds. However, 2.21 is the most recent currently released version on the Play Store and so is the most recent version available - the version setting on CommCareHQ is more aptly described as "the minimum version to require to run this CommCare application" so changing this won't cause you to update version on its own.

If you continue to see the crash, please click the "Report and Issue" button that Android prompts you with, then enter something useful like your name in the dialog box. Then, please report a bug to us directly and indicate that you've submitted a crash report via Android and we can take a look. Its also very helpful if you can provide steps that consistently replicate the bug.

Thanks,
Will



You received this message because you are subscribed to the Google Groups "commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to commcare-user...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages