Building Gingerbread on OS X Lion

3343 views
Skip to first unread message

yasuyuki

unread,
Jul 26, 2011, 6:47:36 AM7/26/11
to Android Building
Hi.

I try to build Gingerbread on OS X Lion(10.7).

I got these error message.

[CODE]
Please install the 10.5 SDK on this machine at /Developer/SDKs/
MacOSX10.5.sdk
external/qemu/Makefile.android:75: *** Aborting the build.. Stop.
[/CODE]

I edit external/qemu/Makefile.android to require version 10.6 SDK and
upper,
Next, I got another error message.

[CODE]
./external/elfutils/config-compat-darwin.h:42: error: static
declaration of ‘strnlen’ follows non-static declaration
/usr/include/string.h:143: error: previous declaration of ‘strnlen’
was here
make: *** [out/host/darwin-x86/obj/STATIC_LIBRARIES/
libelf_intermediates/lib/xstrdup.o] Error 1
[/CODE]

Has anyone built Gingerbread on OS X Lion?

thanks.

Jean-Baptiste Queru

unread,
Jul 26, 2011, 10:37:35 AM7/26/11
to android-...@googlegroups.com
I've heard multiple reports that it's broken.

If anyone has been uploading changes to fix things, please chime in.

Let's use this group (android-building) to discuss the improvements
and changes that need to be made.

Thanks,
JBQ

> --
> You received this message because you are subscribed to the "Android Building" mailing list.
> To post to this group, send email to android-...@googlegroups.com
> To unsubscribe from this group, send email to
> android-buildi...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/android-building?hl=en
>

--
Jean-Baptiste M. "JBQ" Queru
Software Engineer, Android Open-Source Project, Google.

Questions sent directly to me that have no reason for being private
will likely get ignored or forwarded to a public forum with no further
warning.

Jean-Baptiste Queru

unread,
Jul 26, 2011, 10:38:29 AM7/26/11
to android-...@googlegroups.com
Also, I should have mentioned: let's focus on the master branch. Once
we have that one working, we can focus on backporting changes as
necessary.

JBQ

Matt Reimer

unread,
Jul 27, 2011, 8:22:19 AM7/27/11
to android-...@googlegroups.com


On Tuesday, July 26, 2011 6:47:36 AM UTC-4, yasuyuki wrote:
Hi.

I try to build Gingerbread on OS X Lion(10.7).

I got these error message.


[snip]

[CODE]
./external/elfutils/config-compat-darwin.h:42: error: static
declaration of ‘strnlen’ follows non-static declaration
/usr/include/string.h:143: error: previous declaration of ‘strnlen’
was here
make: *** [out/host/darwin-x86/obj/STATIC_LIBRARIES/
libelf_intermediates/lib/xstrdup.o] Error 1
[/CODE]

I got this error while building eclair on Lion. I worked around it by wrapping strnlen() in external/elfutils/config-compat-darwin.h with #if 0. Ideally it would be wrapped with #ifdef some_darwin_version but I don't know what define to use.

Matt

yasuyuki

unread,
Jul 28, 2011, 8:46:27 AM7/28/11
to Android Building
Thank you Matt.

I edit 2 files below:

[CODE]
$ diff -u external/qemu/Makefile.android_org external/qemu/
Makefile.android
--- external/qemu/Makefile.android_org 2011-07-28 20:56:22.000000000
+0900
+++ external/qemu/Makefile.android 2011-07-28 20:58:16.000000000 +0900
@@-67,15 +67,15 @@
ifneq ($(filter 10.1 10.2 10.3 10.1.% 10.2.% 10.3.% 10.4 10.4.%,$
(DARWIN_VERSION)),)
$(error Building the Android emulator requires OS X 10.5 or above)
endif
- ifeq ($(filter 10.5 10.5.%,$(DARWIN_VERSION)),)
+ ifeq ($(filter 10.6 10.6.%,$(DARWIN_VERSION)),)
# We are on Snow Leopard or above
- LEOPARD_SDK := /Developer/SDKs/MacOSX10.5.sdk
+ LEOPARD_SDK := /Developer/SDKs/MacOSX10.6.sdk
ifeq ($(strip $(wildcard $(LEOPARD_SDK))),)
- $(info Please install the 10.5 SDK on this machine at $
(LEOPARD_SDK))
+ $(info Please install the 10.6 SDK on this machine at $
(LEOPARD_SDK))
$(error Aborting the build.)
endif
- MY_CFLAGS += -isysroot $(LEOPARD_SDK) -mmacosx-version-min=10.5 -
DMACOSX_DEPLOYMENT_TARGET=10.5
- MY_LDLIBS += -isysroot $(LEOPARD_SDK) -Wl,-syslibroot,$(LEOPARD_SDK)
-mmacosx-version-min=10.5
+ MY_CFLAGS += -isysroot $(LEOPARD_SDK) -mmacosx-version-min=10.6 -
DMACOSX_DEPLOYMENT_TARGET=10.6
+ MY_LDLIBS += -isysroot $(LEOPARD_SDK) -Wl,-syslibroot,$(LEOPARD_SDK)
-mmacosx-version-min=10.6
endif
endif
[/CODE[

[CODE]
$ diff -u external/elfutils/config-compat-darwin.h_org external/
elfutils/config-compat-darwin.h
--- external/elfutils/config-compat-darwin.h_org 2011-07-28
21:02:07.000000000 +0900
+++ external/elfutils/config-compat-darwin.h 2011-07-28
21:14:38.000000000 +0900
@@-38,6 +38,7 @@
return NULL;
}

+#if 0
static inline size_t strnlen (const char *__string, size_t __maxlen)
{
int len = 0;
@@-45,6 +46,7 @@
len++;
return len;
}
+#endif

static inline void *mempcpy (void * __dest, const void * __src, size_t
__n)
{
[/CODE]

btw, I got another error here:

[CODE]
ld: warning: ignoring file out/host/darwin-x86/obj/STATIC_LIBRARIES/
libSDL_intermediates/libSDL.a, file was built for archive which is not
the architecture being linked (i386)
Undefined symbols for architecture i386:
"_SDL_Init", referenced from:
_init_skinned_ui in main.o
"_SDL_GetError", referenced from:
_init_skinned_ui in main.o
_skin_window_resize in emulator-ui.a(window.o)
"_SDL_EnableUNICODE", referenced from:
_init_skinned_ui in main.o
_skin_keyboard_enable in emulator-ui.a(keyboard.o)
_skin_keyboard_process_event in emulator-ui.a(keyboard.o)
"_SDL_EnableKeyRepeat", referenced from:
_init_skinned_ui in main.o
_skin_keyboard_enable in emulator-ui.a(keyboard.o)
"_SDL_WM_SetIcon", referenced from:
_init_skinned_ui in main.o
"_SDL_FreeSurface", referenced from:
_init_skinned_ui in main.o
_skin_image_unref in emulator-ui.a(image.o)
_skin_image_create in emulator-ui.a(image.o)
_skin_image_clone in emulator-ui.a(image.o)
_skin_window_resize in emulator-ui.a(window.o)
_skin_window_free in emulator-ui.a(window.o)
_skin_trackball_destroy in emulator-ui.a(trackball.o)
...
"_SDL_Quit", referenced from:
_sdl_at_exit in main.o
"_SDL_PollEvent", referenced from:
_sdl_refresh in main.o
"_SDL_WM_GetPos", referenced from:
_emulator_config_done in main.o
_skin_window_toggle_fullscreen in emulator-ui.a(window.o)
_skin_window_reset in emulator-ui.a(window.o)
"_SDL_WM_GetMonitorDPI", referenced from:
_qemulator_fb_rotate in qemulator.o
"_SDL_CreateRGBSurfaceFrom", referenced from:
_sdl_surface_from_argb32 in emulator-ui.a(image.o)
_skin_image_create in emulator-ui.a(image.o)
_skin_image_clone in emulator-ui.a(image.o)
"_SDL_LockSurface", referenced from:
_skin_image_blend_clone in emulator-ui.a(image.o)
_skin_image_create in emulator-ui.a(image.o)
_display_redraw in emulator-ui.a(window.o)
_skin_trackball_refresh in emulator-ui.a(trackball.o)
_skin_scaler_scale in emulator-ui.a(scaler.o)
"_SDL_UnlockSurface", referenced from:
_skin_image_blend_clone in emulator-ui.a(image.o)
_skin_image_create in emulator-ui.a(image.o)
_display_redraw in emulator-ui.a(window.o)
_skin_trackball_refresh in emulator-ui.a(trackball.o)
_skin_scaler_scale in emulator-ui.a(scaler.o)
"_SDL_SetAlpha", referenced from:
_skin_image_blend_clone in emulator-ui.a(image.o)
"_SDL_GetTicks", referenced from:
_skin_trackball_move in emulator-ui.a(trackball.o)
"_SDL_UpperBlit", referenced from:
_display_redraw in emulator-ui.a(window.o)
_skin_window_redraw in emulator-ui.a(window.o)
_trackball_draw in emulator-ui.a(trackball.o)
_skin_trackball_draw in emulator-ui.a(trackball.o)
"_SDL_UpdateRect", referenced from:
_display_redraw in emulator-ui.a(window.o)
"_SDL_WM_GetMonitorRect", referenced from:
_skin_window_resize in emulator-ui.a(window.o)
"_SDL_SetVideoMode", referenced from:
_skin_window_resize in emulator-ui.a(window.o)
"_SDL_WM_SetPos", referenced from:
_skin_window_resize in emulator-ui.a(window.o)
_skin_window_create in emulator-ui.a(window.o)
"_SDL_FillRect", referenced from:
_skin_window_redraw in emulator-ui.a(window.o)
"_SDL_UpdateRects", referenced from:
_skin_window_redraw in emulator-ui.a(window.o)
_trackball_draw in emulator-ui.a(trackball.o)
_skin_trackball_draw in emulator-ui.a(trackball.o)
_skin_scaler_scale in emulator-ui.a(scaler.o)
"_SDL_WM_SetCaption", referenced from:
_skin_window_set_title in emulator-ui.a(window.o)
"_SDL_WM_IsFullyVisible", referenced from:
_skin_window_create in emulator-ui.a(window.o)
"_SDL_ShowCursor", referenced from:
_ball_state_show in emulator-ui.a(window.o)
"_SDL_WM_GrabInput", referenced from:
_ball_state_show in emulator-ui.a(window.o)
"_SDL_PushEvent", referenced from:
-[SDLApplication terminate:] in libSDLmain.a(SDLMain.o)
ld: symbol(s) not found for architecture i386
collect2: ld returned 1 exit status
make: *** [out/host/darwin-x86/obj/EXECUTABLES/emulator_intermediates/
emulator] Error 1
make: *** Waiting for unfinished jobs....
target StaticLib: libc_nomalloc (out/target/product/crespo/obj/
STATIC_LIBRARIES/libc_nomalloc_intermediates/libc_nomalloc.a)
??:???̓t?@?C???̑???̂????A???`?F?b?N?܂??͈??S?ł͂Ȃ????̂?????܂??B
??:?ڍׂɂ‚??ẮA-Xlint:unchecked ?I?v?V???????w?肵?čăR???p?C?????Ă????????B
libpng warning: Ignoring attempt to set cHRM RGB triangle with zero
area
libpng warning: Ignoring attempt to set cHRM RGB triangle with zero
area
[/CODE]

Francesco Donadon

unread,
Aug 11, 2011, 7:27:57 AM8/11/11
to Android Building
I'm having exactly the same problem (complaining about the wrong
architecture in Lion).

Did you manage to fix it somehow?

Francesco Donadon

unread,
Aug 12, 2011, 7:24:18 AM8/12/11
to Android Building
Some updates.

Looks like that linking error is in the libSDL prebuilt package.
Although is should be possible to just download the sources
and compile them separately in your machine, its compilation fails.

I am reporting here the error messages, although it probably would
belong to another group/discussion, in case somebody else would just
happen to know some assembler :)

/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
1168:suffix or operands invalid for `movq'
/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
1829:suffix or operands invalid for `movq'
/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
2566:suffix or operands invalid for `movq'
/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
2836:suffix or operands invalid for `movd'
/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
2934:suffix or operands invalid for `movq'
/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
3884:suffix or operands invalid for `movq'
/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
4433:suffix or operands invalid for `movq'
/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
4992:suffix or operands invalid for `movq'
/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
5207:suffix or operands invalid for `movd'
/var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:
5307:suffix or operands invalid for `movq'
make: *** [build/SDL_RLEaccel.lo] Error 1


Reverting to XCode 3 makes the (Android) compilation work again for
all but the emulator, which still fails.

Commenting out all the lines in external/qemu/Android.mk makes the
building go well until the end.

Personally I'll revert back to Snow Leopard, as I cannot afford to
work in this unstable environment.

I will go back to Lion when it will be more stable and supported.

Francesco

julius canute

unread,
Aug 16, 2011, 3:44:00 PM8/16/11
to Android Building
Is there any way to force the entire build to 32 bit?

BrandonT

unread,
Aug 17, 2011, 11:25:31 PM8/17/11
to Android Building
I've install libsdl & libsdl-devel package via ports. How do I tell
the android build process to use /opt/local/lib as a library
location? This should resolve this problem right?

The problem seems to be the build process is only using default xcode
library locations, which have pre-compiled versions of libsdl.
They're precompiled for i386 however. <-- Not sure about this.

Thanks,
Brandon

Fredrik Duprez

unread,
Aug 21, 2011, 4:59:37 PM8/21/11
to Android Building
I'm having the same problem. Installed sdl with homebrew and put /usr/
local/lib first in PATH, but i suppose the libpath is read somewhere
else?

Brandon Trussell

unread,
Aug 22, 2011, 3:49:38 PM8/22/11
to android-...@googlegroups.com
I got past the sdl errors by excluding the emulator as stated by one of the previous commentators.  I commented the whole android.mk file that was mentioned.

--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to android-...@googlegroups.com
To unsubscribe from this group, send email to
android-buildi...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/android-building?hl=en



--
Brandon

Fredrik Duprez

unread,
Aug 23, 2011, 3:07:10 PM8/23/11
to Android Building
I figured out the problem for everything but the emulator.

I found this post:
http://groups.google.com/group/android-building/msg/d4730b36e861569d

So then I just put the homebrew stuff (/usr/local/bin) last in $PATH,
letting the Mac use all stuff from apple toolchain first.

For building the third party ROM DevNull and Oxygen, you need to make
a symlink in /usr/local/bin from sed to gsed, since they explicitly
call gsed at one point. Also you have to add WITH_DEXPREOPT=false at
the end of the make statement. Like so:

make -j8 devnull WITH_DEXPREOPT=false

So in essence, if you want to build on Lion you patch the makefiles
mentioned in this thread and put homebrew apps last in PATH and you
will be able to build for the real device at least.

Bryan Hinton

unread,
Aug 23, 2011, 4:20:25 PM8/23/11
to Android Building
It looks like there is some new posix stuff in 10.7+. I will be
submitting a patch for this.
Also, I'll post my environment when done.

Cheers,

Bryan

Bryan Hinton

unread,
Aug 29, 2011, 3:33:31 AM8/29/11
to Android Building
Good evening,
I was able to successfully build everything, including the emulator,
on OS X Lion this evening.
I also ran and tested the emulator.

Here are the instructions for building Android (master) on OS X 10.7+.

1) Install XCode 4.1.1 from the Apple App store. If you need to re-
install it, search for "XCode install" in spotlight and then launch
the installer. Leave the default installation location - "/Developer"

2) Download XCode 3.2.4 for Mac OS X 10.6 and iOS 4.1. This can be
obtained for free from the Mac Developer connection via the Developer
Tools Downloads page. You will need this as it contains the OS X 10.4
Universal SDK and the OS X 10.5 SDK.
After downloading, run the installer. Choose custom installation and
ensure that the 10.4u.sdk option is selected.
Set the installation folder to /Developer324

3) From a terminal:
$ sudo cp -R /Developer324/SDKs/MacOSX10.4u.sdk /Developer/SDKs
$ sudo cp -R /Developer324/SDKs/MacOSX10.5.sdk /Developer/SDKs

4) Four directories should now reside in /Developer/SDKs
$ ls -l /Developer/SDKs
MacOSX10.4u.sdk MacOSX10.5.sdk MacOSX10.6.sdk MacOSX10.7.sdk

5) My environment is standard. I'm using the prebuilt arm toolchain in
prebuilt/ with CROSS_COMPILE set appropriately, ARCH is set to arm,
and I'm using the latest llvm-gcc 4.2 build from XCode 4.1.1

6) You can test things out as follows:
$ cd ~/android/external/qemu/
$ ./android-configure.sh
$ make

Last of all, in external/elfutils/config-compat-darwin.h, the
following built-in gcc preprocessor macro should take care of the
strnlen redefinition problem from /usr/include/string.h on OS X >=
10.7.
#if __ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1070
static inline strneln(...) ...
#endif
Or the header include path order can be changed as mentioned in the
above post.

Bryan Hinton

unread,
Aug 30, 2011, 3:37:00 PM8/30/11
to Android Building
Correction to the procedure below for building Gingerbread on OSX Lion
(10.7+).

If you install XCode 4.1 first and then you install XCode 3.2.4
(choose /Developer324 as install location), the installer will place
the resulting gcc binaries in the relevant folders - /Developer324 for
XCode 3.2.4 and /Developer for XCode 4.1.
Given that XCode 3.2.4 was installed after 4.1, the resulting llvm-gcc
binary that is installed in your system path will be the prior version
that was shipped with XCode 3.2.4. It is this version that you will
need to use in order to build qemu, including libsdl.
When you install the XCode 4.1.1 update OR you install XCode 4.1.1
after you install XCode 3.2.4, then the latest gcc binaries will be
symlinked in /usr/bin respectively. In this case, you must set the CC
environment variable upon building qemu and prior to running android-
configure.sh. The following commands show how I have it setup and
working.

Here are the commands to determine the proper version of gcc to use
for building qemu

# prior version works (xcode 3.2.4)
~ $ /Developer324/usr/bin/llvm-gcc-4.2 --version
i686-apple-darwin10-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc.
build 5658) (LLVM build 2326.10)

# latest version does not work (xcode 4.1.1)
~ $ /Developer/usr/bin/llvm-gcc-4.2 --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc.
build 5658) (LLVM build 2335.15.00)

# latest version installed in /usr/bin so we need to set CC when
building qemu
~ $ /usr/bin/gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc.
build 5658) (LLVM build 2335.15.00)
~/android/external/qemu $ export CC=/Developer323/usr/bin/llvm-gcc-4.2

Last of all, the Xcode 4.1.1 update removes the /Developer/SDKs/
MacOSX10.4u.sdk and /Developer/SDKs/MacOSX10.5.sdk folders to you'll
need to symlink them or copy them to /Developer324/SDKs respectively.

Makefile fixes to come so you won't have to mess with any of this...

Brandon Trussell

unread,
Aug 30, 2011, 6:52:18 PM8/30/11
to android-...@googlegroups.com
Submitted a change request for the strnlen implementation issue.  Just wanted to do it in order to learn some git/repo commands.
https://review.source.android.com/#/c/25863/

-BT

riazrahaman

unread,
Sep 19, 2011, 12:09:51 PM9/19/11
to Android Building
Uninstall xcode 4.* and install Xcode 3.2.6 fixed the problem.

Will there be any issues with using Xcode 3.2.6 on LION?

Riaz

On Aug 31, 3:52 am, Brandon Trussell <brandon...@gmail.com> wrote:
> Submitted a change request for the strnlen implementation issue.  Just
> wanted to do it in order to learn some git/repo commands.https://review.source.android.com/#/c/25863/
>
> -BT
> ...
>
> read more »

Andrew Coutts

unread,
Nov 15, 2011, 1:24:53 PM11/15/11
to Android Building
Xcode 3.2.6 did not fix the problem on my macbook:

2009 Model
OS X 10.7.2
2.26GHz Core 2 Duo

Same error about 10.5 support. I remember checking the option to
install 10.5 sdk support when I installed xcode too... going to try re-
installing it again.
> > > > > > > > > > I will go back to Lion when it will be more stable and...
>
> read more »

Andrew Coutts

unread,
Nov 15, 2011, 3:06:11 PM11/15/11
to Android Building
Just as a correction - after doing this step, I was able to
successfully compile on 10.7 (Lion):

3) From a terminal:
$ sudo cp -R /Developer324/SDKs/MacOSX10.4u.sdk /Developer/SDKs
$ sudo cp -R /Developer324/SDKs/MacOSX10.5.sdk /Developer/SDKs

[replace Developer324 with whatever folder Xcode is installed to, mine
was Developer-3.2.6]


So I guess the fix is:

- install xcode 3
- do step 3 mentioned above
> > > > > > > > > > > /var/folders/x2/gmbz48kx5ml_g72ct64t3xv00000gn/T//ccTPt2z6.s:...
>
> read more »

Mike Pontillo

unread,
Nov 15, 2011, 4:50:00 PM11/15/11
to android-...@googlegroups.com
FYI,

   You can actually get away with doing "ln -s" instead of "cp -R" to save some disk space.

Regards,
Mike

>
> read more »

--
You received this message because you are subscribed to the "Android Building" mailing list.
To post to this group, send email to android-...@googlegroups.com
To unsubscribe from this group, send email to
android-buildi...@googlegroups.com
For more options, visit this group at

Shell Shrader

unread,
Nov 19, 2011, 11:48:29 PM11/19/11
to Android Building
All I had to do was link back to the 10.5 SDK that was in my Developer-
old dir that all my pre-Lion xCode 3 stuff was moved to when I
upgraded. ICS built no problem. Thanks for the pointers.

On Nov 15, 4:50 pm, Mike Pontillo <ponti...@gmail.com> wrote:
> FYI,
>
>    You can actually get away with doing "ln -s" instead of "cp -R" to save
> some disk space.
>
> Regards,
> Mike
>
> On Tue, Nov 15, 2011 at 12:06 PM, Andrew Coutts

> <andrewjohncou...@gmail.com>wrote:

> > > > > > > > > > previous commentators.  I commented the whole android.mkfile that

> ...
>
> read more »

Shell Shrader

unread,
Nov 19, 2011, 11:50:29 PM11/19/11
to Android Building
disregard prior post ... this is a GB thread

On Nov 15, 4:50 pm, Mike Pontillo <ponti...@gmail.com> wrote:

> FYI,
>
>    You can actually get away with doing "ln -s" instead of "cp -R" to save
> some disk space.
>
> Regards,
> Mike
>
> On Tue, Nov 15, 2011 at 12:06 PM, Andrew Coutts

> <andrewjohncou...@gmail.com>wrote:

> > > > > > > > > > previous commentators.  I commented the whole android.mkfile that

> ...
>
> read more »

Shell Shrader

unread,
Nov 21, 2011, 6:15:21 PM11/21/11
to Android Building
Correction (even though I know I'm OT) -- My ICS build eventually
failed. Nothing to see here, move along.

On Nov 19, 11:48 pm, Shell Shrader <shelld...@gmail.com> wrote:
> All I had to do was link back to the 10.5 SDK that was in my Developer-

> old dir that all my pre-LionxCode 3 stuff was moved to when I

> > > > > > > > on OS XLionthis evening.

> > > > > > > > > > So in essence, if you want to build onLionyou patch the

> ...
>
> read more »

barrett

unread,
Nov 29, 2011, 3:20:31 PM11/29/11
to Android Building
To get GB (and probably ICS I'm verifying this now) to build on Lion.
this is what I have done:

I followed these instructions:
http://anatomicwax.tumblr.com/post/8064949186/installing-xcode-3-2-6-on-lion-redux

to get XCode 3.2.6 installed. I haven't yet installed 4 (I will
shortly) but I was able to build GB.

I'll post an update when I have more details.

On Nov 19, 9:48 pm, Shell Shrader <shelld...@gmail.com> wrote:
> All I had to do was link back to the 10.5 SDK that was in my Developer-

> old dir that all my pre-LionxCode 3 stuff was moved to when I

> > > > > > > > on OS XLionthis evening.

> > > > > > > > > > So in essence, if you want to build onLionyou patch the

> ...
>
> read more »

Jace

unread,
Dec 5, 2011, 11:16:56 AM12/5/11
to android-...@googlegroups.com
I got following ERROR

ChoonSik-ui-iMac:android choonsik$ cd external/qemu
ChoonSik-ui-iMac:qemu choonsik$ ./android-configure.sh 
OPTION_CC=''
Check32Bits: Forcing generation of 32-bit binaries (--try-64 to disable)
ANDROID_TOP found at /Volumes/android
Prebuilt   : ANDROID_PREBUILT=/Volumes/android/prebuilt/darwin-x86
Targets    : TARGETS= /Volumes/android/out/host/darwin-x86/bin/emulator
Tools      : Found tools revision number 16
GLES       : Probing for headers
GLES       : Headers in /Volumes/android/development/tools/emulator/opengl/host/include
GLES       : Probing for host libraries
GLES       : Libs in /Volumes/android/out/host/darwin-x86/lib
ERROR: Missing OpenGLES emulation host library: /Volumes/android/out/host/darwin-x86/lib/libOpenglRender.dylib
Please fix this by using --gles-libs to point to the right directory!
ChoonSik-ui-iMac:qemu choonsik$ 

Jean-Baptiste Queru

unread,
Dec 5, 2011, 11:39:32 AM12/5/11
to android-...@googlegroups.com
Gingerbread is much too old to build out of the box on Lion. I believe
that the master branch might somewhat work, though not quite entirely.

JBQ

> --
> You received this message because you are subscribed to the "Android
> Building" mailing list.
> To post to this group, send email to android-...@googlegroups.com
> To unsubscribe from this group, send email to
> android-buildi...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/android-building?hl=en
>

--

David Herges

unread,
Mar 9, 2012, 7:05:19 PM3/9/12
to android-...@googlegroups.com

On Monday, 5 December 2011 17:39:32 UTC+1, Jean-Baptiste Queru wrote:
Gingerbread is much too old to build out of the box on Lion. I believe
that the master branch might somewhat work, though not quite entirely.

Yeah, that old that two-third of all Android devices are running it...

So is there any other way past the SDL error other than Xcode 3? Was anything changed in the git repositories in the meantime?

Al Sutton

unread,
Mar 12, 2012, 2:14:27 PM3/12/12
to android-...@googlegroups.com
Gingerbreads release pre-dates Lions by about 7 months, and once a release has been made changes to build scripts are very rare.

I've been working on the master branch, Xcode 4, and Lion, so feel free to check those out and use the patch at https://android-review.googlesource.com/33101 which is enough to build a working image for the Galaxy Nexus. The emulator won't work post compilation, which is something that I've unfortunately not had time to look at in any detail.

Al.
-- 
Al Sutton - Funky Android Ltd.
T: @alsutton  

The views expressed in this email are those of the author and not necessarily those of Funky Android Limited, it's associates, or it's subsidiaries. 

David Herges

unread,
Mar 13, 2012, 8:16:56 AM3/13/12
to android-...@googlegroups.com
Hi Al,

this is great work, really. unfortunately, it didn't work for me. I have a feeling that the problem is not with your patch for the build system, but gcc and cc seem to be shortcuts for the same apple-...-llvm compiler; the problem you stated in https://groups.google.com/forum/?fromgroups#!topic/android-building/63QR-NxnsoY

I now went back to a backup copy of an old build and avoid rebuilding c/c++ system libraries. All I do, is partially building framework and libcore and that seems to work.

Cheers,
David

Al Sutton

unread,
Oct 24, 2012, 1:33:40 AM10/24/12
to android-...@googlegroups.com
That looks like your external disk unmounted itself (possibly going to sleep).

Al.
-- 
Al Sutton - Funky Android Ltd.

T: @alsutton  

The views expressed in this email are those of the author and not necessarily those of Funky Android Limited, it's associates, or it's subsidiaries. 

On 23 Oct 2012, at 21:54, Heaven Chen <yc15...@gmail.com> wrote:

Hi

After I follow the instruction and have osx sdk 10.5 installed, it seemed working until I hit this error:

target Prebuilt: libarity (out/target/product/crespo/obj/JAVA_LIBRARIES/libarity_intermediates/javalib.jar)
Target userdata fs image: out/target/product/crespo/userdata.img
/bin/bash: Image/nfc-card-emu/out/host/darwin-x86/bin:/Volumes/Disk: No such file or directory
make: *** [out/target/product/crespo/userdata.img] Error 127
make: *** Waiting for unfinished jobs....

I am quite new to android development so I don't really understand what the problem is. I tried to google the specific problem but didn't find anything. My mac doesn't have much space left so I created a case-sensitive file system disk image on an external hard drive for the process. I am not sure if that is the problem. Can anyone can give me some suggestions of this problem?

Thanks
Heaven
Reply all
Reply to author
Forward
0 new messages