Reports taking 14 hours to complete

14 views
Skip to first unread message

Nick

unread,
Oct 8, 2007, 8:32:11 AM10/8/07
to AdWords API Forum
For the past 2 weeks our custom reports are again taking 11 to 14
hours to complete. Is anyone else having this problem?

kwal...@gmail.com

unread,
Oct 8, 2007, 11:45:16 AM10/8/07
to AdWords API Forum
We are not having this problem anymore, but I definitely feel your
pain.

Jeff Schumacher

unread,
Oct 8, 2007, 12:33:49 PM10/8/07
to AdWords API Forum
We've been experiencing the same problem. Our reports, which used to
take 4 hours to run, are now taking over 8 hours. This just started
in the past week.

On Oct 8, 5:32 am, Nick <t...@trafficstrategies.com> wrote:

AdWords API Advisor

unread,
Oct 8, 2007, 2:47:52 PM10/8/07
to AdWords API Forum
Hi everyone,

We are aware of the issue with report slowness and are working very
hard to speed things up. I'll let you know as soon as it's fixed.

-Aaron Karp
AdWords API Team

swinny

unread,
Oct 9, 2007, 4:00:31 AM10/9/07
to AdWords API Forum
I'm having custom reports stuck in 'pending' status this morning - but
they were running fine since the update on 21 September. Does anyone
else see this?

carlo

unread,
Oct 9, 2007, 11:44:57 AM10/9/07
to AdWords API Forum
i'm in the same condition
waiting and hoping..!

bye
carlo (from italy)

On 8 Ott, 20:47, AdWords API Advisor <adwordsapiadvi...@google.com>
wrote:

> > > hours to complete. Is anyone else having this problem?- Nascondi testo tra virgolette -
>
> - Mostra testo tra virgolette -

AdWords API Advisor

unread,
Oct 15, 2007, 1:06:53 PM10/15/07
to AdWords API Forum
Hi everyone,

As far as we can tell, things should be back to normal with reports.
Please let me know if you continue to see any latency.

-Aaron

Thomas

unread,
Oct 19, 2007, 4:41:58 AM10/19/07
to AdWords API Forum
Hi,

We are still having this issue, reports that normally take 1 hour to
complete now take about 1 to 2 days. The reports stay stuck in the
status "In progress".
Though, this only happens when we request the report around 6-8pm US
pacific time.

Kind regards,
Thomas


On Oct 15, 7:06 pm, AdWords API Advisor <adwordsapiadvi...@google.com>

AdWords API Advisor

unread,
Oct 19, 2007, 11:28:38 AM10/19/07
to AdWords API Forum
Hi Thomas,

Can you post the report job ID for one of those reports so I can take
a look?

Thanks,
-Aaron

On Oct 19, 4:41 am, Thomas <tho...@rdlt.com> wrote:
> Hi,
>

> We are still having this issue,reportsthat normally take 1 hourtocompletenow take about 1to2 days. Thereportsstay stuck in the

> > > > > take 4hoursto run, are nowtakingover 8hours. This just started


> > > > > in the past week.
>
> > > > > On Oct 8, 5:32 am, Nick <t...@trafficstrategies.com> wrote:
>
> > > > > > For the past 2 weeks our customreportsare againtaking11 to14

> > > > > >hourstocomplete. Is anyone else having this problem?- Nascondi testo tra virgolette -

SEM

unread,
Oct 22, 2007, 3:30:10 AM10/22/07
to AdWords API Forum
Hi Aaron,

11928456676372 Could be one of them.. I am not sure...

Kind regards,
Thomas

On Oct 19, 5:28 pm, AdWords API Advisor <adwordsapiadvi...@google.com>

AdWords API Advisor

unread,
Oct 22, 2007, 10:37:50 AM10/22/07
to AdWords API Forum
Hi Thomas,

That doesn't look like a valid report job ID to me, and I can't find
it in our system. If you continue to experience any latency, please
make a record of the job ID and post it so I can see what's up.

Thanks,
-Aaron

SEM

unread,
Oct 23, 2007, 3:58:06 AM10/23/07
to AdWords API Forum
Hi Aaron,

First of all, thanks for your support :)

Uhmm... strange

How about 11931048577133? It is still in progress at this time.

Kind regards,
Thomas

On Oct 22, 4:37 pm, AdWords API Advisor <adwordsapiadvi...@google.com>

AdWords API Advisor

unread,
Oct 30, 2007, 4:21:07 PM10/30/07
to AdWords API Forum
I just wanted to follow up and see if folks are still experiencing
reports that take much longer (many hours longer) than they normally
take to run.

There was a code change pushed out this past week that was meant to
resolve any of the lingering issues, so hopefully everyone's report
performance is back to normal.

Cheers,
-Jeff Posnick, AdWords API Team

zdvso...@hotmail.com

unread,
Nov 1, 2007, 11:22:11 AM11/1/07
to AdWords API Forum
Got a hanging job today - a long time In Progress.
Job 124006947

AdWords API Advisor

unread,
Nov 2, 2007, 3:24:29 PM11/2/07
to AdWords API Forum
How long did it end up taking to complete, and how long does it
normally take? Is it slow again the next time you ran it?

There was a one-off issue that could have led to some performance
problems yesterday, so I'm more interested in whether there is any
slowness today and in the future.

Cheers,
-Jeff Posnick, AdWords API Team


On Nov 1, 11:22 am, "zdvsoftw...@hotmail.com"

zdvso...@hotmail.com

unread,
Nov 2, 2007, 8:20:25 PM11/2/07
to AdWords API Forum
I think it took about 180 minutes (my software abandons after 40
minutes 'in progress').
Normal is 10-15 minutes.

A few hours later the report was rescheduled and my software was
confronted with a HTTP 502 (Bad Gateway) when calling
ReportService.getReportJobStatus.

That was on Thursday, Friday had no problems.


On Nov 2, 8:24 pm, AdWords API Advisor <adwordsapiadvi...@google.com>
wrote:

> > Job 124006947- Hide quoted text -
>
> - Show quoted text -

Denis Vaillant

unread,
Nov 4, 2007, 8:30:30 PM11/4/07
to AdWords API Forum
Hi,

I got also some issues when asking for a custom report.

Usually, the reports I ask for takes 1 hour to complete. Since
Saturday, I get an error after a 3-4 hours wait.

Here are the report IDs that failed :
- 142545813
- 142449993

Thank you for your help,

Regards,

Denis

Thomas

unread,
Nov 5, 2007, 10:58:38 AM11/5/07
to AdWords API Forum
Hi,

Today, we've encountered a rather strange message when asking for a
report... The api said:
"A mysterious error has occured"...

EEK!

This happened when requesting a report from 1oct to 5nov

Kind regards,
Thomas

AdWords API Advisor

unread,
Nov 5, 2007, 12:46:06 PM11/5/07
to AdWords API Forum
Hi all,

We are experiencing some trouble with reports today and I do
apologize. We're investigating the cause and I'll let you know as soon
as it's resolved.

Thanks,
-Aaron

doug

unread,
Nov 6, 2007, 8:29:43 AM11/6/07
to AdWords API Forum
We run reports every hour and the last 5 have failed. Also over the
weekend, most of our reports failed.
We are using API v10 CustomReport to schedule the reports for large
campaigns.

A few weeks ago, everything was running smooth and our reports were
finishing quickly.
Would upgrading our report requests to use v11 help?

Thanks,
Doug


On Nov 5, 12:46 pm, AdWords API Advisor <adwordsapiadvi...@google.com>
wrote:

> > Thomas- Hide quoted text -

AdWords API Advisor

unread,
Nov 6, 2007, 12:02:14 PM11/6/07
to AdWords API Forum
This is not a version-specific (or API-specific) issue, so using v11
shouldn't make a difference. We do hope to have everything fixed very
soon.

-Aaron

Thomas

unread,
Nov 12, 2007, 4:50:21 AM11/12/07
to AdWords API Forum
Hey Aaron,

Any news on the fixing?

Kind regards,
Thomas

On Nov 6, 6:02 pm, AdWords API Advisor <adwordsapiadvi...@google.com>

AdWords API Advisor

unread,
Nov 12, 2007, 1:44:08 PM11/12/07
to AdWords API Forum
This should now be resolved (see the other thread at
http://groups.google.com/group/adwords-api/browse_thread/thread/06e0a3e4573b2a28#)

Are you still running into problems with reports failing unexpectedly?

Cheers,
-Jeff Posnick, AdWords API Team

Reply all
Reply to author
Forward
0 new messages