We already had the discussion about shinyStan (I objected
to naming it both after Stan and after shiny, but The Nominator
didn't want something obscure or cute [go figure --- he's the
one who gave us "Stan"], like say a riff on "coda" [pun intended]).
"Shiny" is capitalized on their own pages, so I'm not sure
why "shinyStan" was chosen.
I'm OK with changing it --- we've already confused the hell out
of people by calling the R interface "RStan" in print, but "rstan"
as a package and for the repo and capitalizing "STAN" in the first
logo.
As to camel case, a common convention is that classes
are uppercased and variables lowercased initially, so
that'd be "ShinyStan" for a class and "shinyStan" for a variable.
- Bob