Zotonic on Fedora 36 (with Podman?)

Skip to first unread message

Evan Rowley

Aug 13, 2022, 5:56:39 PM8/13/22
to Zotonic users

Advice/guidance for installing Zotonic on Fedora 36 would be appreciated!

I have tried it and encountered some issues:
- Running start-docker.sh results in docker-compose errors when SELinux is enabled.
- Running start-docker.sh results in the same errors without Sudo (on Fedora, Podman is preferred over Docker, and it does not require privileges)
- When running `bin/zotonic config` does not show a wwwadmin user password, and there is no config file that contains it anywhere.
- The PostgresSQL zotonic DB is empty - maybe it's not connecting?

Is there a recommended way to run Zotonic on Fedora?

Evan Rowley

Evan Rowley

Aug 14, 2022, 12:43:51 AM8/14/22
to Zotonic users
I tried following the same Zotonic docker installation instructions on Debian 11. Encountered the same problems (except for the SELinux one). The DB is empty and there is no admin password set. I noticed this message in the debug output, looks like it could be a problem:

2022-08-14 04:41:11 INFO  site=zotonic_site_status  user_id=1 <0.1334.0> [z_module_manager:manage_schema_if_db/5:1509] ▸ text="Skipping schema for module as the site has no database ('nodb')" result=skip reason=nodb module=mod_base in=zotonic_core

I'm new to using Docker, so it could be I am just misunderstanding how docker-compose is supposed to be connecting the zotonic and postgresql containers. Any ideas?
Reply all
Reply to author
0 new messages