USB error: LIBUSB_ERROR_IO - Windows 10 X64

49 views
Skip to first unread message

Jazzcat6581

unread,
Jul 20, 2020, 1:06:43 AM7/20/20
to ZoomFloppy Users
Hi,

When runtest is performed I get USB error: LIBUSB_ERROR_IO
libusb/xum1541:1/20: The handle is invalid.

I am on Windows 10 X64, zadig-2.5 recognises the ZoomFloppy but not the runtest.

I am totally out of ideas.

Any help would be appreciated.


Jazzcat6581

unread,
Jul 20, 2020, 1:22:22 AM7/20/20
to ZoomFloppy Users
Debug mode for runtest.bat

Found the following drives:
[XUM1541] scanning usb ...
[XUM1541] device 8087:0a2b
[XUM1541] device 1a40:0101
[XUM1541] device 1199:9063
[XUM1541] device 8086:9d2f
[XUM1541] device 0e8f:00a7
[XUM1541] device 16d0:0504
[XUM1541] found xu/xum1541 version 0207 on bus 1, device 23
[XUM1541] xum1541 name: xum1541 floppy adapter (ZOOMFLOPPY)
[XUM1541] xum1541 serial number:   0
USB error: LIBUSB_ERROR_IO
[XUM1541] Closing USB link
USB request for XUM1541 close failed, continuing: LIBUSB_ERROR_IO
[XUM1541] scanning usb ...
[XUM1541] device 8087:0a2b
[XUM1541] device 1a40:0101
[XUM1541] device 1199:9063
[XUM1541] device 8086:9d2f
[XUM1541] device 0e8f:00a7
[XUM1541] device 16d0:0504
[XUM1541] found xu/xum1541 version 0207 on bus 1, device 23
[XUM1541] xum1541 name: xum1541 floppy adapter (ZOOMFLOPPY)
[XUM1541] xum1541 serial number:   0
[XUM1541] Closing USB link
USB request for XUM1541 close failed, continuing: LIBUSB_ERROR_IO
libusb/xum1541:1/23: The handle is invalid. 

Martin Thierer

unread,
Jul 20, 2020, 6:19:10 AM7/20/20
to ZoomFloppy Users
Please check which driver is selected in zadig. It should be the "WinUSB" driver. My guess is that you're still using libusb-win32.

Spiro Trikaliotis

unread,
Jul 20, 2020, 12:12:56 PM7/20/20
to ZoomFloppy Users
Hello,

* On Sun, Jul 19, 2020 at 10:06:43PM -0700 Jazzcat6581 wrote:

> When runtest is performed I get USB error: LIBUSB_ERROR_IO
> libusb/xum1541:1/20: The handle is invalid.
>
> I am on Windows 10 X64, zadig-2.5 recognises the ZoomFloppy but not the
> runtest.

Which version of OpenCBM are you using? If it is something >=
0.4.99.100, then you should NOT install the driver with zadig, but use
the one from install.cmd instead!

This is what Martin meant.

If you are using an older version, then your problem is another one. In
this case, it would be good if you could test the newer one.

Regards,
Spiro.

--
Spiro R. Trikaliotis
http://spiro.trikaliotis.net/

jazz...@gmail.com

unread,
Jul 21, 2020, 7:00:24 PM7/21/20
to ZoomFloppy Users
Thanks Spiro,
Have uninstalled libusb and re-run install.bat and installed the drivers from opencbm.

I am running: opencbm-0.4.99.102

Now when I execute runtest.bat (without the 1541 plugged into the ZoomFloppy)


Found the following drives:

You should see your drive detected above. If not, please see the
ZoomFloppy manual for troubleshooting tips.
Press any key to continue . . .







--
You received this message because you are subscribed to the Google Groups "ZoomFloppy Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to zoomfloppy-users+unsub...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/zoomfloppy-users/20200720161244.GB21660%40hermes.local.trikaliotis.net.

jazz...@gmail.com

unread,
Jul 21, 2020, 8:37:16 PM7/21/20
to ZoomFloppy Users
Found the following drives:
 8: 1541-II

You should see your drive detected above. If not, please see the
ZoomFloppy manual for troubleshooting tips.
Press any key to continue . . .


So, looks fine now. (with drive plugged in)

Next is the 1571 and running NIBREAD



Reply all
Reply to author
Forward
0 new messages