Trouble selecting by location and exporting data

28 views
Skip to first unread message

Dan

unread,
May 17, 2010, 11:41:59 PM5/17/10
to zigGIS
Hi -

New to ZigGIS - I recently purchased v. 2.0.5. I'm using ArcMap 9.3
and zigGIS to connect to a Postgres/PostGIS database (Postgres 8.3.7
and PostGIS 1.3).

I am working with a PostGIS table with point geometries. I also have a
view to this table opened in ArcMap as well. I can view/symbolize
these layers fine (haven't tried editing). One of the basic tasks I am
trying to accomplish is to select a group of records from the PostGIS
table or the PostGIS view based on a location within a polygon layer
(not PostGIS - a regular shapefile), and then export that subset to a
shapefile.

When doing the Select by Location to select a subset of the PostGIS
features, I get the following error: "An unexpected error occurred in
the Select By Location command. Error HRESULT E_FAIL has been returned
from a call to a COM component.".

I can select a subset of the PostGIS features graphically or using
Select by Attribute, but if I try to export the selection to a
shapefile, I get the following message:
"Error exporting data
Number of shapes does not match the number of table records" A
shapefile is created, but is corrupted and cannot be opened.

The errors occur whether I am selecting/exporting from the table or
from the view. I'm dead in the water - any idea what is going on?

Thanks!

--
You received this message because you are subscribed to the Google Groups "zigGIS" group.
To post to this group, send email to zig...@googlegroups.com.
To unsubscribe from this group, send email to ziggis+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/ziggis?hl=en.

Abe Gillespie

unread,
May 18, 2010, 12:11:50 PM5/18/10
to zig...@googlegroups.com
This looks like it'll take some digging into. Can you contact me off
list? abe -at- obtusesoft.com.

Thanks.
Reply all
Reply to author
Forward
0 new messages