problem installing zigGIS

49 views
Skip to first unread message

Augustin

unread,
Aug 30, 2010, 1:23:33 PM8/30/10
to zigGIS
Hi,
I downloaded the ziggis 2.0.5 demo and I run the installer. All seemed
to work fine, but when I opened ArcMap, I had no ziggis toolbar
available. I'm on Arcgis 9.3.
Thanks for your help

Abe Gillespie

unread,
Aug 30, 2010, 1:36:32 PM8/30/10
to zig...@googlegroups.com
Right-click the toolbar in ArcGIS. You should see "zigGIS" at the
bottom. Failing this the installer probably did not actually install
correctly. Try installing again and see if it reports any errors in
the details.

Another common problem is the ArcObjects .NET libraries are not
installed. But there's a check and usually fails the installer
properly. However, if this is the problem, the readme.txt file has
instructions (see #4).

-Abe

> --
> You received this message because you are subscribed to the Google Groups "zigGIS" group.
> To post to this group, send email to zig...@googlegroups.com.
> To unsubscribe from this group, send email to ziggis+un...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/ziggis?hl=en.
>
>

Augustin Roche

unread,
Aug 31, 2010, 3:51:11 AM8/31/10
to zig...@googlegroups.com
Hello,
I did all what you said, but still no ziggis toolbar available. Maybe it is because I have a French version of ArcGIS ?
Here is the log of installation :

OK: No existing zigGIS install
Checking dependencies...
OK: .Net 2.0 Framework
Output folder: C:\Temp
Extract: gacutil.exe... 100%
Extract: check-ao.bat
Execute: C:\Temp\check-ao.bat
Delete file: C:\Temp\check-ao.out
Delete file: C:\Temp\check-ao.bat
Delete file: C:\Temp\gacutil.exe
OK: ArcObjects
OK: All dependencies
Output folder: C:\Program Files\Obtuse\zigGIS
Created uninstaller: C:\Program Files\Obtuse\zigGIS\uninstall.exe
Extracting files...
Extract: eula.rtf... 100%
Extract: example.zig... 100%
Extract: License.dll... 100%
Extract: Mono.Security.dll... 100%
Extract: Nini.dll... 100%
Extract: Npgsql.dll... 100%
Extract: Obtuse.ZigGis.dll... 100%
Extract: log4net.dll... 100%
Extract: release.txt... 100%
Registering zigGIS...
Output folder: C:\Temp
Extract: RegAsm.exe... 100%
Delete file: C:\Temp\RegAsm.exe
Adding shortcuts...
Create folder: C:\Documents and Settings\All Users\Menu Démarrer\Programmes\zigGIS
Output folder: C:\Documents and Settings\All Users\Menu Démarrer\Programmes\zigGIS
Create shortcut: Uninstall.lnk
Create shortcut: release.txt.lnk
Create shortcut: eula.rtf.lnk
Create shortcut: example.zig.lnk
Registering uninstaller...
Start zigging!
Success.

Many thanks,
Augustin

2010/8/30 Abe Gillespie <abe.gi...@gmail.com>

xanadont

unread,
Sep 9, 2010, 9:47:07 PM9/9/10
to zigGIS
Your install output is wrong. It should appear similar to below.
Note this missing bit:

"RegAsm : warning RA0000 : Registering an unsigned assembly with /
codebase can cause your assembly to interfere with other applications
that may be installed on the same computer. The /codebase switch is
intended to be used only with signed assemblies. Please give your
assembly a strong name and re-register it.
Types registered successfully"

Ignore the warning, that's OK and is how it should be. Are you
running this on Win7? Please make sure you run as administrator.
That just may be the problem because registering assemblies requires
admin privileges.

OK: No existing zigGIS install
Checking dependencies...
OK: .Net 2.0 Framework
Output folder: C:\Users\abe\AppData\Local\Temp
Extract: gacutil.exe... 100%
Extract: check-ao.bat
Execute: C:\Users\abe\AppData\Local\Temp\check-ao.bat
Delete file: C:\Users\abe\AppData\Local\Temp\check-ao.out
Delete file: C:\Users\abe\AppData\Local\Temp\check-ao.bat
Delete file: C:\Users\abe\AppData\Local\Temp\gacutil.exe
OK: ArcObjects
OK: All dependencies
Output folder: C:\Program Files\Obtuse\zigGIS
Created uninstaller: C:\Program Files\Obtuse\zigGIS\uninstall.exe
Extracting files...
Extract: eula.rtf... 100%
Extract: example.zig... 100%
Extract: License.dll... 100%
Extract: Mono.Security.dll... 100%
Extract: Nini.dll... 100%
Extract: Npgsql.dll... 100%
Extract: Obtuse.ZigGis.dll... 100%
Extract: log4net.dll... 100%
Extract: release.txt... 100%
Registering zigGIS...
Output folder: C:\Users\abe\AppData\Local\Temp
Extract: RegAsm.exe... 100%
RegAsm : warning RA0000 : Registering an unsigned assembly with /
codebase can cause your assembly to interfere with other applications
that may be installed on the same computer. The /codebase switch is
intended to be used only with signed assemblies. Please give your
assembly a strong name and re-register it.
Types registered successfully
Delete file: C:\Users\abe\AppData\Local\Temp\RegAsm.exe
Adding shortcuts...
Create folder: C:\ProgramData\Microsoft\Windows\Start Menu\Programs
\zigGIS
Output folder: C:\ProgramData\Microsoft\Windows\Start Menu\Programs
\zigGIS
Create shortcut: Uninstall.lnk
Create shortcut: release.txt.lnk
Create shortcut: eula.rtf.lnk
Create shortcut: example.zig.lnk
Registering uninstaller...
Start zigging!
Success.


> 2010/8/30 Abe Gillespie <abe.gilles...@gmail.com>
>
>
>
> > Right-click the toolbar in ArcGIS.  You should see "zigGIS" at the
> > bottom.  Failing this the installer probably did not actually install
> > correctly.  Try installing again and see if it reports any errors in
> > the details.
>
> > Another common problem is the ArcObjects .NET libraries are not
> > installed.  But there's a check and usually fails the installer
> > properly.  However, if this is the problem, the readme.txt file has
> > instructions (see #4).
>
> > -Abe
>
> > On Mon, Aug 30, 2010 at 1:23 PM, Augustin <augustin.ro...@gmail.com>
> > wrote:
> > > Hi,
> > > I downloaded the ziggis 2.0.5 demo and I run the installer. All seemed
> > > to work fine, but when I opened ArcMap, I had no ziggis toolbar
> > > available. I'm on Arcgis 9.3.
> > > Thanks for your help
>
> > > --
> > > You received this message because you are subscribed to the Google Groups
> > "zigGIS" group.
> > > To post to this group, send email to zig...@googlegroups.com.
> > > To unsubscribe from this group, send email to
> > ziggis+un...@googlegroups.com<ziggis%2Bunsu...@googlegroups.com>
> > .
> > > For more options, visit this group at
> >http://groups.google.com/group/ziggis?hl=en.
>
> > --
> > You received this message because you are subscribed to the Google Groups
> > "zigGIS" group.
> > To post to this group, send email to zig...@googlegroups.com.
> > To unsubscribe from this group, send email to
> > ziggis+un...@googlegroups.com<ziggis%2Bunsu...@googlegroups.com>
> > .
Reply all
Reply to author
Forward
0 new messages