Zenoss Core 4.2.5 on CentOS 7

54 views
Skip to first unread message

Sam Nirmal

unread,
Apr 14, 2022, 10:27:51 PMApr 14
to zenos...@googlegroups.com
Has anyone attempted and succeeded in installing Core 4.2.5 on CentOS 7? 

Today tried to install the core pkg but it failed on 3 EL6 specific libs. Libgdbm , libpcre and libsasl2 Not sure if there is a workaround...

Anyone tried to build it from the source code?


Thanks

Sam Nirmal

unread,
Apr 15, 2022, 11:13:26 PMApr 15
to 'Sam Nirmal' via Zenoss Core
I was able to compile the Core on CentOS 1810.

Now have to get it setup with other componets and update autodeploy script later.


--
You received this message because you are subscribed to the Google Groups "Zenoss Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to zenoss-core...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/zenoss-core/1377459870.76259.1649989668046%40mail.yahoo.com.

Jane Curry

unread,
Apr 16, 2022, 3:21:14 AMApr 16
to Zenoss Core
That's brilliant news.  Please keep us posted.
Cheers,
Jane

Sam Nirmal

unread,
May 5, 2022, 11:38:24 AMMay 5
to Zenoss Core
Working on Segfault 11 issue with "zentrap" which just dies after connecting to ZenHub.  I suspect it has to do with pynetsnmp and net-snmp incompatibility. 


python /usr/local/zenoss/Products/ZenEvents/zentrap.py
2022-05-04 21:15:05,061 INFO zen.zentrap: Connecting to localhost:8789
2022-05-04 21:15:05,071 INFO zen.zentrap: Connected to ZenHub
2022-05-04 21:15:10,393 INFO zen.zentrap: Connecting to localhost:8789
2022-05-04 21:15:10,400 INFO zen.zentrap: Connected to ZenHub
2022-05-04 21:15:10,477 INFO zen.zentrap: Starting to listen on SNMP trap port 162
Fatal Python error: Segmentation fault

Current thread 0x00007fb7e941d740 <python> (most recent call first):
  File "/usr/local/zenoss/lib/python/pynetsnmp/netsnmp.py", line 451 in awaitTraps
  File "/usr/local/zenoss/Products/ZenEvents/zentrap.py", line 222 in __init__
  File "/usr/local/zenoss/Products/ZenEvents/zentrap.py", line 126 in postStartupTasks






Screen Shot 2022-05-05 at 10.42.53 AM.png
Screen Shot 2022-05-05 at 10.35.07 AM.png

Sam Nirmal

unread,
May 5, 2022, 10:17:41 PMMay 5
to 'Sam Nirmal' via Zenoss Core
Ok. Installing netsnmp 5.6.2 fixed the issue.. 

The source has Pynetsnmp 0.30.7
Going to try out 0.41.3 version which may work with netsnmp 5.7.2 I guess. 
On Thu, May 5, 2022 at 10:38 AM, 'Sam Nirmal' via Zenoss Core
Reply all
Reply to author
Forward
0 new messages