Unable to locate xyce binary location after installation

72 views
Skip to first unread message

Kannan U.M

unread,
Apr 9, 2023, 9:38:50 PM4/9/23
to xyce-users

Hi,

I am trying to install xyce 7.6 from source on WSL2 ubuntu 22.04 LTS. I could build xyce by following the instructions as per the instruction in https://xyce.sandia.gov/documentation-tutorials/building-guide/#serialLinuxXyce. I could execute the make and make install from the build directory. I did the regression test after the make install after adding the prerequisite libraries. Some tests passed whereas others failed. But now I cannot not locate the xyce binary location to add to path as per the manual. I am also trying to add this binary path to the qucs-s as its xyce backend. I tried the following:

1)      There’s a $HOME/XyceInstall/Serial/bin with a Xyce file in it. I tried to run a sample netlist from here with the command “Xyce diode_clip.cir”. I got the error: “Xyce: command not found

2)      $HOME/build_xyce/src/ has a Xyce file. I tried to do the same here but got the same error message

3)      From the build directory,   $HOME/build_xyce, I tried a src/Xyce -v. I got the output “Xyce Release 7.6-opensource”

4)      I checked the /usr/local directory as well but could not find the Xyce directory.

I am attaching the config.log after xyce build and serial_results after regression test. Please help me with this issue.

Thanks

Kannan


NB: This was posted previously in https://groups.google.com/g/xyce-users/c/Y5l8lfQl-OQ/m/S-WZIU1EAAAJ but could not get a reply. So I am posting as a new issue.

serial_results.txt
config.log

xyce-users

unread,
Apr 10, 2023, 12:22:50 PM4/10/23
to xyce-users
Kannan,

From your description, it seems like Xyce is not in your PATH. It also appears that you installed Xyce to $HOME/XyceInstall/Serial/bin, which is fine. That is just not a default PATH location. If you want to have Xyce to always be available, you should add
     export PATH="$PATH:$HOME/XyceInstall/Serial/bin"
to your .bashrc file (or whatever appropriate file you use for your shell).

As an aside, if a binary is not in your path on Unix-like systems, you must give the path to the binary, even when you are in the same directory as the executable. In other words, you must type, "./Xyce diode_clip.cir" when in $HOME/XyceInstall/Serial/bin.

As to the test failures, that is likely due to SciPy not being available. Unless you want to be sure all the tests pass, you don't have to add SciPy. It appears the build went ok.

Thanks,
Jason

Kannan U.M

unread,
Apr 11, 2023, 9:20:47 PM4/11/23
to xyce-users
Hi
 Thanks Jason for the help. Xyce is now running fine from the terminal. 

Regards
Kannan 


Reply all
Reply to author
Forward
0 new messages