Poll. How frequently 2014 SP2 crashes, and when?

85 views
Skip to first unread message

Szabolcs Matefy

unread,
Sep 11, 2013, 3:23:30 AM9/11/13
to soft...@listproc.autodesk.com

Hey folks

 

Here most of our artists have plenty of crashes with Softimage 2014 SP2 (Daily 4-5 on average)

They have crashes on Knife tool, Connect edge, Texture Editor.

 

They have migrated their preferences from previous versions (SI2013 or so)

 

I myself have also problems, but most of them are because of an ICE based modeling tool I use for extrusion.

 

I want to isolate the source of their crashes, and I need to know if you have similar issues. I suspect corrupted memory, but I was told that maybe a user preference might cause this (it sounds bullshit, to be honest), but I want to stay on the safe side, so will test it.

 

 

 

Cheers

___
This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. E-mail transmission cannot be guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or contain viruses. The sender therefore does not accept liability for any errors or omissions in the contents of this message, which arise as a result of e-mail transmission. If verification is required please request a hard-copy version. Crytek GmbH - http://www.crytek.com - Grüneburgweg 16-18, 60322 Frankfurt - HRB77322 Amtsgericht Frankfurt a. Main- UST IdentNr.: DE20432461 - Geschaeftsfuehrer: Avni Yerli, Cevat Yerli, Faruk Yerli

Jens Lindgren

unread,
Sep 11, 2013, 3:44:12 AM9/11/13
to soft...@listproc.autodesk.com
I have been using it for about a month and not a single crash yet. Used the knife tool like crazy on the current project.
I never migrate the preferences and I delete the user folder every time it's time to update Arnold. I then have a script that I run manually to set up all my preferences again.
 
/Jens
--
Jens Lindgren
--------------------------
Lead Technical Director

Vincent Ullmann

unread,
Sep 11, 2013, 5:14:57 AM9/11/13
to soft...@listproc.autodesk.com
Deleteing my UserFolder every time i install Arnold?
So sometimes this might be 5-8 times a day if i work on multiple Projects at once?
I might give it a try....


We are using Softimage2014 here for about 2 Months now.
It didnt crashed on August 9th and September 5th.
On all other Days it crashes every 10 - 60 minutes.
Mostly in combination with external Renderers or ICE

Also i'am not sure how stable it is on Saturday and Sundays.... only a few Crahes here.

Jens Lindgren

unread,
Sep 11, 2013, 5:30:27 AM9/11/13
to soft...@listproc.autodesk.com
Haha, yeah, if I switched Arnold that many times I wouldn't delete my user folder.
I only switch like once a month or something like that.
But instead of deleting the Arnold Render.Preset and all references to Arnold in default.xsipref, I usually delete the whole folder and run my script to set all preferences again.
I don't have any addons or plugins at all in my user folder but instead have a personal workgroup on the network. That way the farm can still use my personal stuff.
The only drawback is that the recent files and Project Manager gets cleared but that's sometimes a good thing as well as old project that has been archived and not accessible anymore gets cleared out.
Oh, and the key map needs to be backed up and copied back to the new user folder.
 
/Jens

Jens Lindgren

unread,
Sep 11, 2013, 5:40:18 AM9/11/13
to soft...@listproc.autodesk.com
Thomas just reminded me that you can put the key map in your personal workgroup so no need to copy it back and forth.
 
/Jens

Chris Chia

unread,
Sep 11, 2013, 5:56:14 AM9/11/13
to soft...@listproc.autodesk.com
Have been using Knife tool and Split, Add Poly and any other modeling tools that you can think of... for modeling (characters for 3d printing :) ) And it doesn't crash on us.

Fyi, we don't use any workgroup and plugin...
winmail.dat

Doeke Wartena

unread,
Sep 11, 2013, 5:56:48 AM9/11/13
to soft...@listproc.autodesk.com
I dont use xsi that much but so far i did not have a single crash yet.


2013/9/11 Jens Lindgren <jens.lin...@gmail.com>

Luc-Eric Rousseau

unread,
Sep 11, 2013, 8:09:09 AM9/11/13
to soft...@listproc.autodesk.com
for crashes with just standard modeling tools, I'd recommend looking
at the graphic card driver. I've read in an internal newsletter last
month that an nVidia driver update was causing higher instanced of
crash reports in all M&E applications. Older driver may be better.

Vincent Ullmann

unread,
Sep 11, 2013, 6:07:26 PM9/11/13
to soft...@listproc.autodesk.com
Stephen just postet a nice Script, regarding this Topic:
http://xsisupport.com/2013/09/11/getting-crash-dirty-exit-and-clean-exit-counts/

Would be nice to se some of your Stats....
wondering if i do something completly wrong ;-)

PS:
Here are some Stats from me
https://dl.dropboxusercontent.com/u/32213900/XSI_Crashes.JPG

Chris Chia

unread,
Sep 11, 2013, 10:05:58 PM9/11/13
to soft...@listproc.autodesk.com
Vincent, it's looking good on your image ;)


From: softimag...@listproc.autodesk.com [mailto:softimag...@listproc.autodesk.com] On Behalf Of Vincent Ullmann
Sent: Thursday, September 12, 2013 6:07 AM
To: soft...@listproc.autodesk.com
Subject: Re: Poll. How frequently 2014 SP2 crashes, and when?

Stephen just postet a nice Script, regarding this Topic:
http://xsisupport.com/2013/09/11/getting-crash-dirty-exit-and-clean-exit-counts/

Would be nice to se some of your Stats....
wondering if i do something completly wrong ;-)

PS:
Here are some Stats from me
https://dl.dropboxusercontent.com/u/32213900/XSI_Crashes.JPG

Am 11.09.2013 11:56, schrieb Doeke Wartena:
I dont use xsi that much but so far i did not have a single crash yet.

2013/9/11 Jens Lindgren <jens.lin...@gmail.com<mailto:jens.lin...@gmail.com>>
Thomas just reminded me that you can put the key map in your personal workgroup so no need to copy it back and forth.

/Jens

On Wed, Sep 11, 2013 at 11:30 AM, Jens Lindgren <jens.lin...@gmail.com<mailto:jens.lin...@gmail.com>> wrote:
Haha, yeah, if I switched Arnold that many times I wouldn't delete my user folder.
I only switch like once a month or something like that.
But instead of deleting the Arnold Render.Preset and all references to Arnold in default.xsipref, I usually delete the whole folder and run my script to set all preferences again.
I don't have any addons or plugins at all in my user folder but instead have a personal workgroup on the network. That way the farm can still use my personal stuff.
The only drawback is that the recent files and Project Manager gets cleared but that's sometimes a good thing as well as old project that has been archived and not accessible anymore gets cleared out.
Oh, and the key map needs to be backed up and copied back to the new user folder.

/Jens

On Wed, Sep 11, 2013 at 11:14 AM, Vincent Ullmann <vincent...@googlemail.com<mailto:vincent...@googlemail.com>> wrote:
Deleteing my UserFolder every time i install Arnold?
So sometimes this might be 5-8 times a day if i work on multiple Projects at once?
I might give it a try....


We are using Softimage2014 here for about 2 Months now.
It didnt crashed on August 9th and September 5th.
On all other Days it crashes every 10 - 60 minutes.
Mostly in combination with external Renderers or ICE

Also i'am not sure how stable it is on Saturday and Sundays.... only a few Crahes here.




Am 11.09.2013 09:44, schrieb Jens Lindgren:
I have been using it for about a month and not a single crash yet. Used the knife tool like crazy on the current project.
I never migrate the preferences and I delete the user folder every time it's time to update Arnold. I then have a script that I run manually to set up all my preferences again.

/Jens

On Wed, Sep 11, 2013 at 9:23 AM, Szabolcs Matefy <szab...@crytek.com<mailto:szab...@crytek.com>> wrote:
Hey folks

Here most of our artists have plenty of crashes with Softimage 2014 SP2 (Daily 4-5 on average)
They have crashes on Knife tool, Connect edge, Texture Editor.

They have migrated their preferences from previous versions (SI2013 or so)

I myself have also problems, but most of them are because of an ICE based modeling tool I use for extrusion.

I want to isolate the source of their crashes, and I need to know if you have similar issues. I suspect corrupted memory, but I was told that maybe a user preference might cause this (it sounds bullshit, to be honest), but I want to stay on the safe side, so will test it.



Cheers
___
This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. E-mail transmission cannot be guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or contain viruses. The sender therefore does not accept liability for any errors or omissions in the contents of this message, which arise as a result of e-mail transmission. If verification is required please request a hard-copy version. Crytek GmbH - http://www.crytek.com - Grüneburgweg 16-18, 60322 Frankfurt - HRB77322 Amtsgericht Frankfurt a. Main- UST IdentNr.: DE20432461 - Geschaeftsfuehrer: Avni Yerli, Cevat Yerli, Faruk Yerli



--
Jens Lindgren
--------------------------
Lead Technical Director
Magoo 3D Studios<http://www.magoo3dstudios.com/>




--
Jens Lindgren
--------------------------
Lead Technical Director
Magoo 3D Studios<http://www.magoo3dstudios.com/>



--
Jens Lindgren
--------------------------
Lead Technical Director
Magoo 3D Studios<http://www.magoo3dstudios.com/>


winmail.dat

Szabolcs Matefy

unread,
Sep 12, 2013, 2:38:22 AM9/12/13
to soft...@listproc.autodesk.com

How to run this snippet? I ran it within the Pywin window, but it listed only 2012 SAP, though I have used all Softimage back since 7?

 

 

Cheers

 

 

Szabolcs

 

From: softimag...@listproc.autodesk.com [mailto:softimag...@listproc.autodesk.com] On Behalf Of Chris Chia
Sent: Thursday, September 12, 2013 4:06 AM
To: soft...@listproc.autodesk.com
Subject: RE: Poll. How frequently 2014 SP2 crashes, and when?

 

Vincent, it’s looking good on your image ;)

 

 

From: softimag...@listproc.autodesk.com [mailto:softimag...@listproc.autodesk.com] On Behalf Of Vincent Ullmann
Sent: Thursday, September 12, 2013 6:07 AM
To: soft...@listproc.autodesk.com
Subject: Re: Poll. How frequently 2014 SP2 crashes, and when?

 

Stephen just postet a nice Script, regarding this Topic:
http://xsisupport.com/2013/09/11/getting-crash-dirty-exit-and-clean-exit-counts/

Would be nice to se some of your Stats....
wondering if i do something completly wrong ;-)

PS:
Here are some Stats from me
https://dl.dropboxusercontent.com/u/32213900/XSI_Crashes.JPG

Am 11.09.2013 11:56, schrieb Doeke Wartena:

I dont use xsi that much but so far i did not have a single crash yet.

 

2013/9/11 Jens Lindgren <jens.lin...@gmail.com>

Thomas just reminded me that you can put the key map in your personal workgroup so no need to copy it back and forth.

 

/Jens

Thomas Volkmann

unread,
Sep 12, 2013, 3:23:34 AM9/12/13
to soft...@listproc.autodesk.com
I just ran it from Softimage's script editor...works fine.
 
Szabolcs Matefy <szab...@crytek.com> hat am 12. September 2013 um 08:38 geschrieben:

Szabolcs Matefy

unread,
Sep 12, 2013, 3:58:03 AM9/12/13
to Thomas Volkmann, soft...@listproc.autodesk.com

Interesting, it runs (doesn’t break) but no feedback at all in Script Editor

Szabolcs Matefy

unread,
Sep 12, 2013, 4:39:42 AM9/12/13
to soft...@listproc.autodesk.com

Resolved, some of my registry key didn’t have a value for crashcount

Ciaran Moloney

unread,
Sep 12, 2013, 4:41:30 AM9/12/13
to Softimage Mailing list
Really solid here on linux, but not doing any rendering.
However, 9 times out of 10 there is a segfault reported at the console upon quitting the program.



Doeke Wartena

unread,
Sep 12, 2013, 5:28:36 AM9/12/13
to soft...@listproc.autodesk.com
who 2012sap crashed really a lot on that image :)


2013/9/12 Ciaran Moloney <moloney...@gmail.com>

Jens Lindgren

unread,
Sep 12, 2013, 6:48:43 AM9/12/13
to soft...@listproc.autodesk.com
Very nice script there. I too had problems with it at first because some Softimage versions didn't have any crashCount value. Probably because it never crashed :)
Here's my ugly fix to the script:
if QueryInfoKey(pi_key)[1] > 4:
    value = QueryValueEx(pi_key, "crashCount" )
    dCrashes[ s ] = value[0]
else:
    dCrashes[ s ] = 0
 
 
/Jens
 
 
Reply all
Reply to author
Forward
0 new messages