XNAT ML 1.8 ML 1.0 Orthanc not running with the latest version of ML

25 views
Skip to first unread message

computerv...@gmail.com

unread,
Jul 29, 2021, 1:39:37 PM7/29/21
to xnat_discussion
Hi XNATler,

I updated my Beta XNAT ML from 0.8 to the new 1.8 an the orthanc is not running.
Any ideas?
There is nothing in the given manifest about the orthanx (xnat-pacs), besides its the wrong name in the description.
I try to to start the orthanc by hand and gives me that:

WARNING: The XNAT_DATASOURCE_DRIVER variable is not set. Defaulting to a blank string.
WARNING: The XNAT_DATASOURCE_URL variable is not set. Defaulting to a blank string.
WARNING: The XNAT_DATASOURCE_USERNAME variable is not set. Defaulting to a blank string.
WARNING: The XNAT_DATASOURCE_PASSWORD variable is not set. Defaulting to a blank string.
ERROR: build path /home/diz/xnat-docker-compose/orthanc/orthanc either does not exist, is not accessible, or is not a valid URL.

My guess is, there is something missing in the whole gradle instalation process. Xnat is running, but there is no xnat-pacs in the docker running. Any ideas where to look?

Thanks,

Ralf

kel...@wustl.edu

unread,
Jul 30, 2021, 11:01:11 AM7/30/21
to xnat_discussion
Hi Ralf,

The Orthanc configuration is not included in the master branch of our docker-compose yaml file due to the inherent problems that come with running Tomcat, Postgres, and NGINX, along with a full PACS, on a single system - namely resource depletion.  

The ML-BETA distribution of our docker-compose configuration should only be used as a small-scale demo or development system, with limited expectations regarding performance and scale.  Assuming you're okay with those limitations, you might copy over relevant sections of your ML docker-compose.yml file along with database initialization commands from the postgres/XNAT.sql script.

For moderate to larger-scale systems, we recommend running Orthanc independently, on its own VM or SWARM node.

Best,

Matt

computerv...@gmail.com

unread,
Nov 18, 2021, 4:12:03 AM11/18/21
to xnat_discussion
Thanks for the answer. It helped and I followed your advice.
Yours, Ralf
Reply all
Reply to author
Forward
0 new messages