It seems that there are two naming schemes for static/import libraries built with GCC on MS Windows. One is used for files built with the bundled GCC makefile (same as for MSVC), the other when building with GCC makefile generated with bundled CMake file (matches configure one?). For example, for the base library it is libwxbase31ud.a
This means that the file names produced using CMake are not only different from those used by the official binaries but AFAICT they are also incompatible with CMake’s module FindwxWidgets used via find_package(), doing which is recommended by wxWidgets documentation and demonstrated in the minimal sample.
FWIW, it appears that this naming scheme is also incompatible with 3rd party tools such as Code::Blocks wxWidgets project wizard or wx-config Windows executable used by CodeLite.
I am not asking for it to be changed, I am just curious about why this choice was made and wanted to ask before 3.2 is released and this is set in stone forever.