Raspberry Pi3 Jessie - issues but finally got it compiled/installed

264 views
Skip to first unread message

robbob2112

unread,
Jun 9, 2016, 6:41:47 PM6/9/16
to wview
Hi all,

Switching from an old FreeBSD box to a Raspberry Pi 3 running Raspbian jessie... 

Fixed it up so it boots from a USB drive verse the flash card... i.e. changed root in /boot/cmdline.txt and the mount point in /etc/fstab.... so now it only uses the SD card for reading the inital files and then switches to a 1TB 2.5" drive to run from.  WDpidrive kit for anyone interested.... low power USB drive with special cable to power it all.... not using their boot loader since it runs a squeeze filesystem and is far slower than from the drive directly.

Had a whole variety of issues that I worked through one at a time... probably not the correct way in some cases... But thought I'd post and see if anyone has a better way.

First go-around just tried the wheezy PPA and had no luck ... errors below

# Added this to the sourcelist file

deb http://www.wviewweather.com/apt/wheezy wheezy main

apt-get install wview

The following packages have unmet dependencies:
 wview : Depends: libgd2-noxpm (>= 2.0.36~rc1~dfsg) but it is not installable or
                  libgd2-xpm (>= 2.0.36~rc1~dfsg) but it is not installable
E: Unable to correct problems, you have held broken packages.


So, off to compile from sources for both radlib and wview  -- which means adding dependencies manually verse letting apt-get do it..

# install dependencies (collected after the fact since I kept adding them one at a time)

apt-get install sqlite3 libssl-dev libudev libcurl4 gawk libreadline5 libgd2-xpm-dev libgd2-noxpm-dev libsqlite3-dev libgd-tools

# radlib was simple enough

wget http://downloads.sourceforge.net/project/radlib/radlib/radlib-2.12.0/radlib-2.12.0.tar.gz
tar -zxf radlib-2.12.0.tar.gz
cd radlib-2.12.0
./configure --enable-sqlite
make
make install


# wview on the other hand was a royal pain  -- using wview-5.21.7

Then just a configure and a make right?... no such luck....

it bombed out compiling 3 stations  WMRUSB,  WH1080, and TE923.... all three the same error message about not finding 'lubs-1.0' on the system...  


Since I have a VantagePro I don't care about those working or not... so I just edited the Makefile in each station and removed the reference to it.  I assume there is some better way to do this or a package I am missing

Anyways,

It is installed now but I haven't tested it yet... will do that tomorrow.

Robert




robbob2112

unread,
Jun 10, 2016, 1:36:16 PM6/10/16
to wview
Well Today ...

Copied over my old configs from version 5.20.2 and had some fun issues with added lines in the config from the interim version

Had to add use sqlite3 command line to add the missing config items..... copy/pasted from the .sql provided with the package for setting up blank DB..

INSERT INTO "config" VALUES('SSH_1_TIMEOUT','120','SSH session timeout (secs):','ENABLE_SSH');
INSERT INTO "config" VALUES('SSH_2_TIMEOUT','120','SSH session timeout (secs):','ENABLE_SSH');
INSERT INTO "config" VALUES('SSH_3_TIMEOUT','120','SSH session timeout (secs):','ENABLE_SSH');
INSERT INTO "config" VALUES('SSH_4_TIMEOUT','120','SSH session timeout (secs):','ENABLE_SSH');
INSERT INTO "config" VALUES('SSH_5_TIMEOUT','120','SSH session timeout (secs):','ENABLE_SSH');


Also moved /usr/local/var/wview and /usr/local/var/wviewmgmt to the default apache root of /var/www then symlinked them back.  Also had to chown 33:33 those directories and files so the apache process could write to them.  

NOTE about my setup... the RPi is inside my network and behind firewalls and the like and once it completes generating pages they are copied to an external webserver...So I try to follow best practices on security for file perms and the like, but if something has to be opened a little wider it isn't exposed to the internet anyways. 

copied ~wviewcompile/examples/Debian/wview over to init.d then this to make it start at boot and run level 3 since I run with no gui enabled.

update-rc.d wview defaults
update-rc.d wview enable 3

Set the station connection to /dev/ttyUSB0 verse the FreeBSD equivalent of /dev/cuaU0

Started it up and miracles do happen, it is running, collecting new data and generating the web pages...   One little hitch is that they are not being done with the same templates and background images like they ought to be... Seems like I edited the templates years back to make the day/night background the same...  Simple enough to figure out/fix this little bit.  And the copy to the external server isn't working yet.

Robert

robbob2112

unread,
Jun 10, 2016, 2:58:50 PM6/10/16
to wview
And everything is working properly and survives a reboot and starts working again.

I have one odd thing that I never noticed when running on FreeBSD ... When wview starts up htmlgend takes quite a long time to start up...

A lot of this sort of thing in the log... while it is doing it.....   Is that normal or have I missed something?

Jun 10 12:54:40 raspberrypi htmlgend[734]: <1465584880071> : htmlHistoryInit: MONTH: samples=100
Jun 10 12:54:40 raspberrypi htmlgend[734]: <1465584880808> : htmlHistoryInit: MONTH: samples=150
Jun 10 12:54:41 raspberrypi htmlgend[734]: <1465584881574> : htmlHistoryInit: MONTH: samples=200
Jun 10 12:54:42 raspberrypi htmlgend[734]: <1465584882310> : htmlHistoryInit: MONTH: samples=250
Jun 10 12:54:43 raspberrypi htmlgend[734]: <1465584883065> : htmlHistoryInit: MONTH: samples=300
Jun 10 12:54:43 raspberrypi htmlgend[734]: <1465584883810> : htmlHistoryInit: MONTH: samples=350
Jun 10 12:54:44 raspberrypi htmlgend[734]: <1465584884544> : htmlHistoryInit: MONTH: samples=400
Jun 10 12:54:44 raspberrypi rsyslogd-2007: action 'action 17' suspended, next retry is Fri Jun 10 12:55:14 2016 [try http://www.rsyslog.com/e/2007 ]
Jun 10 12:54:45 raspberrypi htmlgend[734]: <1465584885285> : htmlHistoryInit: MONTH: samples=450
Jun 10 12:54:46 raspberrypi htmlgend[734]: <1465584886019> : htmlHistoryInit: MONTH: samples=500
Jun 10 12:54:46 raspberrypi htmlgend[734]: <1465584886751> : htmlHistoryInit: MONTH: samples=550



BTW the performance of the RPi3 running straight from a USB drive is almost as good as my 5 year old laptop running Fedora ...   so color me impressed ... and now that I've used my RPi3 for this I guess I need to buy another one to tinker with.


Robert




On Thursday, June 9, 2016 at 4:41:47 PM UTC-6, robbob2112 wrote:

Marcio

unread,
May 25, 2018, 6:57:51 PM5/25/18
to wview
I created a card with the image of raspbian Jessie (debian 8) and Stretch (debian 9) with several other tools, with GPIO, and Wview working.

One image got a little big (~ 8GB). I'm trying to slow down to the cloud

Anyone interested?
Best
Marcio

William Webb

unread,
Dec 19, 2018, 1:33:20 PM12/19/18
to wview
I am interested but I need WS1080 to work.  That's what I am using.

Marcio

unread,
Feb 7, 2019, 6:18:29 PM2/7/19
to wview
Hi
i'm using davis vantage pro
Reply all
Reply to author
Forward
0 new messages