problem exporting wview data to weewx

61 views
Skip to first unread message

William Webb

unread,
Mar 25, 2018, 4:16:16 PM3/25/18
to wview
Like many on this forum, I am plotting the transition to weewx.  I have weewx running on a spare PI with a spare weather station ( a hanger queen whose parts are slowly disappearing).  I made a copy of wview-archive.sdb (35 MB), renamed it weewx.sdb and replace the existing weewx.sdb with it. I rebooted weewx and all appeared well, at first.  I can see my wview daily, weekly and monthly data in weewx but I do not see older data on the yearly weewx page. The yearly page only shows about a month worth of recent data.  Much older data exists. What on earth could be wrong?  

I would add more diagnostic info to this post but I am not sure what would be helpful.

Any suggestions?

Bill - AB6OR 

Jonathan Ryshpan

unread,
Mar 26, 2018, 1:27:02 AM3/26/18
to wv...@googlegroups.com
There may be small differences in format between different versions of the SQLite libraries. I had similar difficulties importing data into a new compilation of wview. The sqlite3 utility seems to be able to handle all versions. Try the attached conversion script (which is hardly tested, use with care.)

jon
sql-conv
Message has been deleted

William Webb

unread,
Mar 27, 2018, 10:41:59 AM3/27/18
to wview
Thanks.  I will keep the script in my back pocket.  Turned out the 'problem' was impatience. The yearly graph does not update at the archive period.  It updates daily.  The next day all was well.

Thanks AB6OR

Tom Keffer

unread,
Mar 27, 2018, 7:58:11 PM3/27/18
to wview
Just for the record, all weeWX plots update as often as their aggregation interval. By default, yearly plots use a one day aggregation, so they get updated daily.

-tk
Reply all
Reply to author
Forward
0 new messages