Kubuntu 17.10 - libgd - libpng issue

28 views
Skip to first unread message

Richard Back

unread,
Nov 1, 2017, 7:11:10 AM11/1/17
to wview
Hi All,

I am in the process of updating an old server that has been running wview for over five years and I just installed kubuntu 17.10.  I have built about three or four of these platforms over the past few years and have never seen an issue quite like this.  This is not a direct wview build issue but looking for some guidance on the problem.

working through the package install list:  all in /usr/local/...
libz: built and installed
linpng(V1.6.32): built and installed
libgd(V2.2.5): built and installed
NOTE the other packages were built and installed if not available as apt-get packages

When I tried to build wview it failed, do to no libgd png suppport.  ran ldd on libgd.so and there was no dependency of the libpng library.

I have checked the /usr/local/lib and /usr/local include directories and the libpng libs and includes look to be there and links configured correctly.  I have tried building the libgd package as myuser, su, and even root to eliminate privilege issues and I get the same result.  I have even looked at my kubuntu 14 system and the libgd configure and it reported not finding the libpng package but it built correctly and has been running for a couple of years.

Has anyone run into this or a similar issue before?

Thanks in Advance

Maxwell Taylor

unread,
Nov 1, 2017, 5:04:56 PM11/1/17
to wv...@googlegroups.com
It was necessary to install the dev libraries for both these packages when I last installed from source on Raspbian.
--
You received this message because you are subscribed to the Google Groups "wview" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wview+un...@googlegroups.com.
To post to this group, send email to wv...@googlegroups.com.
Visit this group at https://groups.google.com/group/wview.
For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages