Rain data missing from DB

52 views
Skip to first unread message

Marius

unread,
Jun 12, 2009, 9:51:58 PM6/12/09
to wview
On the VantagePro2 console I see 30.2mm, whereas on the web page I see
0.51" = 12.9mm. wview had stopped @ 0.36". I then restarted the
daemon, but how do I get the missing data into the DB?

Dr Boulet

unread,
May 30, 2018, 5:46:52 PM5/30/18
to wview
I have the same problem my wmr88 is seeing rain fall but there is nothing in wview this happened suddenly.before I had no problem at all.ibthink I didn’t change anything on my raspberry
I found a topic of someone having exactly the same problem. He deleted sdb files and then it was ok
I did the same but didn’t solve the problem for me
Any idea?
Message has been deleted

Dr Boulet

unread,
Jun 2, 2018, 12:07:04 PM6/2/18
to wview
Actually I can see rain data in current conditions
But not in the history data
It appears to be the same with other data pressure humidity wind
help cheers

Graham Eddy

unread,
Jun 2, 2018, 11:49:48 PM6/2/18
to wview Google Group
summary graphs work off the historical files, and wview incrementally adds to the historical files as summary data becomes available. if the historical files does not exist when wview starts up, it notices the absence and re-creates the historical file from archive data

if summary graphs are showing “holes” in the data, i suggest removing all the historical .sdb files and letting wview re-create them from the archive .sdb - they are just cached summaries derived from archive data

to be more precise, something like
 $ stop wview
 $ cd var/wview/archive
 $ mv wview-hilow.sdb wview-hilow.sdb-save
 $ mv wview-history.sdb wview-history.sdb-save
 $ mv wview-noaa.sdb wview-noaa.sdb-save
 $ # DO NOT mv wview-archive.sdb AS THIS IS THE MASTER DATA
 $ start wview
noting that re-generating the history files can take long time if slow cpu and lots of history - be patient, watch the logs

and if using the NOAA files then, before starting wview, also put their whole folder aside, something like
 $ cd var/wview
 $ mv noaa noaa-save

finally, when confident that all is working properly, remove the saved files
____________
Graham Eddy

--
You received this message because you are subscribed to the Google Groups "wview" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wview+un...@googlegroups.com.
To post to this group, send email to wv...@googlegroups.com.
Visit this group at https://groups.google.com/group/wview.
For more options, visit https://groups.google.com/d/optout.

Dr Boulet

unread,
Jun 3, 2018, 4:17:09 AM6/3/18
to wview
Hi Graham
Thank you so much for your help
For some reason command drop and save are unknown
In addition Wview is Located I. / etc
So I did your ttutorial in this directory

Graham Eddy

unread,
Jun 3, 2018, 4:46:01 AM6/3/18
to wview Google Group
for the record (forum), the location of wview files depends on your platform, and whether you install binaries or build from source code.
  on my macOS box (built from source code), it is under /opt/local/.
  on my ubuntu box (built from source code), it is under /usr/local/.
i don’t know where a binary installation goes, never tried one...
____________
Graham Eddy

Dr Boulet

unread,
Jun 3, 2018, 2:27:31 PM6/3/18
to wview
Ok

Dr Boulet

unread,
Jun 3, 2018, 2:29:21 PM6/3/18
to wview
Sorry it is command stop and start that are unknown (automatic correction is sometimes very bad

Dr Boulet

unread,
Jun 18, 2018, 5:40:12 AM6/18/18
to wview
Still having no data recorded
I will try to reinstall wview

Graham Eddy

unread,
Jun 18, 2018, 5:45:47 AM6/18/18
to wview Google Group
is any data coming in from the weather station at all?
or into computer?
on from computer into wview?
____________
Graham Eddy

On 18 Jun 2018, at 7:40 pm, Dr Boulet <olivier.bou...@gmail.com> wrote:

Still having no data recorded
I will try to reinstall wview

Dr Boulet

unread,
Jun 18, 2018, 6:20:12 AM6/18/18
to wview
Yes data is coming to the Oregon station but not to the rasp

Graham Eddy

unread,
Jun 18, 2018, 6:24:13 AM6/18/18
to wview Google Group
i don’t know what that means. are you saying data is confirmed to be sent to the computer but not arriving at the computer, or sent to the computer but not being processed by the computer?
____________
Graham Eddy

On 18 Jun 2018, at 8:20 pm, Dr Boulet <olivier.bou...@gmail.com> wrote:

Yes data is coming to the Oregon station but not to the rasp

Dr Boulet

unread,
Jun 18, 2018, 6:39:32 AM6/18/18
to wview
I don’t know exactly if data is transferred from the station to the rasp but not processed

It was working perfectly and the problemhappened suddenly without any change on the station or on the rasp

Dr Boulet

unread,
Jun 19, 2018, 5:29:54 AM6/19/18
to wview
I think data is transferred to the rasp since I can see current data but not history

Dr Boulet

unread,
Sep 18, 2019, 11:39:39 AM9/18/19
to wview
Data is transferred from the station to the rasp but incorrectly all data are labeled with the same fixed date it happened suddenly. data station has the right date
Rasp have the right date.something happens during communication.if someone can help
Reply all
Reply to author
Forward
0 new messages