Shared directory in plugin_customization.ini

215 views
Skip to first unread message

Martin

unread,
Sep 6, 2012, 4:37:33 AM9/6/12
to workspac...@googlegroups.com
Hi,

I'm putting together a distribution of eclipse with Workspace Mechanics for our developers and would like Workspace Mechanics to scan a common directory by default. 
From what I understand this is possible via plugin_customization.ini.

Being rather new on these things my (perhaps stupid) question is where do I put this file?
Is it in the plugins folder? Do I need to name it in any special way?

Thanks for your help!

/Martin

Vincent Latombe

unread,
Sep 6, 2012, 5:49:31 AM9/6/12
to workspac...@googlegroups.com
Hello,

you need to edit the eclipse.ini to reference your customization file

something like

-pluginCustomization
custom.ini

Then, in your custom.ini, add something like

# set directory to listen on by workspace mechanic
com.google.eclipse.mechanic/mechanicSourceDirectories=\\\\share\\drive

Hope that helps,

Vincent


2012/9/6 Martin <martin...@gmail.com>

Mats Rappe

unread,
Sep 7, 2012, 5:30:16 AM9/7/12
to workspac...@googlegroups.com
I personaly uses that aproach, since that also allows me to use different preferences for Workspace mechanics depending on user settings at startup. That allows us to start up Eclipse with different worskapce-defaults depending on what department you are working in.
 
Another aproach is to start Eclipse with the argument
-pluginCustomization /var/myDepartment/customization.ini

Holger

unread,
Sep 12, 2012, 4:43:25 AM9/12/12
to workspac...@googlegroups.com
Hi,

does this approach work with Eclipse Juno 4.2 on Windows 7, too?
Until now I tried without success. The Plugin always uses the default location.

Any help is appreciated.
Thanks,
Holger

Robert Konigsberg

unread,
Sep 12, 2012, 7:21:18 AM9/12/12
to workspac...@googlegroups.com

Sadly, I don't know enough about Windows anymore to be able to give a good answer. But if somebody figures it out we can add documentation as need be.

Holger Brands

unread,
Sep 12, 2012, 8:34:16 AM9/12/12
to workspac...@googlegroups.com
I can confirm that it works with Eclipse 3.7.2 on Windows 7.
So, perhaps it's more like a Eclipse 4.2 issue?

Just guessing...
Holger

2012/9/12 Robert Konigsberg <konig...@gmail.com>

Holger

unread,
Sep 15, 2012, 8:41:13 AM9/15/12
to workspac...@googlegroups.com, holger...@googlemail.com
So, was someone able to make this work on Eclipse 4.2, irrespective of the used OS?

Thanks,
Holger

qotsa

unread,
Oct 31, 2012, 11:38:35 AM10/31/12
to workspac...@googlegroups.com, holger...@googlemail.com
Hi, 

I did, but it only work for new workspace that is better than nothing ;)
Reply all
Reply to author
Forward
0 new messages