windmill.settings not found

391 views
Skip to first unread message

jamwellian

unread,
Jul 4, 2009, 12:46:30 AM7/4/09
to Windmill Developers
when i ran:

easy_install -U windmill

the only warnings were:

***************************************************************************
WARNING: The C extension could not be compiled, speedups are not
enabled.
Failure information, if any, is above.
I'm retrying the build without the C extension now.
***************************************************************************
***************************************************************************
WARNING: The C extension could not be compiled, speedups are not
enabled.
Plain-Python installation succeeded.
***************************************************************************

but when i tried to instantiate WindmillTestClient, i got this error:

$ python
Python 2.5.2 (r252:60911, Jul 31 2008, 17:28:52)
[GCC 4.2.3 (Ubuntu 4.2.3-2ubuntu7)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from windmill.authoring import WindmillTestClient
>>> client = WindmillTestClient('test')
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/usr/lib/python2.5/site-packages/windmill-1.2-py2.5.egg/
windmill/authoring/__init__.py", line 145, in __init__
method_proxy = windmill.tools.make_jsonrpc_client()
File "/usr/lib/python2.5/site-packages/windmill-1.2-py2.5.egg/
windmill/tools/__init__.py", line 35, in make_jsonrpc_client
url = urlparse(windmill.settings['TEST_URL'])
AttributeError: 'module' object has no attribute 'settings'

thanks!
john

Mikeal Rogers

unread,
Jul 7, 2009, 2:42:24 PM7/7/09
to windmi...@googlegroups.com
You can't just instantiate WindmillTestClient without getting the rest
of windmill up and running first, the framework needs to get
bootstrapped first.

If you do this from the Python shell it'll work:

from windmill.authoring import setup_module, WindmillTestClient
from windmill.conf import global_settings

global_settings.START_FIREFOX = True
setup_module(sys.modules[__name__])
x = WindmillTestClient()


-Mikeal

John

unread,
Jul 10, 2009, 12:06:23 PM7/10/09
to windmi...@googlegroups.com
thanks, that worked. what should i do to open a page?

>>> client = WindmillTestClient(__name__)
>>> client.open('http://www.example.com')
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
TypeError: __call__() takes exactly 1 argument (2 given)

the reason i need to do this in code is that my site opens a link in a
new window, and windmill doesnt seem to capture my clicks in that new
window. is there a way to tell it to switch to the new window?

thanks, john

Kala C

unread,
Feb 22, 2014, 8:23:49 AM2/22/14
to windmi...@googlegroups.com, jo...@saponara.net
Hi,
 
When I try to instantiate the windmill from my Linux system, I am getting the below error, can you please help me how to get around this?
Thanks in Advance
 
Linux orkxstg4pweb01.espdev.aurdev.national.com.au 2.6.18-308.24.1.0.1.el5xen #1 SMP Tue Dec 4 16:04:50 PST 2012 x86_64 x86_64 x86_64 GNU/Linux
 
[p725635d@orkxstg4pweb01 ~]$ windmill firefox http://www.google.com

Traceback (most recent call last):
  File "/usr/local/bin/windmill", line 9, in <module>
    load_entry_point('windmill==1.6', 'console_scripts', 'windmill')()
  File "/usr/local/lib/python2.7/site-packages/windmill-1.6-py2.7.egg/windmill/bin/windmill_bin.py", line 33, in main
    admin_lib.command_line_startup()
  File "/usr/local/lib/python2.7/site-packages/windmill-1.6-py2.7.egg/windmill/bin/admin_lib.py", line 351, in command_line_startup
    shell_objects = setup()
  File "/usr/local/lib/python2.7/site-packages/windmill-1.6-py2.7.egg/windmill/bin/admin_lib.py", line 153, in setup
    httpd, httpd_thread = run_threaded(windmill.settings['CONSOLE_LOG_LEVEL'])
  File "/usr/local/lib/python2.7/site-packages/windmill-1.6-py2.7.egg/windmill/bin/admin_lib.py", line 95, in run_threaded
    httpd = setup_servers(console_level)
  File "/usr/local/lib/python2.7/site-packages/windmill-1.6-py2.7.egg/windmill/bin/admin_lib.py", line 89, in setup_servers
    httpd = windmill.server.wsgi.make_windmill_server()
  File "/usr/local/lib/python2.7/site-packages/windmill-1.6-py2.7.egg/windmill/server/wsgi.py", line 200, in make_windmill_server
    import https
  File "/usr/local/lib/python2.7/site-packages/windmill-1.6-py2.7.egg/windmill/server/https.py", line 55, in <module>
    from httplib import FakeSocket
ImportError: cannot import name FakeSocket
 
Reply all
Reply to author
Forward
0 new messages