Weird error on Linux Mint 18.3

35 views
Skip to first unread message

Elias Carciente

unread,
Dec 29, 2017, 2:58:52 AM12/29/17
to wikidpad-devel
Hello  am trying to run Widpad on LInux Mint 18.3 and after satisfying all dependencies (I believe), I get this error.

python WikidPad.py 
Traceback (most recent call last):
  File "WikidPad.py", line 1, in <module>
    import WikidPadStarter
  File "/home/ori/tmp/wikidpad/WikidPadStarter.py", line 111, in <module>
    from pwiki.MainApp import App, findDirs
  File "lib/pwiki/MainApp.py", line 27, in <module>
    import WindowLayout
  File "lib/pwiki/WindowLayout.py", line 10, in <module>
    from .wxHelper import LayerSizer, ProxyPanel
  File "lib/pwiki/wxHelper.py", line 726, in <module>
    class wxKeyFunctionSink(wx.EvtHandler, KeyFunctionSink):
TypeError: Error when calling the metaclass bases
    multiple bases have instance lay-out conflict


Does anybody have an idea about what is going on?

Thanks in advance

Elias

Michael Butscher

unread,
Dec 29, 2017, 5:45:25 AM12/29/17
to wikidpa...@googlegroups.com
Which version of WikidPad and which version of Python do you use?


Michael

Elias Carciente

unread,
Dec 29, 2017, 10:46:59 AM12/29/17
to wikidpa...@googlegroups.com
Thanks for your answer,

Python 2.7.12 (default, Nov 20 2017, 18:23:56) 
[GCC 5.4.0 20160609] on linux2


I downloaded WikidPad-2.2-src.zip


Thanks again,

Elias


--
You received this message because you are subscribed to a topic in the Google Groups "wikidpad-devel" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/wikidpad-devel/d-eDn4q3y00/unsubscribe.
To unsubscribe from this group and all its topics, send an email to wikidpad-devel+unsubscribe@googlegroups.com.
To post to this group, send email to wikidpad-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/wikidpad-devel.
For more options, visit https://groups.google.com/d/optout.

Michael Butscher

unread,
Dec 31, 2017, 3:03:23 PM12/31/17
to wikidpa...@googlegroups.com
On 29.12.2017 16:46, Elias Carciente wrote:
> Thanks for your answer,
>
> Python 2.7.12 (default, Nov 20 2017, 18:23:56)
> [GCC 5.4.0 20160609] on linux2
>
>
> I downloaded WikidPad-2.2-src.zip

I guess you try to use it with wxPython 4.0 (aka "Phoenix")?


Unfortunately WikidPad 2.2 and 2.3 won't support that because there would be too
much changes to make it work.

WikidPad 2.2 was originally developed for wxPython 2.8 but may also work with
2.9 and 3.0.



Michael

Elias Carciente

unread,
Jan 1, 2018, 8:26:55 PM1/1/18
to wikidpa...@googlegroups.com
Thank you so much!

That was exactly the problem.

Best regards.

Elias




Michael

Reply all
Reply to author
Forward
0 new messages