Error with London_air_photo demo data

Skip to first unread message

David Wormuth

Dec 16, 2022, 7:39:28 PM12/16/22
to WhiteboxTools
Can't seem to download this file without errors.

Is there a problem with the name? Anyone else grab the file?

Is there a direct download URL?

Dave Wormuth

Whitebox Geospatial Inc

Dec 16, 2022, 8:06:32 PM12/16/22
to David Wormuth, WhiteboxTools

Hi David,


This script seems to work for me (sub in your floating license ID):


Graphical user interface, text, application

Description automatically generated

What version of the Whitebox Workflows for Python (WbW) are you using? V1.0.5?





You received this message because you are subscribed to the Google Groups "WhiteboxTools" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit
For more options, visit

David Wormuth

Dec 16, 2022, 9:11:41 PM12/16/22
to WhiteboxTools
I get this error, with floating license or node-locked:

Downloading sample data...
Traceback (most recent call last):
  File "/Users/dwormuth/Documents/GIS_Data/WhiteboxGeo/", line 14, in <module>
    wbe.working_directory = wbw.download_sample_data('London_air_photo')
TypeError: Request body was invalid.
[Finished in 30.2s with exit code 1]
[cmd: ['python3', '-u', '/Users/dwormuth/Documents/GIS_Data/WhiteboxGeo/']]
[dir: /Users/dwormuth/Documents/GIS_Data/WhiteboxGeo]

All the other demo files downloaded as expected except the London_air_photo.

It's always at 30.2s as well. Weird.

Using 1.0.5 and on macOS Monterey, same error on Windows 10 but takes 31.1s


David Wormuth

Dec 16, 2022, 9:18:49 PM12/16/22
to WhiteboxTools
So I was running this a "build" in Sublime Text on Mac and Windows. Worked when I ran it from the command line.

Must have been a Sublime Text gremlin


Whitebox Geospatial Inc

Dec 16, 2022, 9:23:32 PM12/16/22
to David Wormuth, WhiteboxTools

I’m thankful to hear that it worked out for you David. There is a time-out for the network request, that can impact the success of a download, particularly on slower Internet connections. I have recently upped it to 120 seconds on the development branch and it’ll be available to you when I release v1.0.6 soon. This particular sample data set is the largest of the currently available data sets and so it’s not surprising that you had issue with this one and not the others. Hopefully with the longer time-out that will be available in v1.0.6 others won’t experience this same issue.

Reply all
Reply to author
0 new messages