ipad not a target (appologies! repost with spaces in the ip addy url)

43 views
Skip to first unread message

Sherri Fleming

unread,
Mar 14, 2014, 12:41:17 PM3/14/14
to wei...@googlegroups.com
I do not have a Mac. Using Windows 8.1.

I can see the target when I connect via my computer but the iPad is unable to connect. On a prior machine I was able to get the iPad to connect and only 1 time was it showing in the target list. After that it no longer showed in the target list but it was able to view the local website. So no weinre debugging but at least I could see the site using my local code.

New machine and now I am unable to see the local site. Node.js is installed properly or I could not get the site to run locally on my computer.

This has been added to the index.html file:
<script src="http://10 . 10 . 31 . 61 : 8080/target/target-script-min.js#anonymous"></script>

Server Properties
boundHost: -all-
deathTimeout: 15
debug: false
httpPort: 8080
readTimeout: 5
staticWebDir: C:\Users\Sherri\Documents\ss\node_modules\weinre\web
verbose: false
version: 2.0.0-pre-HH0SN197


I have tried both a global and local install of weinre. No luck with either.

​I run weinre from the local site using this:
 > node.exe ../../../node_modules/weinre/weinre --boundHost -all-

I've also tried uninstalling and reinstalling weinre. It did not help.

Using debug true, it is too long to see the beginning however I see this a the end:

weinre: WeinreClientCommands.logError(["weinre: invocation exception on Object.childNodeInserted(): TypeError: Cannot call method '_insertChild' of undefined",null])
weinre: client c-1: weinre: invocation exception on Object.childNodeInserted(): TypeError: Cannot call method '_insertChild' of undefined

I reran it again and I am not seeing these exceptions this time but no difference in the lack of ipad connecting as a target.

Thank you for any help!
Sherri

Sherri Fleming

unread,
Mar 14, 2014, 2:03:05 PM3/14/14
to wei...@googlegroups.com
I also tried connecting to it via my android phone with no luck. The demo also is not working on both devices.

-Sherri

Patrick Mueller

unread,
Mar 14, 2014, 5:40:15 PM3/14/14
to wei...@googlegroups.com
Sherri - 

I wonder if your devices and your Windows 8.1 machine are on different networks?  Are your devices connected to Wifi or cell, and the Windows 8.1 connected differently?  It might be the machines can't actually talk to each other.

Is the demo working on your Windows 8.1 machine?  That is, open the demo application in Chrome on your Windows 8.1 machine; hopefully at least that works.

Are you debugging just a web page, or a Cordova application?  If a web page, what server is that web page running on?

There's not much point in installing weinre "locally" - it will install the `weinre` executable in a node_modules/.bin directory that makes it painful to invoke.  Installing "globally" will install weinre somewhere on the path.

Patrick Mueller

unread,
Mar 14, 2014, 6:13:45 PM3/14/14
to wei...@googlegroups.com
I fired up a weinre server on our BlueMix PaaS that you can try using instead of running locally.  If you're having problem having your machines access each other, this should make things easier:


Instructions on how to host your own weinre on the Internets for free or cheap, here:

Sherri Fleming

unread,
Mar 18, 2014, 11:38:20 AM3/18/14
to wei...@googlegroups.com
Thank you for your help. A new day and it works after reinstalling weinre globally. I had done that on Friday without luck.

It will just remain a mystery what I was doing wrong Friday.

Thank you for such a helpful tool!

-Sherri

On Friday, March 14, 2014 11:41:17 AM UTC-5, Sherri Fleming wrote:

Bill Underwood

unread,
Jul 8, 2014, 12:07:38 PM7/8/14
to wei...@googlegroups.com
Is this service still available? I used it a couple of weeks ago (I think) but now I'm getting an odd 404 error. It looks like it's gone. I don't have Heroku set up, and was wondering if anyone has other public weinre debuggers out there?

Patrick Mueller

unread,
Jul 11, 2014, 9:11:52 AM7/11/14
to wei...@googlegroups.com
Sorry, they switched domains on us a few weeks ago.   The server is now running at:

Reply all
Reply to author
Forward
0 new messages