Weinre Install Problem on Windows 8.1

328 views
Skip to first unread message

Spencer Shaw

unread,
Jul 14, 2015, 1:54:22 PM7/14/15
to wei...@googlegroups.com
Hi

On trying to install using:

C:\Windows\System32>npm install -g http://people.apache.org/~pmuellr/weinre/buil
ds/2.0.0-pre-I0Z7U9OV/apache-cordova-weinre-2.0.0-pre-I0Z7U9OV-src.zip


Error:

npm ERR! not a package C:\Users\Spencer\AppData\Local\Temp\npm-4952-73e5bf83\peo
ple.apache.org\~pmuellr\weinre\builds\2.0.0-pre-I0Z7U9OV\apache-cordova-weinre-2
.0.0-pre-I0Z7U9OV-src.zip
npm ERR! Windows_NT 6.3.9600
npm ERR! argv "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs
\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "http://people.apache.org/~
pmuellr/weinre/builds/2.0.0-pre-I0Z7U9OV/apache-cordova-weinre-2.0.0-pre-I0Z7U9O
V-src.zip"
npm ERR! node v0.12.5
npm ERR! npm  v2.11.2
npm ERR! path C:\Users\Spencer\AppData\Local\Temp\npm-4952-73e5bf83\unpack-b338d
bd61513\package.json
npm ERR! code ENOENT
npm ERR! errno -4058

npm ERR! enoent ENOENT, open 'C:\Users\Spencer\AppData\Local\Temp\npm-4952-73e5b
f83\unpack-b338dbd61513\package.json'
npm ERR! enoent This is most likely not a problem with npm itself
npm ERR! enoent and is related to npm not being able to find a file.
npm ERR! enoent
npm ERR! Windows_NT 6.3.9600
npm ERR! argv "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs
\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "http://people.apache.org/~
pmuellr/weinre/builds/2.0.0-pre-I0Z7U9OV/apache-cordova-weinre-2.0.0-pre-I0Z7U9O
V-src.zip"
npm ERR! node v0.12.5
npm ERR! npm  v2.11.2
npm ERR! path C:\Windows\System32\npm-debug.log.8f510755ad79210c9c17d53ea5563d09

npm ERR! code EPERM
npm ERR! errno -4048

npm ERR! Error: EPERM, open 'C:\Windows\System32\npm-debug.log.8f510755ad79210c9
c17d53ea5563d09'
npm ERR!     at Error (native)
npm ERR!  { [Error: EPERM, open 'C:\Windows\System32\npm-debug.log.8f510755ad792
10c9c17d53ea5563d09']
npm ERR!   errno: -4048,
npm ERR!   code: 'EPERM',
npm ERR!   path: 'C:\\Windows\\System32\\npm-debug.log.8f510755ad79210c9c17d53ea
5563d09' }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Windows\System32\npm-debug.log

No log file at  C:\Windows\System32\npm-debug.log


Any advice?

Patrick Mueller

unread,
Jul 14, 2015, 2:15:54 PM7/14/15
to wei...@googlegroups.com, spencer...@gmail.com
You should just be doing an `npm install -g weinre`.  

Note however that there seems to be some issue with npm; using the version shipped with node 0.12, you can run into a "can't find compatible version" issue, even though there are versions available and you're willing to take any.  Works with iojs 2.x though.

Spencer Shaw

unread,
Jul 15, 2015, 8:23:59 AM7/15/15
to wei...@googlegroups.com
npm install -g weinre 
also doesn't work

I was on node.js v0.12.5 and upgraded to v.0.12.7. Both don't work with the Weinre install.

Can't find any instructions on how to get to work with iojs. The Weinre installation docs only talk about node.js.

Any advice?

Below is output from the cmd terminal on Windows 8.1 run as administrator.


C:\Windows\system32>npm install -g weinre
npm ERR! Windows_NT 6.3.9600
npm ERR! argv "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs
\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "weinre"
npm ERR! node v0.12.7
npm ERR! npm  v2.11.3
npm ERR! code ETARGET

npm ERR! notarget No compatible version found: weinre@'*'
npm ERR! notarget Valid install targets:
npm ERR! notarget ["2.0.0-pre-H0WTHDO5-incubating","2.0.0-pre-H1GCS73N-incubatin
g","2.0.0-pre-H3FWTQKQ-incubating","2.0.0-pre-H41DGW8S-incubating","2.0.0-pre-H8
EOSCLN-incubating","2.0.0-pre-H9PU2WST-incubating","2.0.0-pre-HA5N9T49","2.0.0-p
re-HG9PLCRF","2.0.0-pre-HH0SN197","2.0.0-pre-HYFXM3QM","2.0.0-pre-HZ79PDUK","2.0
.0-pre-HZO3BMNG","2.0.0-pre-I0Z7U9OV"]
npm ERR! notarget
npm ERR! notarget This is most likely not a problem with npm itself.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Windows\system32\npm-debug.log

Andrew Langmead

unread,
Jul 15, 2015, 9:11:53 AM7/15/15
to wei...@googlegroups.com

Hi 

I too am having problems installing on Windows 8.1.

I've just installed npm from here: https://nodejs.org/download/

and get the following when trying to install.

C:\Users\Administrator>npm -g install weinre
npm ERR! Windows_NT 6.3.9600
npm ERR! argv "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs
\\node_modules\\npm\\bin\\npm-cli.js" "-g" "install" "weinre"
npm ERR! node v0.12.7
npm ERR! npm  v2.11.3
npm ERR! code ETARGET

npm ERR! notarget No compatible version found: weinre@'*'
npm ERR! notarget Valid install targets:
npm ERR! notarget ["2.0.0-pre-H0WTHDO5-incubating","2.0.0-pre-H1GCS73N-incubatin
g","2.0.0-pre-H3FWTQKQ-incubating","2.0.0-pre-H41DGW8S-incubating","2.0.0-pre-H8
EOSCLN-incubating","2.0.0-pre-H9PU2WST-incubating","2.0.0-pre-HA5N9T49","2.0.0-p
re-HG9PLCRF","2.0.0-pre-HH0SN197","2.0.0-pre-HYFXM3QM","2.0.0-pre-HZ79PDUK","2.0
.0-pre-HZO3BMNG","2.0.0-pre-I0Z7U9OV"]
npm ERR! notarget
npm ERR! notarget This is most likely not a problem with npm itself.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Users\Administrator\npm-debug.log

C:\Users\Administrator>npm -v
2.11.3

C:\Users\Administrator>
 


I've installed io.js too but I can't find any details of how to install via io.js and am completely unfamiliar with it.  Any help would be greatly appreciated.

Many thanks

Andrew

Patrick Mueller

unread,
Jul 15, 2015, 9:12:44 AM7/15/15
to wei...@googlegroups.com, spencer...@gmail.com
As I mentioned, there seems to be some weird problem with npm - it's claiming there are no compatible versions, but there are OBVIOUSLY plenty of versions compatible with "*".  There may some incantation that would work, like `npm -g install wei...@2.0.0-pre-H0WTHDO5-incubating` (or try `2.0.x` instead of the long version string).

Should just work with iojs.  Install iojs.  Use it's version of npm like you would normally.

In lieu of all this, you can use a public weinre server like http://weinre.mybluemix.net/

spencer...@gmail.com

unread,
Jul 15, 2015, 9:44:22 AM7/15/15
to wei...@googlegroups.com
This worked

npm -g install wei...@2.0.0-pre-H0WTHDO5-incubating
--
--
From the weinre Google Group -- http://groups.google.com/group/weinre

---
You received this message because you are subscribed to a topic in the Google Groups "weinre" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/weinre/_FVwB7KnEDs/unsubscribe.
To unsubscribe from this group and all its topics, send an email to weinre+un...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Andrew Langmead

unread,
Jul 16, 2015, 3:40:46 AM7/16/15
to wei...@googlegroups.com
Hi 

I managed to get the same command to install here.

I'm not getting another error however when starting:

C:\Users\Administrator\AppData\Roaming\npm\node_modules\weinre\lib\cli.coffee:66

    if (!path.existsSync(fileName)) return properties;
              ^
---------------------------------------------------------
error: TypeError: undefined is not a function
---------------------------------------------------------
stack:
   cli.coffee:66  - getDotWeinreServerProperties()

I'm guessing this is some sort of node js problem as it seems some expected property is not present.  I don't see anything searching the group though so I guess it's not a common problem.

I'm going to try re-installing node js I think.

Andrew Langmead

unread,
Jul 16, 2015, 6:26:01 AM7/16/15
to wei...@googlegroups.com
I've removed io.js and re-installed node js from the same source.  Sadly this doesn't work.  I wonder if there is a problem with the version I'm running?  Can anyone suggest a recent version that is known to work with Weinre on windows 8.1?

Thanks

Patrick Mueller

unread,
Jul 16, 2015, 8:44:01 AM7/16/15
to wei...@googlegroups.com, andrew....@nexusalpha.com
This seems like a weinre bug.  Long ago, `existsSync()` lived in the `path` module, but has since moved to the `fs` module.  It lived in `path` as deprecated, but I guess has been removed.

I've opened an issue to get it resolved - https://issues.apache.org/jira/browse/CB-9377

I'm currently quite busy.  In the mean time, you should be able to run this in an older version of node, like node 0.10.x
Reply all
Reply to author
Forward
0 new messages