weinre installation problem

636 views
Skip to first unread message

Francesco Reitano

unread,
Jul 1, 2015, 12:57:53 PM7/1/15
to wei...@googlegroups.com
Hi, i try to install weinre but giveme this error:
No compatible version found: weinre@
I use windows 8.1 and npm is updated.

why? i attach the log file

thanks
Francesco
npm-debug.log

Francesco Reitano

unread,
Jul 1, 2015, 1:14:09 PM7/1/15
to wei...@googlegroups.com
i install with this command:
npm install -g http://people.apache.org/~pmuellr/weinre/builds/2.0.0-pre-I0Z7U9OV/apache-cordova-weinre-2.0.0-pre-I0Z7U9OV-src.zip

i don't know why with this command  i can install and with "-g weinre" not....

Patrick Mueller

unread,
Jul 1, 2015, 2:05:56 PM7/1/15
to wei...@googlegroups.com, gpir...@gmail.com
Ya, that's weird.  Did you try `npm -g install weinre@` with the "@"?  That's kinda what it seemed like.  I've never used "@" with nothing after it.

I just tried a basic install myself, here are the versions of npm and node I'm using as well:

13:01:05 pmuellr ~/tmp
$ npm install -g weinre
/usr/local/bin/weinre -> /usr/local/lib/node_modules/weinre/weinre
wei...@2.0.0-pre-I0Z7U9OV /usr/local/lib/node_modules/weinre
├── under...@1.7.0
├── no...@3.0.3 (abb...@1.0.7)
└── exp...@2.5.11 (q...@0.4.2, mi...@1.2.4, mkd...@0.3.0, con...@1.9.2)

═════════════════════════════════════════════════════════════════════════════
13:01:15 pmuellr ~/tmp
$ npm -v
2.10.1

═════════════════════════════════════════════════════════════════════════════
13:01:21 pmuellr ~/tmp
$ node -v
v2.1.0

Spencer Shaw

unread,
Jul 14, 2015, 1:55:33 PM7/14/15
to wei...@googlegroups.com
I can't get to work either  

N'chaka Benjamin

unread,
Jul 21, 2015, 12:26:42 PM7/21/15
to wei...@googlegroups.com
Same issue for me, I couldn't get it to work. Same scenario with the binary file as well. To fix this, you'll have to download the binary file, extract it, then look into the build-info.txt text file and see which version of the Weinre binary you can use.

The most current build version I found was a bit cryptic, it was: 2.0.0-pre-I0Z7U9OV

Then, once you have the version, you'd run the command:

sudo npm -g install weinre@build_version

e.g. sudo npm -g install wei...@2.0.0-pre-I0Z7U9OV

Note: the 'sudo' command is for mac users.

Then you should get weinre back up to speed.

Patrick Mueller

unread,
Jul 21, 2015, 12:52:53 PM7/21/15
to wei...@googlegroups.com, nchakab...@gmail.com
The most recent version of weinre, 2.0.0-pre-I0Z7U9OV , is listed on the npmjs.org page for weinre - so there's no need to download anything

Reply all
Reply to author
Forward
0 new messages