Weewx SDR

98 views
Skip to first unread message

Mark Fraser

unread,
Jul 10, 2022, 11:09:47 AMJul 10
to weewx...@googlegroups.com
I had to rebuild my install of weewx recently as the SD card became
corrupted to the point where I couldn't even use dpkg.

It is all back up and running now, except that every few hours it will
stop receiving data from the WH1080 transmitter whilst still receiving
data from the other 3 devices.

I have checked on my computer which is located further away from the
WH1080 and that is receiving fine.

Is there anything that could be interfering with just one device on
433MHz or is something on the Pi causing it?

f4n...@gmail.com

unread,
Jul 26, 2022, 10:02:31 PMJul 26
to weewx-user
Interesting, did you find a solution? The WH1080 transmitters can get quite wonky on their own: I have one that always resets as soon as the humidity gets too high (usually if it starts raining or sometimes just random), resulting in a new transmitter ID.. My workaround was to just use * instead of always having to manually correct the ID number in the sensor map. Works fine as long as there is just one WH1080 transmitter around. The display console on the other hand won't start to search for a new ID in less than a few hours each time

It's always helpful to use more than one SDR stick and maybe different antennas and usb cables/cable lengths to find out what could cause signal issues. Also, is it connected to ethernet or just wifi? Maybe try with or without an usb hub.




Mark Fraser

unread,
Jul 28, 2022, 10:28:38 AMJul 28
to weewx...@googlegroups.com
I just rebooted the Pi and it seemed to work again after that. No idea
what the issue was, but it was odd that it could receive from all my
other sensors.

It was connected by just wi-fi.
> --
> You received this message because you are subscribed to the Google
> Groups "weewx-user" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to weewx-user+...@googlegroups.com
> <mailto:weewx-user+...@googlegroups.com>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/weewx-user/453c9c36-b99f-47a0-aa61-3626baa2c26dn%40googlegroups.com
> <https://groups.google.com/d/msgid/weewx-user/453c9c36-b99f-47a0-aa61-3626baa2c26dn%40googlegroups.com?utm_medium=email&utm_source=footer>.

f4n...@gmail.com

unread,
Aug 4, 2022, 10:11:38 PMAug 4
to weewx-user
Yeah sometimes there are really odd things with SDR setups, e.g. I have an issue where a FC0012 stick won't recieve any packet from a WS80 sensor, while an R820T2 stick with the antenna only 10cm apart, works just fine and gets nearly every packet (but sometimes freezes, even weewx stopps running then, probably USB related or power issue)
Reply all
Reply to author
Forward
0 new messages