weewx purple air

110 views
Skip to first unread message

rons...@gmail.com

unread,
Aug 26, 2021, 7:31:59 AMAug 26
to weewx-user
Good Morning,

I am getting these errors in my log.

Aug 26 07:18:44 raspberrypi wee_reports[9070] ERROR user.purple: Could not get concentrations from any source.
Aug 26 07:18:45 raspberrypi wee_reports[10999] INFO user.purple: collect_data: Attempt to fetch from: PurpleAir-8ac1 failed: HTTPConnectionPool(host='purpleair-8ac1', port=80): Read timed out. (read timeout=15).

Aug 26 07:27:58 raspberrypi wee_reports[11802] ERROR user.purpleair: sensor error pm10_0_cf_1 disagree. 21.880000 vs 27.840000 
Aug 26 07:27:58 raspberrypi wee_reports[11802] ERROR user.purpleair: sensor error pm10_0_atm disagree. 21.880000 vs 27.840000 
Aug 26 07:27:58 raspberrypi wee_reports[28451] ERROR user.purpleair: sensor error pm1_0_cf_1 disagree. 7.790000 vs 9.820000 
Aug 26 07:27:58 raspberrypi wee_reports[28451] ERROR user.purpleair: sensor error pm1_0_atm disagree. 7.790000 vs 9.820000 


any reason for concern?

John Kline

unread,
Aug 26, 2021, 9:27:35 AMAug 26
to weewx...@googlegroups.com
It looks like you have both the weewx-purple and the weewx-purpleair extensions installed.  You probably should pick one.

As for the errors from weewx-purple (ERROR user.purple), the purpleair device (purpleair-8ac1) is not responding, so yes, that is a problem.

If you decide to keep weewx-purple, rather than weewx-purpleair, do the following:

From a browser on your home network, what happens when you enter the following URL?


I do not think that will work, in weewx.conf, substitute the IP address for purpleair-8ac1 and you should be good.  Alternatively, if you have DNS set up, you could us the DNS name.

On Aug 26, 2021, at 4:32 AM, rons...@gmail.com <rons...@gmail.com> wrote:

Good Morning,
--
You received this message because you are subscribed to the Google Groups "weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to weewx-user+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/weewx-user/e4a46b3b-0aef-4c99-81a8-71d053e9d9d4n%40googlegroups.com.

rons...@gmail.com

unread,
Aug 26, 2021, 3:50:15 PMAug 26
to weewx-user

So it looks like my purple air keeps going off line. The WiFi is connected but the device goes into an unknown state. I contacted purple air for troubleshooting.

typically going to this link it goes right into the device.
image.png

John Kline

unread,
Aug 26, 2021, 3:56:01 PMAug 26
to weewx...@googlegroups.com
Got it.  Besides that issue, you really should have only one of weewx-purple or weewx-purpleair installed.  Pick one and uninstall the other.

On Aug 26, 2021, at 12:50 PM, rons...@gmail.com <rons...@gmail.com> wrote:



rons...@gmail.com

unread,
Aug 27, 2021, 7:48:21 AMAug 27
to weewx-user
thanks

rons...@gmail.com

unread,
Sep 1, 2021, 4:48:49 PMSep 1
to weewx-user
HI, now it looks like the data has stopped populating in the database
stuck at 489 records.

I just replaced my tempest with a new one.

syslog attached , I don't see any errors.

My purple air is stable.

weewx.conf attached

any help would be appreciated
weewx.conf
syslog

vince

unread,
Sep 1, 2021, 6:11:57 PMSep 1
to weewx-user
Your logs show nothing obvious but I suspect your hostname 'PurpleAir-8ac1' is not resolvable from the weewx system.   Just a guess.

vince

unread,
Sep 1, 2021, 6:14:47 PMSep 1
to weewx-user
oops - you didn't say which system wasn't populating records.  Was it the WF or the PA ?

If you changed to a new Tempest sensor the serial number has to be changed in weewx.conf to match.

Ron Sell

unread,
Sep 1, 2021, 6:47:11 PMSep 1
to weewx...@googlegroups.com
It’s the purple air not populating.
The purple air has data .

When I go to the hostname/json all the data is there.

I updated my conf with the new tempest data.


--
You received this message because you are subscribed to the Google Groups "weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to weewx-user+...@googlegroups.com.

gjr80

unread,
Sep 1, 2021, 7:15:35 PMSep 1
to weewx-user
I know nothing about Purple Air but this sure looks like an error to me:

Sep  1 16:36:37 raspberrypi weewx[1293] DEBUG weewx.engine: Loading service user.purple.Purple
Sep  1 16:36:38 raspberrypi weewx[1293] INFO user.purple: Service version is 3.0.2.
Sep  1 16:36:38 raspberrypi weewx[1293] ERROR user.purple: Could not get concentrations from any source.
Sep  1 16:36:38 raspberrypi weewx[1293] ERROR user.purple: No sources configured for purple extension.  Purple extension is inoperable.
Sep  1 16:36:38 raspberrypi weewx[1293] DEBUG weewx.engine: Finished loading service user.purple.Purple

Gary

John Kline

unread,
Sep 1, 2021, 8:23:20 PMSep 1
to weewx...@googlegroups.com
He doesn’t have the purple extension configured in weewx.conf, so he’ll get that message since no sources are configured.

To get rid of that message change the following:
data_services = user.purple.Purple,
to
data_services = ,

A proper uninstall would have removed it.

As for the PurpleAirMonitor you do have configured, perhaps ask the author.


On Sep 1, 2021, at 4:15 PM, gjr80 <gjrod...@gmail.com> wrote:

I know nothing about Purple Air but this sure looks like an error to me:

rons...@gmail.com

unread,
Sep 2, 2021, 7:59:45 AMSep 2
to weewx-user

thanks i removed the purple reference.

Ill reach out to the author
Reply all
Reply to author
Forward
0 new messages