weewx web pages stuck in the past.

37 views
Skip to first unread message

Ben Hohman

unread,
Aug 2, 2022, 4:30:52 PMAug 2
to weewx-user
Seems to be stuck in the past.  It was doing this on my old PI, running 3.5.  I got a newer pi and installed 4.8 and edited the config and copied over the db file (after stopping it).

restart of the service: syslog.
Aug  2 13:23:53 weewx systemd[1]: Stopping weewx weather system...
Aug  2 13:23:53 weewx weewx[419] INFO __main__: Terminating weewx version 4.8.0
Aug  2 13:23:53 weewx systemd[1]: weewx.service: Succeeded.
Aug  2 13:23:53 weewx systemd[1]: Stopped weewx weather system.
Aug  2 13:23:53 weewx systemd[1]: weewx.service: Consumed 25min 1.090s CPU time.
Aug  2 13:24:13 weewx systemd[1]: Started Session 30 of user buster.
Aug  2 13:24:32 weewx systemd[1]: Started weewx weather system.
Aug  2 13:24:32 weewx weewx[6417] INFO __main__: Initializing weewx version 4.8.0
Aug  2 13:24:32 weewx weewx[6417] INFO __main__: Using Python 3.9.2 (default, Mar 12 2021, 04:06:34) #012[GCC 10.2.1 20210110]
Aug  2 13:24:32 weewx weewx[6417] INFO __main__: Platform Linux-5.15.32-v7+-armv7l-with-glibc2.31
Aug  2 13:24:32 weewx weewx[6417] INFO __main__: Locale is 'en_US.UTF-8'
Aug  2 13:24:32 weewx weewx[6417] INFO __main__: Using configuration file /home/weewx/weewx.conf
Aug  2 13:24:32 weewx weewx[6417] INFO __main__: Debug is 0
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.engine: Loading station type Vantage (weewx.drivers.vantage)
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.engine: StdConvert target unit is 0x1
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.wxservices: StdWXCalculate will use data binding wx_binding
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.engine: Archive will use data binding wx_binding
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.engine: Record generation will be attempted in 'hardware'
Aug  2 13:24:32 weewx weewx[6417] ERROR weewx.engine: The archive interval in the configuration file (300) does not match the station hardware interval (1800).
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.engine: Using archive interval of 1800 seconds (specified by hardware)
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.restx: StationRegistry: Registration not requested.
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.restx: Wunderground-RF: Data for station KWAABERD11 will be posted
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.restx: PWSweather: Posting not enabled.
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.restx: CWOP: Posting not enabled.
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.restx: WOW: Posting not enabled.
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.restx: AWEKAS: Posting not enabled.
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.engine: 'pyephem' detected, extended almanac data is available
Aug  2 13:24:32 weewx weewx[6417] INFO __main__: Starting up weewx version 4.8.0
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.engine: Clock error is -0.94 seconds (positive is fast)
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.engine: Using binding 'wx_binding' to database 'weewx.sdb'
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.manager: Starting backfill of daily summaries
Aug  2 13:24:32 weewx weewx[6417] INFO weewx.manager: Daily summaries up to date
Aug  2 13:24:34 weewx weewx[6417] INFO weewx.engine: Starting main packet loop.
Aug  2 13:24:34 weewx weewx[6417] INFO weewx.restx: Wunderground-RF: Published record 2022-08-02 13:24:35 PDT (1659471875)
Aug  2 13:24:35 weewx weewx[6417] INFO weewx.restx: Wunderground-RF: Published record 2022-08-02 13:24:35 PDT (1659471875)
Aug  2 13:24:36 weewx weewx[6417] INFO weewx.restx: Wunderground-RF: Published record 2022-08-02 13:24:35 PDT (1659471875)
Aug  2 13:24:37 weewx weewx[6417] INFO weewx.restx: Wunderground-RF: Published record 2022-08-02 13:24:37 PDT (1659471877)
Aug  2 13:24:39 weewx weewx[6417] INFO weewx.restx: Wunderground-RF: Published record 2022-08-02 13:24:39 PDT (1659471879)

It keeps publishing data to wunderground, so I know it is reading data from the station.

It doesn't seem that this error is the cause (although I will have to dig into it).
Aug  2 13:24:32 weewx weewx[6417] ERROR weewx.engine: The archive interval in the configuration file (300) does not match the station hardware interval (1800).


Ben Hohman

unread,
Aug 2, 2022, 4:35:15 PMAug 2
to weewx-user
I do see this
Aug  2 13:30:22 weewx weewx[6417] INFO weewx.cheetahgenerator: Generated 8 files for report SeasonsReport in 5.25 seconds
Aug  2 13:30:26 weewx weewx[6417] INFO weewx.imagegenerator: Generated 26 images for report SeasonsReport in 4.11 seconds
Aug  2 13:30:26 weewx weewx[6417] INFO weewx.reportengine: Copied 5 files to /home/weewx/public_html

But it is rendering values for 6/28/22. 

Tom Keffer

unread,
Aug 2, 2022, 4:38:33 PMAug 2
to weewx-user
You didn't include enough of the log to be definitive, but from your description, this sounds like a classic case of corruption of the logger memory.

For how to clear, see the wiki article WeeWX generates HTML pages, but it does not update them.

--
You received this message because you are subscribed to the Google Groups "weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to weewx-user+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/weewx-user/727366fd-1998-461d-b1f1-1bd401b228dbn%40googlegroups.com.

Ben Hohman

unread,
Aug 2, 2022, 6:42:38 PMAug 2
to weewx-user
I was reading that page when your post came in.

For me:
Step 1 - remove battery and power did not work

Step 2 - wee_device --dump  (which on a raspberry running bullseye
/home/weewx/bin>sudo ./wee_device --dump
then
/home/weewx/bin>sudo ./wee_device --clear_memory

Has fixed the problem.

If i have a gap in my data, then this would be a good solution?
https://weewx.com/docs/utilities.htm#Importing_from_Weather_Underground

Thanks,
Ben

Tom Keffer

unread,
Aug 2, 2022, 9:26:53 PMAug 2
to weewx-user
If you used --dump, then you've recovered all you can off the logger. There might be more on the WU. Take a look at what WeeWX is generating and see if much is missing.

If there is still some missing then, yes, you could try to recover it from the WU. However, when you use RapidFire, the WU creates records with odd timestamps --- probably not the same as what you were using. I'm not sure what the results would look like --- I haven't heard of anyone who has tried it. 

If you've got the time and interest, make a copy of your database and give it a try!



Reply all
Reply to author
Forward
0 new messages