new insertion in sensor map

188 views
Skip to first unread message

Peppe

unread,
Aug 7, 2022, 9:32:29 AMAug 7
to weewx-user
Hello everyone, I ask you for a little help to insert the uv and radiation sensors of a whx080 station into my sensor map.
Here is the result of the sudo rtl_433 -M utc -F json command:

{"time": "2022-08-07 13:26:39", "model": "Endoffset-WHx080", "subtype": 2, "uv_sensor_id": 225, "uv_status": "OK", "uv_index ": 2," lux ": 32082.000," wm ": 46,972," mic ":" CRC "}

What is the right line to insert within the weewx.conf sensor map?
thanks for your cooperation and sorry for my bad english

Peppe

unread,
Aug 7, 2022, 9:45:17 AMAug 7
to weewx-user
I used a weeewx 4.8.0 installation using the weewx-sdr driver updated on February 12th of this year and capturing the sensors at 433 mhz with a Nesdr key;
the sdr.py file is from January 22nd

f4n...@gmail.com

unread,
Aug 8, 2022, 3:18:08 AMAug 8
to weewx-user
I've never seen "Endoffset-WHx080", not sure if this is available in sdr.py, but maybe I'm wrong. 

Mine works with following sensor map entries:

UV = uv_index.*.FOWHx080Packet
radiation = light.*.FOWHx080Packet

You can replace * with your ID (necessary if there are other WHx080 stations around)

Peppe

unread,
Aug 8, 2022, 10:44:09 AMAug 8
to weewx-user

first of all thank you so much for answering me. I was wrong in transcribing the syslog.
this is correct: {"time": "2022-08-07 13:26:39", "model": "Fineoffset-WHx080", "subtype": 2, "uv_sensor_id": 225, "uv_status": " OK "," uv_index ": 2," lux ": 32082.000," wm ": 46,972," mic ":" CRC "}
I'll try your suggestions and post them here

Peppe

unread,
Aug 9, 2022, 10:46:09 AMAug 9
to weewx...@googlegroups.com
good evening
I put the two lines on the sensor map but it doesn't work. I am writing you a series of attempts made by me along with your suggestions:
UV = uv_index.225.FOWHx080Packet
radiation = light.225.FOWHx080Packet
radiation = radiation.225.FOWHx080Packet
UV = uv_index.225.FOWH3080Packet
radiation = light.225.FOWH3080Packet
radiation = light.225.FOWH3080Packet
I don't know what I did wrong.
I rewrite the data I receive from my Nesdr:
{"time": "2022-08-09 14:42:36", "model": "Fineoffset-WHx080", "subtype": 2, "uv_sensor_id": 225, "uv_status": "OK", "uv_index ": 3," lux ": 36888.800," wm ": 54.010," mic ":" CRC "}

--
You received this message because you are subscribed to a topic in the Google Groups "weewx-user" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/weewx-user/PohR3wcR1UM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to weewx-user+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/weewx-user/e67461ea-3e02-4979-afd2-7191a4cfc043n%40googlegroups.com.

Peppe

unread,
Aug 9, 2022, 10:49:48 AMAug 9
to weewx...@googlegroups.com
sorry, the last line is wrong
this is what I wanted to write
radiation = radiation.225.FOWH3080Packet

Peppe

unread,
Aug 14, 2022, 8:14:29 AMAug 14
to weewx-user
can anyone help me?

f4n...@gmail.com

unread,
Aug 16, 2022, 12:11:21 AMAug 16
to weewx-user

I currently don't have it in front of me and am just writing from my phone, but maybe i can give a few hints:

Which sdr command do you use in your config file? Try adding:

-Y classic

Which WHx080 model do you have? Is it the old one with separated sensors or the newer all in one sensor array?

Do the other sensors work with your sdr weewx conf?

Please keep in mind, the whx080 never really gave accurate solar radiation readings in the first place, mine showed 600 instead of 900 w/m2 last month. The newer wh65 array does this a lot better imo (but worse for wind gusts instead..)

You will have to add in stdCalibrate -> Corrections

radiation = radiation/126.7

To convert the lux illuminance to w/m2 radiation readings.

There is a way to show the recorded loop packets in the terminal but i can't remember the command, if you find it,  check and see if weewx is getting the data. If so, make sure the uv and radiation fields exist in your database, and whether or not they are listed in your skin.conf (for plots as well as the current values)



Peppe

unread,
Aug 16, 2022, 11:46:27 AMAug 16
to weewx...@googlegroups.com
good evening,
I will try first of all to put order and to answer your questions:
the weather station is a froggit wh3080 with separate sensors at 433 mhz, therefore the old model. Here is the photo in jpg

Profi-radio-Stazione-Meteo-wh3080-luce-UV-USB.jpg
IThis is the result of what the stick sees thanks to the rtl command:
sudo rtl_433  -R 32

time      : 2022-08-16 17:20:15
model     : Fineoffset-WHx080                      Msg type  : 0
Station ID: 226
Battery   : 1            Temperature: 32.9 C       Humidity  : 36 %
Wind Direction: 0        Wind avg speed: 0.00      Wind gust : 0.00
Total rainfall: 65.1     Integrity : CRC
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
time      : 2022-08-16 17:20:27
model     : Fineoffset-WHx080                      Msg type  : 2
UV Sensor ID: 225        Sensor Status: OK         UV Index  : 4
Lux       : 84102.8      Watts/m   : 123.14        Integrity : CRC
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
time      : 2022-08-16 17:20:27
model     : Fineoffset-WHx080                      Msg type  : 2
UV Sensor ID: 225        Sensor Status: OK         UV Index  : 4
Lux       : 84102.8      Watts/m   : 123.14        Integrity : CRC
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
time      : 2022-08-16 17:20:27
model     : Fineoffset-WHx080                      Msg type  : 2
UV Sensor ID: 225        Sensor Status: OK         UV Index  : 4
Lux       : 84102.8      Watts/m   : 123.14        Integrity : CRC

the command lines inserted in the sdr:
driver = user.sdr
cmd = rtl_433 -R 32 -R 40 -R 42
the command lines inserted in the sensor map
UV = uv_index.225.FOWH3080Packet
radiation = radiation.225.FOWH3080Packet
also replaced by another entry
UV = uv_index.225.FOWHx080Packet
radiation = radiation.225.FOWHx3080Packet

finally this is the result of the driver weewx sdr using the command
PYTHONPATH=/home/weewx/bin python /home/weewx/bin/user/sdr.py --config /home/weewx/weewx.conf --hide=parsed,mapped    

 out: ['{"time" : "2022-08-16 15:40:27", "model" : "Fineoffset-WHx080", "subtype" : 2, "uv_sensor_id" : 225, "uv_status" : "OK", "uv_index" : 3, "lux" : 66370.100, "wm" : 97.174, "mic" : "CRC"}\n', '{"time" : "2022-08-16 15:40:27", "model" : "Fineoffset-WHx080", "subtype" : 2, "uv_sensor_id" : 225, "uv_status" : "OK", "uv_index" : 3, "lux" : 66370.100, "wm" : 97.174, "mic" : "CRC"}\n', '{"time" : "2022-08-16 15:40:27", "model" : "Fineoffset-WHx080", "subtype" : 2, "uv_sensor_id" : 225, "uv_status" : "OK", "uv_index" : 3, "lux" : 66370.100, "wm" : 97.174, "mic" : "CRC"}\n']


inside the syslog there is no trace of UV or radiation
 
Profi-radio-Stazione-Meteo-wh3080-luce-UV-USB.jpg

Peppe

unread,
Aug 16, 2022, 12:01:31 PMAug 16
to weewx-user

I use 2 other sensors
one is tfa wind and the other is acurite lightning sensor
I don't use the wind sensor of the wh3080
my skin inside the current.inc the right strings of UV and radiation but the result is UV N / A and radiation N / A

f4n...@gmail.com

unread,
Aug 17, 2022, 8:10:00 AMAug 17
to weewx-user
I just realized it never worked with my WHx080 too (only the usb instance) as I use the radiation from the WH65 in my SDR setup. A quick look into sdr.py reveals why: There is no parsing of uv data for class FOWHx080Packet(Packet) -  Only for class FOWH3080Packet(Packet)

First, make a backup of your sdr.py, then try changing 
 IDENTIFIER = "Fine Offset Electronics WH3080 Weather Station"
to
 IDENTIFIER = "Fineoffset-WHx080"

and see if it works. You might have to use FOWH3080Packet in the sensor map, or maybe add

 return Packet.add_identifiers(pkt, station_id, FOWHx080Packet.__name__)

to @staticmethod in class FOWH3080Packet(Packet):

But first, try with just the identifier change. 

I'll update the Issue you created in https://github.com/matthewwall/weewx-sdr/issues/162
Maybe someone can add it to the weewx-sdr driver

f4n...@gmail.com

unread,
Aug 17, 2022, 9:47:20 PMAug 17
to weewx-user
Just out of interest: why are you using the TFA/Hideki Sensor for wind, instead of the WH3080?  As far as I know, the TFA samples wind gusts much slower, about 11 seconds, resulting in too low wind gust readings. Compared to the 1 second sampling of the WHx080 models (fastest gust out of 48x1s is then sent every 48s). 

Peppe

unread,
Aug 18, 2022, 9:41:41 AMAug 18
to weewx-user
as soon as we have solved the uv problem we will talk about it again

f4n...@gmail.com

unread,
Sep 5, 2022, 12:19:48 PMSep 5
to weewx-user
Seems solved on github, does it work good? Now, how are your experiences with the TFA/Hideki Anemometer compared to the WH3080 Anemometer? 
Reply all
Reply to author
Forward
0 new messages