Firefox 5

97 views
Skip to first unread message

Kai Hendry

unread,
Jul 5, 2011, 4:50:24 AM7/5/11
to webc-users
Hi guys,

The latest builds of Webconverger have a FF5 build in them:
http://build.webconverger.org/webconverger.2011-07-04.iso

http://www.mozilla.com/en-US/firefox/5.0/releasenotes/

Thanks to Daniel Baumann who is celebrating his birthday today. :)

Kind regards,


p.s. @Guttorm be interesting to know if this browser build exhibits
the same startup problems as the previous version on your hardware.
I've seen no problems in VMWARE.

Ben

unread,
Jul 5, 2011, 11:16:12 AM7/5/11
to Webconverger Users


On Jul 5, 3:50 am, Kai Hendry <hen...@webconverger.com> wrote:
> p.s. @Guttorm be interesting to know if this browser build exhibits
> the same startup problems as the previous version on your hardware.
> I've seen no problems in VMWARE.

I'm experiencing the same issues as before. I still haven't had the
time to spend to much time looking at those error logs. I should get a
chance either today or tomorrow. I'd like to point that I haven't
experienced the issues on VMWare either, only on a few of my machines.

-Ben

Guttorm Flatabø

unread,
Jul 8, 2011, 10:55:31 AM7/8/11
to webc-...@googlegroups.com
I've just used hours trying to run the latest build. I've tried four different laptops, and on none of them did it work properly: 

Dell Precision M4500
After four boots without problem I was thinking the problem with iceweasel has been fixed, but on boot number 5 and 6 iceweasel doesn't come up, but works again on attempt number 7.

After iceweasel started on attempt 7, I tried to make a strace log, by modifying pb.sh, and killing X. Unfortunately, iceweasel didn't come up again after killing X, it stopped at the background picture, as with all the failed boot attempts.

Dell Latitude D630
First, it doesn't have firmware for the wireless card, and when WLAN doesn't work, nor does LAN. So I rebuild without wireless, and try again.

The machine starts very fast with LAN, but as I've reported before the network is slower getting up than iceweasel, and on this machine, very much so. I restarted Iceweasel several times before it had finally acquired an IP address. Could be that our DHCP server is slow, but is still a considerable problem.

I try adding strace to pb.sh, kill X, and then, as on the first Dell, it stops at the bg.png.

Dell Inspiron 500m
Won't start at all with Webconverger 8 because:
"This kernel requires the following features not present on the CPU:
pae
Unable to boot - please use a kernel appropriate for your CPU."

Which is not a problem with 7.2. In addition the wireless card (mini-pci) can't be used because Webconverger doesn't have the required legacy firmware.

Acer Travelmate 6492
Booting will stall several times waiting for timeouts. The problem seems to be related with udev, and the wireless card does not come up. I noted some of the messages:

It stalls after this:
"[   21.833909] input: PS/2 Generic Mouse as /devices/platform/i8042/serio4/serio5/input/input11"

Later on says:
"udevadm settle - timeout of 180 seconds reached, the event ...."

stalles at:
"[   261.488245] tpm_tis 00:0b: tpm_transmit: tpm"

Does not happen with 7.2.

Identified bugs/improvements
  • Iceweasel does not start
  • Does not fall back to LAN when WLAN fails
  • Network is too late coming up / acquiring IP address
  • Lacks firmware for wireless network cards
  • Kernel is buggy and/or restricted to newer CPU's
As you can understand, I'm sticking to 7.2, for now...


--
You received this message because you are subscribed to the Google Groups "Webconverger Users" group.
To post to this group, send email to webc-...@googlegroups.com.
To unsubscribe from this group, send email to webc-users+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/webc-users?hl=en.


Kai Hendry

unread,
Jul 10, 2011, 6:16:54 PM7/10/11
to webc-...@googlegroups.com
Thanks ever so much for your testing work here Guttorm.

Apologies for all the regressions in 8.0 :(

2011/7/8 Guttorm Flatabø <po...@guttormflatabo.com>:


> Lacks firmware for wireless network cards
> Kernel is buggy and/or restricted to newer CPU's

In the latest builds I'm now using 486 which will work with older CPUs
and I've added a bunch of wireless firmware.
http://build.webconverger.org

I'm quickly running out of time due to the charity rally I'm
undertaking http://geekout.org.uk/ though I will attempt to make a 8.5
release or something like that. I hope you can find some time to give
the latest builds a whirl.

Many thanks,

Guttorm Flatabø

unread,
Jul 11, 2011, 1:35:50 PM7/11/11
to webc-...@googlegroups.com
I've tried with the latest build. It's looking good, I've summed up at the end.

IBM Thinkpad T42
Didn't try this with 7.2 before. Iceweasel starts. Wireless works fine.

Dell Latitude D620
Haven't tried this one before. Webconverger boots. Iceweasel starts over and over again, haven't tried WLAN.

2011/7/8 Guttorm Flatabø <po...@guttormflatabo.com>

Dell Precision M4500
After four boots without problem I was thinking the problem with iceweasel has been fixed, but on boot number 5 and 6 iceweasel doesn't come up, but works again on attempt number 7.

After iceweasel started on attempt 7, I tried to make a strace log, by modifying pb.sh, and killing X. Unfortunately, iceweasel didn't come up again after killing X, it stopped at the background picture, as with all the failed boot attempts.

Haven't tried wireless on this one before. Webconverger boots, Iceweasel starts, but wireless does not seem to come up:
"iwalign: no suitable firmware found"

Another problem with this machine, is that X doesn't use a proper screen resolution (using "current").

Without internet, iceweasel seems to be starting just fine now, and I've probably tried more than 10 times.

Dell Latitude D630
First, it doesn't have firmware for the wireless card, and when WLAN doesn't work, nor does LAN. So I rebuild without wireless, and try again.

WLAN still no go, I get messages like this (the same as before):
iwlwifi-3945-2.ucode firmware file req failed: -2
iwlwifi-3945-1.ucode firmware file req failed: -2
could not read microcode: -2 

Wit LAN, though, Iceweasel seems to have no problem starting. Internet still takes time to get up, but this is only a problem with this machine.

Dell Inspiron 500m
Won't start at all with Webconverger 8 because:
"This kernel requires the following features not present on the CPU:
pae
Unable to boot - please use a kernel appropriate for your CPU."

Which is not a problem with 7.2. In addition the wireless card (mini-pci) can't be used because Webconverger doesn't have the required legacy firmware.

Webconverger starts.
Wireless fails:
"firmware file "b43legacy/ucode4.fw" not found or load failed"

Iceweasel does not start when WLAN doesn't come up, nor did it with LAN.

Acer Travelmate 6492
Booting will stall several times waiting for timeouts. The problem seems to be related with udev, and the wireless card does not come up. I noted some of the messages:

It stalls after this:
"[   21.833909] input: PS/2 Generic Mouse as /devices/platform/i8042/serio4/serio5/input/input11"

Same stalling as before. 

Identified bugs/improvements
  • Iceweasel does not start
This might have been fixed, or substantially improved. Only the Inspiron 500m has this problem now.
  • Network is too late coming up / acquiring IP address
This seems to be a more exotic problem than I thought before. 
  • Lacks firmware for wireless network cards
No improvement for my machines. 
  • Kernel is buggy and/or restricted to newer CPU's
Kernel does not seem to be resticted to newer machines, but still doesn't work with the Acer.
 
As you can understand, I'm sticking to 7.2, for now...

Will probably use both now.

Guttorm Flatabø

unread,
Jul 11, 2011, 3:01:06 PM7/11/11
to webc-...@googlegroups.com
2011/7/11 Guttorm Flatabø <po...@guttormflatabo.com>
I've tried with the latest build. It's looking good, I've summed up at the end.
Acer Travelmate 6492
Booting will stall several times waiting for timeouts. The problem seems to be related with udev, and the wireless card does not come up. I noted some of the messages:

It stalls after this:
"[   21.833909] input: PS/2 Generic Mouse as /devices/platform/i8042/serio4/serio5/input/input11"

Same stalling as before. 

Just tried booting the LiveDVD of Fedora derived Fuduntu on this machine, and it has the same problem. Which indicates that this is an issue with the kernel/hardware itself and is not specific to the setup Webconverger is using.

Kai Hendry

unread,
Jul 12, 2011, 4:47:26 AM7/12/11
to webc-...@googlegroups.com
2011/7/11 Guttorm Flatabø <po...@guttormflatabo.com>:

> WLAN still no go, I get messages like this (the same as before):
> iwlwifi-3945-2.ucode firmware file req failed: -2
> iwlwifi-3945-1.ucode firmware file req failed: -2
> could not read microcode: -2
>> Lacks firmware for wireless network cards
> No improvement for my machines.

Ok, I think I missed out on another firmware package:
http://anonscm.debian.org/gitweb/?p=debian-live/config-webc.git;a=commitdiff;h=0bfbe169f251f252c73c192218e191da14534aec

Daily build has it in:

hendry@x201 ~$ curl -s
http://build.webconverger.org/webconverger.2011-07-12.packages | grep
iwl
firmware-iwlwifi 0.32~artax1

Thanks ever so much for your detailed testing!

Ben

unread,
Jul 14, 2011, 10:11:50 AM7/14/11
to Webconverger Users
Hey Guys,

> In the latest builds I'm now using 486 which will work with older CPUs
> and I've added a bunch of wireless firmware.http://build.webconverger.org

This appears to have solved the browser not loading issue. After some
testing, in which we were unable to reproduce the problem, we have
finally deployed a working Webconverger to all the machines we wanted
to. Thank you very much for such a wonderful product. :)

-Ben

Kai Hendry

unread,
Jul 14, 2011, 10:16:54 AM7/14/11
to webc-...@googlegroups.com
http://webconverger.org/blog/entry/Webconverger_8.5_release_notes/

On 14 July 2011 15:11, Ben <islin...@gmail.com> wrote:
> to. Thank you very much for such a wonderful product. :)

Thank you! :)

Guttorm Flatabø

unread,
Jul 14, 2011, 10:28:17 AM7/14/11
to webc-...@googlegroups.com
I should add that wireless has also been solved more or less. Only card I have trouble with ism Broadcom BCM94306MP, which might be caused by what looks like a complicated install procedure. But I've replaced it with something else that works.

Guttorm Flatabø

unread,
Jul 18, 2011, 9:44:57 AM7/18/11
to webc-...@googlegroups.com
I wnet around upgrading my terminals this weekend, some machines have been running for almost three years without any issues. Pretty awesome, if you ask me :)

However, all is not well, and though I know Kai is going to be racing away soon, I might as well recount some info from my log and speculate as to what causes the problem.

2011/7/8 Guttorm Flatabø <po...@guttormflatabo.com>
  • Iceweasel does not start
While this looks like it is a mostly eliminated problem with the 486 kernel, in addition to the Dell Inspiron 500m, I was unable to use Webconverger 8.5 on a Fujitsu Siemens Lifebook C1320. I think it's from 2005 and it has a "Pentium M", processor.

As the problem seems to be binary, and was introduced with the Artax binaries, maybe it would help to revert back to the binaries used before (but debian live doesn't have up to date Iceweasel?). Was 7.2 using a 386 or 486 kernel, if it was 386, then at least reverting to that should be worth trying?
  • Network is too late coming up / acquiring IP address
This was a problem on almost half of my machines now, and to such a degree that one of the users thought the machine was broken. Iceweasel will come up with a message that the page could not be loaded. Sometimes you have to wait more than 10 seconds after start, and close the browser to reload iceweasel before it comes up. I think it happens exclusively on LAN, and the DHCP servers don't seem to be particularly slow.

Good luck getting all the visas, and getting through all the countries in the rally Kai :)

--
Guttorm
Reply all
Reply to author
Forward
0 new messages