Squid 4.14 installer

91 views
Skip to first unread message

Patrick Sweitzer

unread,
Aug 10, 2021, 5:15:47 PM8/10/21
to Diladele Web Safety
There seems to be a problem with the 4.14 MSI on your website.
I can install it, the diadele squid launcher service appears to start up, but the squid executable core dumps immediately.

If I stop the service and run the executable manually I get this :

C:\Squid\bin>squid.exe
      0 [main] squid 461 cygwin_exception::open_stackdumpfile: Dumping stack trace to squid.exe.stackdump

I uninstalled version 4.14 re-installed 3.5.28 and it functions normally.

Please help!  I have many systems that rely on the squid installation and due to security concerns I cannot go back to version 3.5.28.

Thanks for your assistance!
 

Rafael Akchurin

unread,
Aug 10, 2021, 10:44:55 PM8/10/21
to web-s...@googlegroups.com

Hello Patrick,

 

This seems to be the issue at https://github.com/diladele/squid-windows/issues/95

Might be related to what older native CPU on your servers :/ not clear. Here in the test lab we have no problems running the MSI.

 

Unfortunately I cannot say when the bug is researched/fixed – we cannot do it ourselves because of large involvement into other projects, and Squid team might also be busy.

 

Best regards,

Rafael

--
You received this message because you are subscribed to the Google Groups "Diladele Web Safety" group.
To unsubscribe from this group and stop receiving emails from it, send an email to web-safety+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/web-safety/8db31d96-a640-4c45-a7ae-03b3440b20d5n%40googlegroups.com.

Reply all
Reply to author
Forward
0 new messages