Hello!
Thanks for using wazuh!
You can try the following rules:
<group name="sysmon_eid11_detections,">
<rule id="100028" level="6">
<if_group>sysmon_event_1</if_group>
<field name="win.eventdata.image">^C:\Windows\system32\cleanmgr.exe</field>
<description>Executable file dropped in folder commonly used by malware.</description>
</rule>
<rule id="100029" level="6">
<if_sid>100028</if_sid>
<field name="agent.name">^VW2k19SAPPRD$|^W2k19BKP$</field>
<description>Executable file dropped in folder commonly used by malware on agent $(agent.name).</description>
</rule>
</group>These are parent-child rules, where we have the parent rule that will match the file C:\Windows\system32\cleanmgr.exe among all the events in the sysmon_event1 group.
Then we will have the daughter rule that will generate the alert for this type of event located in the agents with the names of the agents specified in the <field> field.
You can check our documentation about custom rules in the following links:
Custom RulesOverwriting RulesHope this helps, let me know if you need anything else.
Regards,
Luis Avendaño.