Hi Max!
Default value of log_alert_level(3) indicate Successful/Authorized events (successful login attempts, firewall allow events, etc) according to Wazuh Rules Classification. If these types of events are not of your interest, you could increase the log_alert_level, discarding and not storing logs/alerts for rules under that value.
I hope this helps. If you have any other question, do not hesitate to ask.
Regards,
Nico
Hi Max!
You could discard multiple rules creating a new custom one that silence, for example, all successfully authentications no matter the mechanism using if_group. An example could be:
<group name="local,">
<rule id="100001" level="0">
<if_group>authentication_success</if_group>
<description>Silencing Logins</description>
</rule>
</group>
Similar way but using if_sid with specific logins rules (for example 60106, 60118, 60200):
<group name="local,">
<rule id="100001" level="0">
<if_sid>60106, 60118, 60200</if_sid>
<description>Silencing some Windows Logins</description>
</rule>
</group>
Regards,
Nico
Hi Max!
You’re very welcome, happy to help :) . The concept of location is related to where the log is obtained within the agent and no the agent itself. For example, if the log comes from /var/log/syslog, that will be it value. The location option in a rule will try to match it with the log location.
Unfortunately and currently there’s no a unified way to filter by agent with rules. If the events to filter are specifics ones and you know beforehand they have an agent information, i.e Window’s events win.system.computer, you could use CDB list as whitelist and silence them.
Other option is to use agent labels and then filter in Kibana.
Please let me know if this information was helpful.
Regards,
Nico