Based on my experience no you don't have to use logstash if you don't want but is needed for geolocation ...
On the suricata side in the case of the ssh there is a rule on wazuh that detect the Brute Force so maybe that why you can't find it on the alerts as a suricata one .... it happens there is a way to point it to the suricata rule check here : https://groups.google.com/forum/m/?utm_medium=email&utm_source=footer#!msg/wazuh/kAhYgvM9CzA/otvbYJdRCAAJ
On the alerts .... I had the same issue and that's how I fix it .... you can maybe try other attacks that are not default on wazuh so you can be sure that suricata can detect them .... I was about to send a hallmary to one of my client and on that way test as much of both suricata and wazuh but I've been short on time lately ....also you can disable the wazuh rule to make sure suricata can detect it " that's what I was planning "
output.elasticsearch: hosts: ["localhost:9200"] pipeline: geoip-info
On Oct 28, 2019, at 11:31 PM, Rick Gutierrez <xserve...@gmail.com> wrote:
Hi list , I am trying to detect attacks on my servers connected to my
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3TJ_wmjMr9XHEeFoC%3DEJUqxodquA4y%3D-_JMMXHJsDsY0Q%40mail.gmail.com.<suricata-log.jpg>
Regarding about GeoIP, you can compile Suricata with GEoIP support and you'll have geolocation on all Suricata alerts, Rick.
Regards,
C. L. Martinez
________________________________________
From: wa...@googlegroups.com <wa...@googlegroups.com> on behalf of Rick Gutierrez <xserve...@gmail.com>
Sent: 29 October 2019 00:55
Cc: Wazuh mailing list
Subject: Re: Suricata in wazuh does not detect attacks
--
rickygm
http://gnuforever.homelinux.com
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Sftc9fvQPQ6EGnPA84AQeq%2BK%3DcfafUW1dmO-4oZtba9A%40mail.gmail.com.
But as a simple check, you can run "suricata --build-info" and you can see if GeoIP support is enabled.
Regards,
C. L. Martinez
________________________________________
From: Rick Gutierrez <xserve...@gmail.com>
Sent: 30 October 2019 18:43
To: Carlos Lopez
Cc: Wazuh mailing list
Subject: Re: Suricata in wazuh does not detect attacks
El mar., 29 oct. 2019 a las 1:24, Carlos Lopez (<clo...@outlook.com>) escribió:
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Q8PcAv6A0j7zttF%3D7%2BE8xNWtEi2pSMMkr3emp1m3hO7A%40mail.gmail.com.
"alerted": true
<rule id="86600" level="4"> <decoded_as>json</decoded_as> <field name="timestamp">\.+</field> <field name="event_type">\.+</field> <description>Suricata messages.</description> </rule>
<rule id="86605" level="3"> <if_sid>86600</if_sid> <field name="event_type">^flow$</field> <description>Suricata: FLOW.</description> <options>no_full_log</options> </rule>To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Q8PcAv6A0j7zttF%3D7%2BE8xNWtEi2pSMMkr3emp1m3hO7A%40mail.gmail.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Q8PcAv6A0j7zttF%3D7%2BE8xNWtEi2pSMMkr3emp1m3hO7A%40mail.gmail.com.
----Regards,Gergely--Regards,Gergely--Regards,Gergely
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/27494efe-833e-458d-bb4c-944abb62d255%40googlegroups.com.
<rule id="86605" level="3"> <if_sid>86600</if_sid> <field name="event_type">^flow$</field> <field name="flow.alerted">true</field> <description>Suricata: FLOW.</description> <options>no_full_log</options> </rule>
<rule id="86605" level="3"> <if_sid>86600</if_sid> <field name="event_type">^flow$</field> <match>\palerted\p\ptrue</field> <description>Suricata: FLOW.</description> <options>no_full_log</options> </rule>To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Q8PcAv6A0j7zttF%3D7%2BE8xNWtEi2pSMMkr3emp1m3hO7A%40mail.gmail.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/27494efe-833e-458d-bb4c-944abb62d255%40googlegroups.com.
--Regards,Gergely
Hello Jose,The situation is really strange for me. Im tested it in our test environment and yes this rule worked for me.
<rule id="86605" level="3"><if_sid>86600</if_sid><field name="event_type">^flow$</field>
<match>\palerted\p\ptrue</match>
<description>Suricata: FLOW.</description><options>no_full_log</options></rule>
but I got a new suricata alerts for the same checks before the flow. So looks something was wrong on my wazuh changes.TOday I will going to check in our prod env and will see. The full truth is, we have many wazuh related fine tune in our env since my first error.I will come back with my results in 1-2 daysGergely
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Q8PcAv6A0j7zttF%3D7%2BE8xNWtEi2pSMMkr3emp1m3hO7A%40mail.gmail.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/27494efe-833e-458d-bb4c-944abb62d255%40googlegroups.com.
----Regards,Gergely
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/6883e185-5490-4081-825b-db7258979c5b%40googlegroups.com.
--Regards,Gergely
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Q8PcAv6A0j7zttF%3D7%2BE8xNWtEi2pSMMkr3emp1m3hO7A%40mail.gmail.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/27494efe-833e-458d-bb4c-944abb62d255%40googlegroups.com.
--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/6883e185-5490-4081-825b-db7258979c5b%40googlegroups.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Q8PcAv6A0j7zttF%3D7%2BE8xNWtEi2pSMMkr3emp1m3hO7A%40mail.gmail.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/27494efe-833e-458d-bb4c-944abb62d255%40googlegroups.com.
--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/6883e185-5490-4081-825b-db7258979c5b%40googlegroups.com.
----Regards,Gergely--Regards,Gergely--Regards,Gergely
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/32b7892f-04c0-4d64-8bc3-bb632105494c%40googlegroups.com.

To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Q8PcAv6A0j7zttF%3D7%2BE8xNWtEi2pSMMkr3emp1m3hO7A%40mail.gmail.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/27494efe-833e-458d-bb4c-944abb62d255%40googlegroups.com.
--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/6883e185-5490-4081-825b-db7258979c5b%40googlegroups.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/32b7892f-04c0-4d64-8bc3-bb632105494c%40googlegroups.com.
--Regards,Gergely

To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/CAL_GE3Q8PcAv6A0j7zttF%3D7%2BE8xNWtEi2pSMMkr3emp1m3hO7A%40mail.gmail.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/27494efe-833e-458d-bb4c-944abb62d255%40googlegroups.com.
--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/6883e185-5490-4081-825b-db7258979c5b%40googlegroups.com.
--Regards,Gergely--Regards,Gergely--Regards,Gergely
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/32b7892f-04c0-4d64-8bc3-bb632105494c%40googlegroups.com.
--Regards,Gergely