--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/843ece8a-1fd8-4686-b9f9-a58623762e1c%40googlegroups.com.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/843ece8a-1fd8-4686-b9f9-a58623762e1c%40googlegroups.com.
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/142b7249-49ce-4a88-bbd6-1e3589daed1f%40googlegroups.com.
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/f7976fcb-12d3-4302-9906-88df9210b9c5%40googlegroups.com.
Suricata Attack signatures for Eternalblue
# EternalBlue Signature matching potential NEW installation of SMB payloadalert tcp $HOME_NET any -> any any (msg:”EXPLOIT Possible Successful ETERNALBLUE Installation SMB MultiplexID = 82 – MS17-010″; flow:from_server,established; content:”|FF|SMB|32 02 00 00 c0|”; offset:4; depth:9; content:”|52 00|”; distance:21; within:23; classtype:trojan-activity; sid:5000072; rev:1;)# EternalBlue signature matching return signature for connection to pre-installed SMB payloadalert tcp $HOME_NET any -> any any (msg:”EXPLOIT Successful ETERNALBLUE Connection SMB MultiplexID = 81 – MS17-010″; flow:from_server,established; content:”|FF|SMB|32 02 00 00 c0|”; offset:4; depth:9; content:”|51 00|”; distance:21; within:23; classtype:trojan-activity; sid:5000073; rev:1;)
# Signature to identify what appears to be initial setup trigger for SMBv1 – MultiplexID 64 is another unusual valuealert tcp $HOME_NET any -> any any (msg:”EXPLOIT Possible ETERNALBLUE SMB Exploit Attempt Stage 1/2 – Tree Connect AndX MultiplexID = 64 – MS17-010″; flow:to_server,established; content:”|FF|SMB|75 00 00 00 00|”; offset:4; depth:9; content:”|40 00|”; distance:21; within:23; flowbits: set, SMB.v1.AndX.MID.64; classtype:trojan-activity; sid:5000074; rev:1;)
# Signature triggers on Trans2 Setup Request with MultiplexID – 65 – Another unusual MID – Only triggers if 64 was seen previously.alert tcp $HOME_NET any -> any any (msg:”EXPLOIT Possible ETERNALBLUE SMB Exploit Attempt Stage 2/2 – Trans2 SUCCESS MultiplexID = 65 – MS17-010″; flow:to_server,established; content:”|FF|SMB|32 00 00 00 00|”; offset:4; depth:9; content:”|41 00|”; distance:21; within:23; flowbits:isset, SMB.v1.AndX.MID.64; classtype:trojan-activity; sid:5000075; rev:1;)
Suricata Attack signatures for DOUBLE PULSAR
alert tcp any any -> $HOME_NET 445 (msg:”DOUBLEPULSAR SMB implant – Unimplemented Trans2 Session Setup Subcommand Request”; flow:to_server, established; content:”|FF|SMB|32|”; depth:5; offset:4; content:”|0E 00|”; distance:56; within:2; reference:url,https://twitter.com/countercept/status/853282053323935749; sid:1618009; classtype:attempted-user; rev:1;)alert tcp $HOME_NET 445 -> any any (msg:”DOUBLEPULSAR SMB implant – Unimplemented Trans2 Session Setup Subcommand – 81 Response”; flow:to_client, established; content:”|FF|SMB|32|”; depth:5; offset:4; content:”|51 00|”; distance:25; within:2; reference:url,https://twitter.com/countercept/status/853282053323935749; sid:1618008; classtype:attempted-user; rev:1;)
alert tcp $HOME_NET 445 -> any any (msg:”DOUBLEPULSAR SMB implant – Unimplemented Trans2 Session Setup Subcommand – 82 Response”; flow:to_client, established; content:”|FF|SMB|32|”; depth:5; offset:4; content:”|52 00|”; distance:25; within:2; reference:url,https://twitter.com/countercept/status/853282053323935749; sid:1618010; classtype:attempted-user; rev:1;)
Suricata Attack signatures for WannaCry
alert udp $HOME_NET any -> any 53 (msg:"wCry Ransomware - Termination URL Call"; content:"|01 00 00 01 00 00 00 00 00 00|"; offset:2; depth:10; content:"|29|iuqerfsodp9ifjaposdfjhgosurijfaewrwergwea|03|com|00|"; distance:0; fast_pattern; classtype:trojan-activity; sid:5000090; rev:1;)
alert udp $HOME_NET any -> any 53 (msg:"wCry Ransomware - Termination URL Call"; content:"|01 00 00 01 00 00 00 00 00 00|"; offset:2; depth:10; content:"|29|ifferfsodp9ifjaposdfjhgosurijfaewrwergwea|03|com|00|"; distance:0; fast_pattern; classtype:trojan-activity; sid:5000091; rev:1;)
alert udp $HOME_NET any -> any 53 (msg:"wCry Ransomware - Termination URL Call"; content:"|01 00 00 01 00 00 00 00 00 00|"; offset:2; depth:10; content:"|29|ayylmaotjhsstasdfasdfasdfasdfasdfasdfasdf|03|com|00|"; distance:0; fast_pattern; classtype:trojan-activity; sid:5000092; rev:1;)
alert udp $HOME_NET any -> any 53 (msg:"wCry Ransomware - Termination URL Call"; content:"|01 00 00 01 00 00 00 00 00 00|"; offset:2; depth:10; content:"|29|iuqssfsodp9ifjaposdfjhgosurijfaewrwergwea|03|com|00|"; distance:0; fast_pattern; classtype:trojan-activity; sid:5000093; rev:1;)
# This domain needs to remain UNSINKHOLED - Worm will propagate if sinkholed.alert udp $HOME_NET any -> any 53 (msg:"wCry Ransomware - Activation URL Call"; content:"|01 00 00 01 00 00 00 00 00 00|"; offset:2; depth:10; content:"|29|ayylmaoTJHSSTasdfasdfasdfasdfasdfasdfasdf|03|com|00|"; distance:0; fast_pattern; classtype:trojan-activity; sid:5000094; rev:1;)This particular rule triggers on suricata alerts.
<rule id="86601" level="3"> <if_sid>86600</if_sid> <field name="event_type">^alert$</field> <description>Suricata: Alert - $(alert.signature)</description> <options>no_full_log</options></rule>To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/f7976fcb-12d3-4302-9906-88df9210b9c5%40googlegroups.com.
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/68689d5b-5d0b-41d9-a9df-6116add8af06%40googlegroups.com.
Thanks for you guys hel and interest .... I don't know if I understand well... so you mean that I can create a policy to collect the process logs of the windows machines but not in wazuh just on the elk stack ?
Hi Rick
Welcome to the discussion I'm glad me, my ignorance and short knowledge captivate your attention on this topic stay tune for more of my crazy questions 👍
Thanks for you guys hel and interest .... I don't know if I understand well... so you mean that I can create a policy to collect the process logs of the windows machines but not in wazuh just on the elk stack ?

so basically you recommend to implement or pair wazuh with an IDS for better visibility ... this might work on some scenarios but it could be a pain in others... let's said I got a wazuh stack running on a place and I have the NIDS there but got a few spread host on different places that I can't had an NIDS in that case I loose the visibility and the possibility of log the event.
I get that part of the policy what i dont understand was the creation of dashboards for it ..... or the available dashboards on wazuh can handle that ?
On the suricata side i was looking foward to make this kind of deployment didnt know that was that easy..... on the example you send they use logstash it is necessary to use logstash ?.....also can you elaborate a lil bit on why should suricata be installed on both ends "just want to understand better the setup since it require more procesing power to run this kind of deploy"
On other note if i use cdb lists how can it help me improve discovery and incident response ..... or it just can be use to block or ban the blacklist address ....i will need to create a rule to check out the address that match and create a response based on that? im correct
Currently, there is no specific windows auditing dashboard:
- Using the proper filters in the discover section can give you good information about the rule or group of rules associated with the audit windows events.
- Also, if you don't want to type these filters every time you need to visualize a certain group of alerts, you should create a dashboard containing a group of filters and a visualization.
- Logstash isn't mandatory, in the example I posted above Logstash is used to add GeoIP data to alerts and this is out of the Suricata scope.
- About Suricata being installed on both ends, it depends on the traffic you want to monitor and your infrastructure. Depending on this, maybe you can monitor all your networks from one machine using promiscuous mode in network iface or maybe you cant. After installing Suricata you just need to monitor its output logs through Wazuh localfile blocks.
CDB lists are used to check if the event data contains any blacklist/whitelist value and generate alerts(and maybe launch an active response script) when an event contains/doesn't contains a certain attribute value). As you say above, you should create some custom rules to use CDB lists on it. You have an example here.
PD: Wazuh will support MITTRE in upcoming releases. Stay tuned!
It is possible to create active response rules based on the suricata rule set ?
it is necessary to have the cdb list on both the manager and the agent? or it just run on the manager side ?
It is possible to create active response rules based on the suricata rule set ?
- Yes, totally. Custom or default Active-response scripts can be tripped by a specific Suricata alert, or by the Suricata rules group. Here you can check our default Linux and Windows Active-response scripts.
- Maybe you want to check our Blocking attacks with Active-response document for an example of IP blocking through SSH rules and active response.
it is necessary to have the cdb list on both the manager and the agent? or it just run on the manager side ?
- As the agents just forward events, CDB lists should be only on the manager side, preferably in /var/ossec/etc/lists . It's the manager the one that checks these events against the rules and CDB lists.
- If you want to launch an active-response script trough an agent, that agent should have a script copy.
group name="attack,"><rule id="100100" level="10"><if_group>web|attack|attacks</if_group><list field="srcip" lookup="address_match_key">etc/lists/blacklist-alienvault</list><description>IP in black list.</description></rule></group>
--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/b2903116-4147-4665-86fb-85223e8c2891%40googlegroups.com.
i think i sort of figured the rule out
rule run fine did i still need the decoder
testing the rule
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
Hi again Juan
I test the configuration trying a brute Force attack with one of the black list IP address but the alert bring me a different rule Id 5712 to the one that I create 100100 did wazuh has a brute Force rule by default ? ....... the level is correct the attack is the correct one but not the ID

I test the configuration trying a brute Force attack with one of the black list IP address but the alert bring me a different rule Id 5712 to the one that I create 100100 did wazuh has a brute Force rule by default ?
<rule id="5712" level="10" frequency="8" timeframe="120" ignore="60"> <if_matched_sid>5710</if_matched_sid> <description>sshd: brute force trying to get access to </description> <description>the system.</description> <same_source_ip /> <group>authentication_failures,pci_dss_11.4,pci_dss_10.2.4,pci_dss_10.2.5,gdpr_IV_35.7.d,gdpr_IV_32.2,hipaa_164.312.b,nist_800_53_SI.4,nist_800_53_AU.14,nist_800_53_AC.7,</group> </rule><rule id="100100" level="10">
<if_sid>XXXXXX</if_sid>
<list field="srcip" lookup="address_match_key">etc/lists/blacklist-alienvault</list>
<description>IP in black list.</description