Hello John,
If I understand you correctly you want to trigger alerts for applications that passed the Fortigate firewalls and are not inside your
Fortigate-WebApps-Whitelist CDBlist. If that is the case I advice against modifying the default ruleset because we can solve this using custom rules. Please see the custom rules below:
1. This rule is for application that are listed in your CDB list but is silenced as you wanted:
<rule id="222032" level="0" > <if_sid>81633</if_sid>
<list field="app" lookup="match_key">etc/lists/Fortigate-WebApps-Whitelist</list>
<description>Fortigate: App passed by firewall-Whitelist Apps</description>
</rule>
I used the log sample you provided and created the list with the
SSL entry to test.

2. This second rule triggers for applications not listed in your CDB list:
<rule id="222033" level="5" >
<if_sid>81633</if_sid>
<list field="app" lookup="not_match_key">etc/lists/Fortigate-WebApps-Whitelist</list>
<description>Fortigate: App passed by firewall-Needs Investigation for suspicious application</description>
</rule>
This is a second test without the
SSL entry in the list:

Kindly test them and tell me if they suit your needs.