Dear Support
First of all i'll tell you steps that i make
3 - log to Sophos-Central-SIEM-Integration with command cd Sophos-Central-SIEM-Integration
4 - edit config.ini with client id and client id secret
5 - run siem.py with python3
6 - when i run this command it create folder log and inside the folder text file with name result with bath /root/Sophos-Central-SIEM-Integration/log/result.txt
7- Edit the Wazuh agent configuration file (/var/ossec/etc/ossec.conf) to monitor the directory where Sophos logs are stored with this configuration
<localfile>
<log_format>syslog</log_format>
<location>/root/Sophos-Central-SIEM-Integration/log/result.txt</location>
</localfile>
8- i create a group SophosLog and add the agent into the group
the group configuration is
<agent_config>
<localfile>
<log_format>syslog</log_format>
<location>/root/Sophos-Central-SIEM-Integration/log/result.txt</location>
</localfile>
</agent_config>
9 - create rules sample-rules-Sophos.xml with this configuration
<group name="sophoslog,">
<rule id="100075" level="0">
<decoded_as>json</decoded_as>
<field name="app-name">sophos</field>
<description>Sophos central console logs</description>
</rule>
<rule id="100076" level="2">
<if_sid>100075</if_sid>
<field name="severity">low</field>
<description>Sophos: $(severity) severity log on $(source_info.ip): $(type)</description>
</rule>
<rule id="100077" level="5">
<if_sid>100075</if_sid>
<field name="severity">medium</field>
<description>Sophos: $(severity) severity log on $(source_info.ip): $(type)</description>
</rule>
<rule id="100078" level="10">
<if_sid>100075</if_sid>
<field name="severity">high</field>
<description>Sophos: $(severity) severity log on $(source_info.ip): $(type)</description>
</rule>
<rule id="100079" level="14">
<if_sid>100075</if_sid>
<field name="severity">critical</field>
<description>Sophos: $(severity) severity log on $(source_info.ip): $(type)</description>
</rule>
</group>
at last i can't see the logs on the dashboard what is the next step or any thing in this configuration is wrong