Hello,
You just need to append the rule I shared to the one you currently have to look like the block below.
<rule id="112000" level="10">
<if_group>windows</if_group>
<field name="win.eventdata.taskName" negate="yes">^\\\\Microsoft\\\\Office\\\\Office Feature Updates</field>
<field name="win.eventdata.taskName" negate="yes">^\\\\OneDrive Reporting Task</field>
<field name="win.eventdata.taskName" negate="yes">^\\\\Microsoft\\\\Windows\\\\UpdateOrchestrator\\\\USO_UxBroker</field>
<field name="win.eventdata.taskName" type="pcre2" negate="yes">^\\\\Microsoft\\\\Windows\\\\GroupPolicy.*</field>
<field name="win.eventdata.subjectUserSid" type="pcre2" negate="yes">^S-1-5-20.*</field>
<description>Task Scheduler registered</description>
</rule>
But remember, all the conditions (fields) in this rule will have to be evaluated before it can trigger, meaning the task name is NOT one of the common benign system tasks listed, and it was NOT created by the NETWORK SERVICE account
Please let me know if you require further explanation on this.