Hi Pablo,
Sorry for the delay.
The rule I created:
<group name="firewall,fortianalyzer,syslog,">
<rule id="111700" level="4">
<decoded_as>fortianalyzer</decoded_as>
<description>Fortianalyzer: Messages grouped.</description>
</rule>
<rule id="111710" level="3">
<if_sid>111700</if_sid>
<field name="event_category">^traffic$</field>
<description>Fortianalyzer: Traffic logs.</description>
</rule>
<rule id="111742" level="4">
<if_sid>111710</if_sid>
<list field="srcip" lookup="address_match_key">etc/lists/private-ip</list>
<list field="dstip" lookup="address_match_key">etc/lists/private-ip</list>
<description>Fortianalyzer: Internal traffic.</description>
</rule>
<rule id="111745" level="14" frequency="5" timeframe="300">
<if_matched_sid>111742</if_matched_sid>
<same_srcip/>
<same_dstport/>
<different_dstip/>
<dstport negate="yes">^53$|^123$</dstport>
<description>Fortianalyzer: LAN2LAN horizontal scanning detected from a single host to multiple destinations.</description>
</rule>
In order to activate this rule, I need my wazuh to examine five internal traffic logs with the same srcip, dstport, and distinct dstip over a period of five minutes. However, Wazuh is not checking as I need it to when I write this rule. Was the rule written incorrectly?
Wazuh just compares the fourth and fifth logs with the conditions I specified in rule ID 111745; they do not check this condition for all of the prior logs as all 4 previous logs have same dstip.
Please provide a solution for this ASAP
Regards