Hello Louis,
The Windows sysmon event here triggers rule ID 92213 which describes as below:
<rule id="92213" level="15">
<if_group>sysmon_event_11</if_group>
<field name="win.eventdata.targetFilename" type="pcre2">(?i)[c-z]:\\\\Users\\\\.+\\\\AppData\\\\Local\\\\Temp\\\\.+\.(exe|com|dll|vbs|js|bat|cmd|pif|wsh|ps1|msi|vbe)</field>
<options>no_full_log</options>
<description>Executable file dropped in folder commonly used by malware</description>
<mitre>
<id>T1105</id>
</mitre>
</rule>
This rule will be triggered whenever a executable file (exe|com|dll|vbs|js|bat|cmd|pif|wsh|ps1|msi|vbe) is dropped in the "C:\\Users\\USER_NAME\\AppData\\Local\\Temp\\" directory.
Now, if you want to whitelist some specific file or user within this path, you can do this by creating a child rule of 92213 with relevant conditions with rule level 0 as below:
<rule id="111129" level="0">
<if_sid>92213</if_sid>
<field name="win.eventdata.targetFilename">AppxProvider.dll</field>
<options>no_full_log</options>
<description>Ignore RULE</description>
</rule>
You can learn more about the rule syntax and regular expressions here:
I hope it helps. Please let us know if you need anything else here.