Hello Perps,
I have created a sample decoder and matching rule for you below. Feel free to modify this at will to meet your requirements. You can also refer to the documentation on writing and modifying custom decoders and rules.
Decoder in /var/ossec/etc/decoders/local_decoder.xml
<decoder name="Trendvision">
<program_name>CEF</program_name>
<prematch>\|Trend Micro\|Trend Vision One\|</prematch>
</decoder>
<decoder name="trendmicro-child">
<parent>Trendvision</parent>
<prematch>Trend Vision One Observed Attack Technique</prematch>
<regex type="pcre2">^\d+\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|.*?rt=([^=]*?)(?=\s+\w+=).*?cat=([^=]*?)(?=\s+\w+=).*?cs1=([^=]*?)(?=\s+\w+=).*?cs2=([^=]*?)(?=\s+\w+=).*?dpt=([^=]*?)(?=\s+\w+=).*?dst=([^=]*?)(?=\s+\w+=).*?msg=(.*?)(?=\s+\w+=).*?dvchost=([^=]*?)(?=\s+\w+=).*?externalId=([^=]*?)(?=\s+\w+=).*?deviceFacility=([^=]*?)(?=\s+\w+=).*?deviceExternalId=([^=]*?)(?=\s+\w+=).*?deviceProcessName=([^=]*?)(?=\s+\w+=|$)</regex>
<order>vendor,product,version,eventid,eventname,severity,rt,category,mitre_tactic,mitre_technique,dstport,dstip,message,dvchost,externalId,deviceFacility,deviceExternalId,processImage</order>
</decoder>
<decoder name="trendmicro-audit-child">
<parent>Trendvision</parent>
<prematch>Trend Vision One System Audit Log</prematch>
<regex type="pcre2">^\d+\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|.*?rt=([^=]*?)(?=\s+\w+=).*?cat=([^=]*?)(?=\s+\w+=).*?cn1=([^=]*?)(?=\s+\w+=).*?cs1=([^=]*?)(?=\s+\w+=).*?msg=(.*?)(?=\s+\w+Label=|$)</regex>
<order>vendor,product,version,eventid,eventname,severity,rt,category,timestamp,activity,message</order>
</decoder>
And rules in /var/ossec/etc/rules/local_rules.xml
<group name="trendmicro,trendvisionone,">
<rule id="158877" level="3">
<decoded_as>trendmicro-v1-parent</decoded_as>
<description>Trend Vision One Event</description>
</rule>
<rule id="158878" level="8">
<if_sid>158877</if_sid>
<match>Trend Vision One Observed Attack Technique</match>
<description>Trend Vision One – Observed Attack Technique</description>
<group>trendmicro,attack_technique,</group>
</rule>
<rule id="158879" level="5">
<if_sid>158877</if_sid>
<match>Trend Vision One System Audit Log</match>
<description>Trend Vision One – System Audit Log</description>
<group>trendmicro,audit,</group>
</rule>
</group>
Ref: