


/var/ossec/etc/lists/maintenance_agents
Example:
user-ali
agent-02
agent-03
Rebuild the CDB
/var/ossec/bin/wazuh-cdb maintenance_agents maintenance_agents.cdb
Place the rule in your custom rules file:
/var/ossec/etc/rules/local_rules.xml <rule id="101509" level="9">
<if_group>windows|json|syslog</if_group>
<list field="hostname">etc/lists/maintenance_agents</list>
<description>Maintenance in Process - Agent: $(hostname)</description>
<options>no_full_log</options>
</rule>
Reference the CDB list as shown:
<list field="hostname">etc/lists/maintenance_agents</list>

Restart Wazuh Manager
systemctl restart wazuh-manager
Check Discover / Alerts in wazuh Dashboard to see triggered alerts like:
Maintenance in Process - Agent: user-ali
--
You received this message because you are subscribed to the Google Groups "Wazuh | Mailing List" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To view this discussion visit https://groups.google.com/d/msgid/wazuh/b5b23d15-eb1a-4c82-bc93-0c6d085252fdn%40googlegroups.com.
Hi Brenno,
There is no global "mute" switch in Wazuh. To silence alerts, your rule must be level 0. By default, Wazuh only generates alerts for rules level 3 and above (set in your ossec.conf), so your current level 4 rule is actually creating a new alert instead of hiding it.
Also, use agent.name instead of hostname to avoid common decoding issues
<rule id="100051" level="0">
<if_group>syslog|windows|linux|pci_dss</if_group>
<list field="agent.name" lookup="match_key">etc/lists/maintenancemode</list>
<description>Suppressing maintenance agents</description>
</rule>
Make sure your CDB keys match your agent names exactly and verify the fields using /var/ossec/bin/wazuh-logtest
your questions might be related to known issues #8269 and #4067.
To view this discussion visit https://groups.google.com/d/msgid/wazuh/f3954999-fdf0-499f-a534-7de78f874ec5n%40googlegroups.com.
<rule id="100051" level="0">
<list field="hostame" lookup="match_key">etc/lists/maintenancemode</list>
<description>Suppressing maintenance agents</description>
</rule>