Hello
Galymzhan,
I have reviewed your integration script and other details. I found no specific restriction that may block this specific alert from there.
However, as you are suspecting this to be related to no decoder matched for this log, I have created a custom decoder and rule for this specific log sample.
Decoder:
<decoder name="pfsense-custom">
<prematch>pfSense</prematch>
</decoder>
<decoder name="pfsense-custom-child">
<parent>pfsense-custom</parent>
<prematch offset="after_parent">sshd</prematch>
<regex offset="after_prematch">Authentication error for (\S+) from (\d+.\d+.\d+.\d+)</regex>
<order>user, srcip</order>
</decoder>
Rule:
<group name="authentication_failed,syslog,access_control,">
<rule id="220001" level="5">
<if_sid>2501</if_sid>
<decoded_as>pfsense-custom</decoded_as>
<match>Authentication error</match>
<description>SSH Authentication failed at pfSense.</description>
</rule>
</group>
Here is the logtest result after adding this custom decoder and rule:
You can use this decoder and rule and then test with some ssh failed attempts to trigger alert to check if the notifications are received at telegram end or not. If you want to make any changes in the custom decoder and rule, you can follow these official documents for that:
I hope it helps. Please let us know how it goes.