Hello
Spaugh!
Thank you for using Wazuh.
To suppress the rule ID: 2501 for agent_name1 and agent_name2, you can add a child rule with level 0 using the <hostname> tag.
To do so, add the following block in the /var/ossec/etc/rules/local_rules.xml file of the Wazuh manager:
<group name="syslog,access_control,suppresion,">
<rule id="150000" level="0">
<if_sid>2501</if_sid>
<hostname>agent_name1|agent_name2</hostname>
<description>Suppress User authentication failure on selected hosts</description>
</rule>
</group>
Replace agent_name1 and agent_name2 with the correct name of your Wazuh agents.
You can get additional information of this option
here
Let me know if you find this information helpful.
Best regards.