Hi Todor,
This seems to be a false positive match for rootcheck.
You can check this discussion for more information
https://github.com/ossec/ossec-hids/issues/2020
Check this document to learn more about how rootcheck works.
Can you check your rootkit check script
cat /var/ossec/etc/shared/default/rootkit_trojans.txt | grep diff
You can update your rootkit_trojans.txt at /var/ossec/etc/shared/default/
with this file.
https://github.com/ossec/ossec-hids/blob/master/src/rootcheck/db/rootkit_trojans.txt
Further, you can silence this by using a custom rule.
<rule id="730004" level="0">
<if_sid>510</if_sid>
<match>bin/mail$|bin/diff$</match>
<description>False-positive match for rootcheck regex</description>
</rule>
Check this document to learn more about custom rules.
https://documentation.wazuh.com/current/user-manual/ruleset/custom.html
Let me know if this solves your issue or if you need any further help.
It will be resolved in a future release, to be more specific in 4.10.0
https://github.com/wazuh/wazuh/issues/26137
At the end of the document, you will see the instruction given how to Ignoring false positives
https://documentation.wazuh.com/current/user-manual/capabilities/malware-detection/rootkits-behavior-detection.html#ignoring-false-positives
I hope you find this informations useful.