Hello Gabrielle!
It is possible to silence rules based on some field of the alert, like the source ip.
You need to create a child rule of the rule that you want to silence, set the level of this new rule to 0 and add the extra checks needed to match the events that you want to silence.
For example, let's say that the rule that is generating some noise is rule 5716 (this is an ssh authentication failure), and you don't want to generate an alert when the source ip is 192.168.0.3. Then you can create the following rule in
/var/ossec/etc/rules/local_rules.xml<group name="syslog,sshd,">
<rule id="100050" level="0">
<if_sid>5716</if_sid>
<srcip>192.168.0.3</srcip>
<description>Ignoring failed authentication from 192.168.0.3</description>
</rule>
</group>Every event that matches the rule id 5716 will be tested against this new rule, and if the srcip is 192.168.0.3 it will trigger this rule (100050), but since the alert level is 0 it will not generate an alert.
You can find more info about the rules syntax
here and about custom rules
here.
And rememeR to restart the manager after making any changes to the ruleset.
Of course, the new rule (or rules) must be tuned for your specific use case.
If you need further assistance with this please share some log event samples of the alerts that you want to prevent (remember to obfuscate any sensitive data).
Regards!